New Official Integration: Samsung Multiroom Audio

Thanks for the suggestions, however, as I reported earlier, I tried updating the automatic speaker firmware update and it bricked my speaker. Ugh. I did finally get it working by using the Sono’s speaker notify. I followed the directions to get the sonos software from https://www.youtube.com/watch?v=QOAAFnFUtPw.

So, I heard back from support and my issue is that speaker notify with sound is currently broken. I was concerned that was the case. Hence it not being available in the marketplace. I won’t be back at my machine until Friday but I will upload the email for everyone. In not sure if everyone has four d a way around this but apparently that’s my issue. Just thought it might help those trying to add it.

tts isn’t broken, I have a house full of it, running on Samsung and generic dlna devices.
you can use rule machine or big talker, both are working correctly right now.

I had mine working fine before I migrated to the V2 hub as well. I think if you already have it, it works. I don’t have native support in my smartapps list.

Any way that’s what I’m being told. Unless I’m reading something different I believe big talker has been deprecated. I was looking for native support anyway for for custom text.

an app that’s not published, can’t be depreciated…, so who’s telling you that big talker is depreciated?

anyway, by native support you mean what? an ST supported app?, that’s broken?
Seriously give big talker a try

I’ll give it a shot. Can’t hurt at this point as I don’t think the official smartapp is going to be fixed anytime soon. I am referring to the native support apparently they aren’t allowing anyone to pull the code from the marketplace for the ST supported Speaker notify with sound. I just pulled the BT from github but I won’t be able to give it a shot until this weekend. Thank you for your feedback. I had my wires crossed it was rule machine that had been abandoned. Not big talker.

Ok so when I added the code the smartapp shows in IDE but not on the app. Any ideas?

did you go to market place, smartapps, my apps and install it?

here’s a FAQ on the process:

1 Like

Mike, Thanks for you help. It’s setup, but won’t be able to test whether or not it’s working. I also pulled the Rule Machine Code from your github. I can’t believe I haven’t been using that! I don’t have a lot set up as of yet, But I’ll keep playing with it. I think I’ve been running into a some funky migration issues. IE: I log into IDE, install a smartapp or device type but ide thinks I’m not logged in. If I click on my location it prompts me to log in again, this is all within less than 5 minutes. That is why I wasn’t able to see the my apps section under marketplace. After I went to my location and logged in again and reinstalled the SA’s and Devices all was good. None the less thank you again,.

so as of this morning (possibly yesterday) my weather notify smart app is not working. haven’t dug into the log, but just so you all know… using a samsung m5, and has been working for months now without issue. maybe there is a problem again with tts?

Update: It worked again this morning. How are others going?!?

Brand new ST person here. I just bought 4 M7 speakers and I feel like I should have found this thread first. All I saw was official support on the master list and I got them at a pretty good deal. Do I need the Samsung multi-room hub in addition to the ST v2 hub? What kind of functionally in terms of multi room audio should I expect? Thanks!!!

what capabilities are you using with them as in what are you able to perform and what smartapp do you use?

You don’t need the multi room hub. I have 3 multi room speakers. Make sure they are running the latest firmware - SmartThings should pick them up. I have the hub but 1 of the 3 prefers a direct connection to the router rather than the hub…

Right now I’m using Big Talker. It annouced doors open, and presence.

Is your big talker running at the moment? I’m getting error messages saying it can’t announce anything at the moment.

No tts is having problems right now

Ahh ok good, thought for a second you was immune and I wanted what ever you had! Lol :slight_smile:

Thanks for letting me know. Did you find an option to push a URL to the speakers to play something instead of using TTS?

At the moment all I get is a short ‘beep’ when I try to use an action.

are the commands documented somewhere? I am trying to feed an URL to play on action but all I get is a beep … and an error that its the wrong command

groovy.lang.MissingMethodException: No signature of method: script1464218869902703960685.playSoundAndTrack() is applicable for argument types: (org.codehaus.groovy.runtime.GStringImpl) values: [“https://s3.amazonaws.com/smart-media/tts/you_are_now_in_home_mode.mp3”, 50]