New Mikrotik wired router, no zigbee connectivity

Installed a new Mikrotik wired router and placed current router in AP mode. The new router seems to somehow block zigbee communication—either from the app or cloud. I can verify that plugging the old router back in and changing back to router functionality resolves the issue. Was wondering if anyone else has had a similar issue and what may have resolved it. I can set firewall rules, etc., just don’t really want to enable UPnP.

I am using the RB750Gr3/hEX router.

Not directly related if it’s just a router without ap. If it has a wireless adapter built in and it operates on the same frequency as your ST ZigBee radio, that will cause issues.

The wifi router can’t in any way talk to ZigBee devices.

@amrobx
When you put in service your Mikrotik router and your current router in AP mode, the IP address pool changes to what Mikrotik has set up, which might be different from what your other router had. As such, your hub might not work unless you unplug it for a while and then plug it back in.
UPnP should not be a factor, but you can temporarily enable it.