New Iris Motion Sensor with Humidity Model IL071 Information [BETA DTH in post 2]

ST was spot on when it reported 1% for me because it died 2 days ago. Replaced the battery and it’s at 100%. It could be that I had a crappy battery, so we’ll see.

Sorry if I missed it but how long did it last? Couldn’t have been that long. My Iris sensors typically last at least a year.

Just 2 months. All my others (old versions) have been well over a year, or even close to 2.

1 Like

Just a heads up but Lowes website says they are shutting down this product. https://www.irisbylowes.com/?searchTerm=iris%20motion

Does the Zigbee Motion/Temp/Humidity Sensor have the intention to report in decimal format? Because it appears the previous IDE doesn’t nor the Zigbee Motion/Temp/Humidity Sensor. In the logs it displays .0 and the “Reccently” section of the app but the icon still displays as an int. It’s a iL07_1 model and I’ve unjoined/rejoined

Thank you

It uses SmartThings’ standard zigbee temperature parsing, which unfortunately doesn’t show decimals.

1 Like

@ johnconstantelo is your code as shown in your screen shot of your handwork in the app, still producing as decimal for iL07_1 Motion Sensor? What does the device handler look like?

Hi @g0fish, for temperature, yes it still should work. I haven’t used it since ST released their version, but there’s no reason why it shouldn’t still work.

I added this device as a Motion Sensor without any custom DTH. I see Motion sensior, Temperature, Humidity, and Battery as available triggers used in automation. Is there any need to install the custom DTH?

this thread is 2 years old and SmartThings now has a standard DTH for it, so no.

2 Likes

Thanks…noted.

1 Like

I just received one of these, and it was discovered as a Zigbee Motion/Temperature Humidity sensor. Is there a way to make it run local? If I try SmartSense motion, it doesn’t show proper battery. Any ideas? Also, why will it not show in Smart Home Monitor?

No, not without doing what you’ve already tried.

Not sure why, but all of mine are. I just added another one an hour ago, but that one doesn’t show up as available in STHM yet. I bet it’s a cache or backend platform sync thing issue. I’ll keep an eye on the new one to see when it shows up.

EDIT : The new one showed just now. All good here!

What DTH are you using?

The stock one : Zigbee Motion/Temp/Humidity Sensor

Yes I am using the same one. Mine still doesn’t show in Smart Home Monitor.

That’s weird. I’m not sure where to tell you to even start debugging that issue, sorry!

Yes this is strange.