New Hub (V3), can not add any of my appliances to the 'SmartThings' App

All, I am new to the group. I just purchased a new Hub (V3) and I can not add any of my appliances to the ‘SmartThings’ App. I get all the way to “Your Washer is being registerd to your Samsung account” and then it times out. I have all the Samsung appliances (Washer/Dryer/Frig, etc…) None of them will join the app, same results.

A bit more information:

I have Cisco network at home. All APs are in the same VLAN as the Hub. I am running my DHCP with the Cisco Router:

!
ip dhcp excluded-address 172.16.3.1 172.16.3.30
!
ip dhcp pool vlan30pool
import all
network 172.16.3.0 255.255.255.0
default-router 172.16.3.1

!
ip domain name honeypot.com
ip name-server 8.8.8.8
!
interface FastEthernet0
description ISP INTERFACE
ip address dhcp
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0
switchport trunk native vlan 10
switchport mode trunk
no ip address
!
interface GigabitEthernet1
switchport trunk native vlan 10
switchport mode trunk
no ip address
!
interface GigabitEthernet2
switchport trunk native vlan 10
switchport mode trunk
no ip address
!
interface GigabitEthernet3
switchport trunk native vlan 10
switchport mode trunk
no ip address
!
!
interface GigabitEthernet5
switchport access vlan 30
no ip address
!
interface Vlan30
description SECURED
ip address 172.16.3.1 255.255.255.0
ip nat inside
ip virtual-reassembly in

As mentioned, this was working, well the frig was working. Thus, why I upgraded to a newer Hub.

One more thing, when I check the logs in the router/DHCP server, I see:

HOUSE_SWR_00#
*Jan 3 14:31:55.014: DHCPD: client’s VPN is .
*Jan 3 14:31:55.014: DHCPD: No option 125
*Jan 3 14:31:55.014: DHCPD: DHCPREQUEST received from client 018c.861e.df24.d5.
*Jan 3 14:31:55.014: DHCPD: Option 125 not present in the msg.
*Jan 3 14:31:55.014: DHCPD: Appending system default domain
*Jan 3 14:31:55.014: DHCPD: Using hostname ‘Colbys-iPhone.honeypot.com.’ for dynamic update (from hostname option)
*Jan 3 14:31:55.014: DHCPD: Sending DHCPACK to client 018c.861e.df24.d5 (172.16.3.40).DHCPD: Setting only requested parameters

*Jan 3 14:31:55.014: DHCPD: Option 125 not present in the msg.
*Jan 3 14:31:55.014: DHCPD: no option 125
*Jan 3 14:31:55.014: DHCPD: src nbma addr as zero
*Jan 3 14:31:55.014: DHCPD: ARP entry exists (172.16.3.40, 8c86.1edf.24d5).
*Jan 3 14:31:55.014: DHCPD: unicasting BOOTREPLY to client 8c86.1edf.24d5 (172.16.3.40).
HOUSE_SWR_00#

YES I do have a firewall, all trafic is allowed out, I see no drops or deny packets.

Please Help!