New Hub - Hampton Bay Ceiling Fan

My dog managed to unplug my old v2 Hub and it would not come back when plugged back in. I purchased a new Aeotec ST hub to replace it, and now trying to get my old things working with it. Many connect and work - in fact some that had custom handlers work just fine on stock.

Separating the items into individual topics: Hampton Bay Z-Wave Ceiling Fan.

This one I expect is harder. I had the KingOfFans device handler on this in groovy. I was able to get this paired with my new hub as a dimmer - that only controls the light, not the fan. The KoF had a thing where you had to create a child device so it would do both.

Is there a new Edge driver for this device?

Apparently it is Zigbee not Z-Wave

Hmm - I found it on @philh30 driver channel.

Now let’s see if it works!

Stop blaming the dog!! :laughing: :sunglasses:


It was totally him though! He likes to roll his ball under things that make us go get it for him, he rolled it under the entertainment console and started scrambling and pulled all the cables out! The v2 hub never worked again.

Lost the previous v2 hub in a power outage in a storm.

Anyway - results from the KoF driver. It has a parent device and two children, Fan and Light, and I can control the fan and light from the ST app. BUT - Alexa integration does not work the same as it did.

With the old device handler it would create two devices that each were addressable by Alexa. Old way, parent named Master, it would create Master Light and Master Fan (or whatever you named them) and you could tell Alexa to control each of them. Now, in ST, there is a device Master, and it has two children, Fan and Light and they cannot be renamed. And the fan is the one that Alexa controls. If you say Alexa turn on Master it will turn on the fan. If you ask to turn on Fan, it will ask do you mean Master? If you say turn on Light it says okay but does nothing.

You need to link the light to a virtual switch if you want Alexa control.

Probably the best option is @Mariano_Colmenarejo “virtual mirror switch” with is part of his “Aplicaciones Virtuales Mc” driver.

I have the drivers for virtual devices, not sure how to “link the light” to it.

Is that by routine? ie have a routine that says if virtual switch is on, set light to on?

Here is the problem with that - if I go to routines for the KoF device it allows me to select in the IF condition either fan or light. However, for the Then condition, it only allows me to select the fan.

Yes you would link it using multiple routines. @Mariano_Colmenarejo had the directs in his thread.

Show up a screen shot of the routine problem you are referring to.

Okay a little RTFM. Read the KoF thread from @philh30 and there is a setting to create a separate device for the light. Turned that on, created the light separately, and now Alexa is in control!