SmartThings Community

New Fibaro wall plug


#1

Hi all

I am completely new to this and just bought my hub, some motion sensors and fibaro wall plugs whish is the new model with zwave plus.

I have no issues installing them but they do not show watt consumption, total watt consumption and the on/off colouring doesnt work. It can be green when it is turned on and vice versa.

Anyone else with these issues and anyone with a solution?

Thanks for advicing


(Robin) #2

Are you familiar with installing custom device handlers in the ST online IDE?

The following thread appears to contain the custom code you need:


#3

Hi Robin

Thanks for your reply. I have had Smartthings for like two weeks and I must say that all these new terminologies are completely new to me. Routines, scenes, smartapps, CoRE, device handler etc. Sorry, I dont even know what a device handler is…

I am actually browsing the community now but it is quite overwhelming all info here.

Any tips for a beginner thread?


(Robin) #4

This is the point where @JDRoberts normally posts links to a bunch of useful threads / FAQ’s… Nudge nudge :sunglasses:

If you ping me a reminder later (in going out for Dinner now) I’ll guide you through setting up a custom device handler and assigning it to your device… It’s simple once you have done it once or twice but not at all intuitive for a newbie!!

ST can certainly be a bit overwhelming at first!!!


#5

Welcome! :sunglasses:

The following might help:


(Anders) #6

Hi Fredde,

Read up on the stuff posted here to figure out the terminology.

When you have done that: the new Fibaro Wall Plug needs an updated device handler. Check out the thread posted above about the release of the Fibaro Wall plug. That thread is for the older version, but I’ve posted a link to a really early version for the new plug at the bottom.

I just got it working yesterday, but everything looks fine. I’ll continue to test it the next days and fix any errors I find.


#7

Hi Anders

Thanks. I found it and added it a new device handler. What i do not understand is if i should create a smart app as well? I tried, but then i get an error message…

I have then excluded my wall plug and tried to understand how to add my wall plug with this new code but that i do not understand. I cant see the device handler in my app so i guess i am missing something here…

Thanks for any advice

Br
Fredrik


(Anders) #8

Hi Fredde,

The fingerprint stuff is not correct in this one so it won’t auotmatically tie it to the device. I havn’t had enough time to understand how that works. :slight_smile: I’m not sure Smartthings will automatically choose custom device handlers, maybe someone else knows?

But basically: Add the device (mobile app), add the device handler (web interface), edit the device to the new device handler (web interface).

It’s the type field (when you edit the device) that needs to change to the new device handler. Your custom device handlers will be listed at the bottom of the list when changing the type.

You don’t need a smart app to achieve a working device. That is only if you’re thinking about having some automation or rules tied to it. After adding the device handler and changing the device type it shows up in the mobile app with on/off and measurements.

Anders,


#9

Hi Anders

One of my issues here was that my location and hub was missing in the web interface. I managed to het it back after a couple of hours searching for a solution.

Now i have added your device handler to all my (5) wall plugs and so far, all is working well. I will check for some days now

Thansk again for your help and support and pf course for the decice handler

Best
Fredrik


(Robin) #10

I imagine you were logging into the wrong online shard. There is one address for US and another for UK.

UK:
https://graph-eu01-euwest1.api.smartthings.com/

US
https://graph.api.smartthings.com/

If you log into the wrong shard you see blank lists. You can then get pushed back into the correct shard by clicking your home location under ‘location’.


(Anders) #12

The working device handler for Firbaro Wall Plug ZW5 can be found here: [ABANDONED] Fibaro Wall Plug ZW5


(Valentino Baccolini) #13

Hi, I m in you situation(fibaro smart plug are not regonized) . From Web smartthings page i login, I find the device and I choose another type. Unfortunately I don’t find fibaro smart plug, so I find aeon smart energy meter. With this I can see the watt, and switch off /on the plug. Someone have a better solution?


(Robin) #14

The Fibaro Wall Plug is not a default item on the ‘type’ list in the IDE… you need to add a custom device handler, which will add the device to the bottom of the ‘type’ list.

This is currently the best handler i know of:

And this is how to install custom code:


[RELEASE] Fibaro Wall Plug ZW5 (Z-Wave+) DTH