New Fibaro switches FGS-213/223

I see that my FGS-223 was not included in secure mode, will try to get it included in secure mode and let you know if my issue was resolved.
Thanks for the great DH.

Thanks @erocm1231 and @RobinWinbourne.

@erocm1231 here is the raw descriptions from the device:
zw:L type:1001 mfr:010F prod:0203 model:1000 ver:3.02 zwv:4.05 lib:03 cc:5E,86,72,25,5A,59,85,73,56,70,32,8E,60,22,75,71,98,7A,5B ccOut:26 role:05 ff:8700 ui:8700 epc:2 ep:[‘EEEE EE’]

I’m unable to add the device in secure mode, is there anyway I can force it?
What is the best way to exclude / reset the FGS-223? Currently I’m doing this:

  1. Switch mains off
  2. Press button and hold button B
  3. Switch mains back on
  4. Wait for LED to change
  5. Release button “B”
  6. Switch mains off and on again.

Regards

That is not in secure mode. See where the raw description shows zw:L. You need to have zw:Ls.

I had this same issue when I included the device too far away from the hub. You need to exclude the device and then bring the device and hub together and include again. Once you have the Ls showing you can move the device anywhere and do a z-wave repair to update the routing tables. You should also be able to configure it without any errors.

To exclude it you need to set the hub in general exclusion mode and hit the B button 3 times same as for include. Use the app to set general exclusion. Go to more, click on hub is online and then go to the Z-wave utilities.

You can also try this handler:

https://pastebin.com/EU9qWeUJ

I have modified it to detect whether the switch was included secure or not and use the appropriate commands. I haven’t tested it yet so let me know if you do.

Once tested, I can replace the version in github.

1 Like

Thank you very much, the new DH works perfectly.

1 Like

Hi @erocm1231 , please help.

I connected 223 but to control only 1 light. Have v3 hub, new app and paired it OK. Manual switching works fine - so I guess it means I connected everything fine. Installed Eric’s DHs: Fibaro Double Switch 2 FGS-223 and metering device.
App created Fibaro double switch 2 shortcut and two other S1 and S2 shortcuts.

I cannot get it working! Simply nothing happens when I try to turn ON. :frowning:

Thanks!

Anyone? :confused:

Hi Ivan,
Make sure it is using the right device controller.

Hi @noamleshem,

I took the one from Eric, is there some other available? Here is what I have in my IDE:

1

Is this OK?

Check that you are using Eric’s controller under type. it will at the bottom of the list and not alphabetical

@noamleshem,

I this OK to have these devices listed here:

A parent and then 2 devices with the type - Metering switch?

Parent is Eric’s DH:

4

Any errors showing up in the live logs when you try to toggle the device via the app?

Also, please post a screenshot of the device settings page (the page that shows when you click on the device name in the IDE)

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.