SmartThings Community

New Fibaro switches FGS-213/223


(Marco) #168

Compatibily problems between Smartthings Hub (I have V2) and Fibaro products.
For example, yesterday I add my first Fibaro sensor (motion sensor). I have it in my hand, not on the wall. And in the Smartthings app says it is “tampered”.
I connect it for two times and I create an automation (notify me when…).
I read all Fibaro switch for lights and rollers shutter have problems to connect to the Hub.
Is it correct or no?


(Eric M) #169

I have not had any problems connecting Fibaro devices to SmartThings. I haven’t had any problems with functionality either.


(Marco) #170

Ok. In this discussion I read some problems at first.
So I need only to find the dimmer on the app and all works?


(Simon) #171

I have had zero problem with my Fibaro modules. In fact they are the most reliable part of my system. I had one minor issue with the Fibaro smoke detector that Smarthings fixed with an update.


(Marco) #172

Ok.
In this topic I read some people has problems and they set Hub in a mode for work with Fibaro.
Probably it was an old problem.


(Robin) #173

That just sounds like people not used to using custom device handlers.

This should clear up those concerns:


(Marco) #174

I’m sorry I don’t speak a good english…


(Noam Leshem) #175

hi and thank you for all your work in the community.

i installed the double switch fgs-223 to control my irrigation system. it was working well until i had to reset my hub and trying to pair it again it blow(user error) i got a new one and can’t get it to work. the main relay doesn’t change from on to off and S1 and S2 hang on “turning on” or “turning off”. after power restart it will suddenly switch on the taps but still show as off.

what am i doing wrong?


(Eric M) #176

It sounds like the association group isn’t getting set correctly. Can you try hitting the “Configure” tile a couple of times?


(Noam Leshem) #177

Thanks for your help. I tried hitting the configure a few times but it
didn’t do anything. It has a orange dot on it.

using your SmartApp the Detected Number of Endpoints: 0 and create virtual device is greyed out.


#178

Hi

reaching out for help for some strange behaviour of the Fibaro Double relay. im using the FGS 223 DTH and its working very well.

what i noticed today is that whenever I turn on an Aeon Labs MultiSensor 6, the Fibaro Double Z-Wave Device Multichannel starts to flash the lights !!! This is strange as I don’t have any rule configured that relates these 2 devices !

Any help or thoughts on what should I look for to unlock this strange device behaviour ?

F


(Robin) #179

The 223 is not a relay, it’s a switch :sunglasses:

Unexpected flashing on Fibaro modules is normally related to general alarm frames being sent across the mesh. Try changing parameter 40 to 0 so that alarm frames get ignored.

Also parameter 42 defaults to flashing when detecting a Co / smoke alarm frames, so for good measure, change that to 0 as well.


#180

thx Robin for your prompt reply
yes it’s a switch and I’m using it as such . … my bad

params 40 and 42 were already at 0. I tried changing 43 and 31 , 33 to 0
but nothing worked. still same, whenever I tamper the motion sensor , it starts flashing … although I have no rule for that in SM


(Robin) #181

You might have somehow setup association with the motion sensor???

You could use the zwave tweaker device handler to scan current associations.

Or you could just turn off association groups 2-4 in the preferences (depending on the handler you are using?)


#182

I’ve never defined any association in the device itself niether for this motion sensor nor others
I’m using Fibaro Double Switch 2 FGS-223 DH

I tried to look for params in relation to associations but no luck …

This is very strange and random which worries me …

I’m thinking if removing the sensor than adding it again might help ? the thing is that I’m worried if there other unwanted device associations

Thx for the help !
Fab


(Robin) #183

Can you link to the actual handler code please… there are a few floating about for this device?


#184

Thx Robin, i don’t have the link to the source code but can copy and email it or add it here if that helps

This is the header section:

/**

  • Note: This handler requires the “Metering Switch Child Device” to be installed.
  • Copyright 2016 Eric Maycock
  • Licensed under the Apache License, Version 2.0 (the “License”); you may not use this file except
  • in compliance with the License. You may obtain a copy of the License at:
  •  http://www.apache.org/licenses/LICENSE-2.0
    
  • Unless required by applicable law or agreed to in writing, software distributed under the License is distributed
  • on an “AS IS” BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License
  • for the specific language governing permissions and limitations under the License.
  • Fibaro FGS-223 Dual Relay
  • Author: Eric Maycock (erocm123)
  • 04/25/2017 - Fix for combined energy & power reports & switch endpoints showing correct info.
  • 04/18/2017 - This handler requires the Metering Switch Child device to create the multiple switch endpoints.
    */

Fab


#185

following up on this thread
Any advise you can help me with!?

I have a 2nd of those fibaro double switches that i want to install, but now waiting to understand what’s going on with this issue below before geting the 2nd installed to avoid any unexpected network behaviour

Really appreciate any help @RobinWinbourne @erocm1231

Fab


(Simon) #186

FWIW, I have a number of FGS-223 installed using the device handler you show above and I don’t see these issues. I don’t have the Aeon Multi-sensor 6, but I do have some Fibaro smoke detectors. Perhaps its time to start looking at what the Aeon is doing to trigger this. Maybe some adjustments are needed to the DH for that. What do you see in the logs for the Aeon when its turned on?


#187

Thx Simon, below is the log from the aeon multi sensor … but frankly despite any wrong behaviour of the Aeon , why would the fibaro switch react to that by flashing the lights !

Fab