New devices certified from Leviton and Kwikset! ZigBee lock support! Oct 19, 2015

Spent evening messing with the locks again. I called Kwikset support and we determined the reason exclusion/inclusion was not working was radio was bad. I had purchased 2 916 locks from Amazon Marketplace and both turned out to be bad. The 914 which I purchased direct from Amazon is working fine so far.

Hey @Tyler, the link you put for Kwikset 910 is actually for the touchpad version not the touchscreen… Is the touchpad version also compatible with ST? Because i’m planning to get one…

Yes, we’re compatible with the ZigBee Kwikset 910 Touchpad.

my lock worked again for a while and has now stopped - hasn’t worked for about 3 days - it is not even showing handed turns. Battery’s ’ say 80% and the pin function and lock function manually works fine - plenty of power on the motor.

Anyone else seeing similar issues again? i have not re added it just yet… quite annoying having to do it so often.

my smartthings setup seems to be stable for about a month then i have to spend an hour re jigging. - don’t get me wrong - love it, but it’s getting on my nerves with a few other issues i’m having.

Edit: was just about to remove and readd device but it started working again… hmm

Hi @Tyler , did you ever get an official answer to whether or not the ZBC4 models of the Kwikset 910 are fully supported?


No, we’re not compatible with the C4 models.

hi @Tyler, is the Kwikset SmartcCode 914 Zigbee version compatible with UK ST hub? If not by default, can it get to work through a custom devices type/handler? Thanks!

Yeah it should work! We’re not doing anything in our cloud that would prevent you from pairing that device to a UK hub,

Tyler how about support for programming remote user codes in the Device Handler for ZigBee like Z-Wave locks?

1 Like

It’s coming! Hopefully before the end of March.

1 Like

hey Tyler - any update on this at all? I just shot a note to smartthings support.

i’m guessing no reply means no update. :frowning:

Just purchased a couple of the 910 model 450191 deadbolts and can get it to pair with ST just fine. However, I can not get the device to open or close using ST. I’ve tried setting up/removing several times including deleting directly from the IDE. I’ve also rebooted the hub just to be sure. Any suggestions before I return them?

Note also that when I hit the device from my things menu on the android app, the red light on the lock flashes. However, the lock doesn’t open/close or change status, just shows perpetually as “unlocking”

I’ve found with my lock, that it paired fine but would not update or respond to lock commands in one of two cases. The hub or closest ZigBee repeater is too far away or the batteries are not fully charged. I added a repeater about 4’ away and replaced the included batteries with name brand ones (My Yale lock included batteries that were poor). Haven’t had a problem since.

Only other thing to say is make sure that your 910 is the HA 1.2 version and not Control4, though I don’t think the Control4 versions would even pair.

Thanks for the information. The lock is less than 18 inches away from two zwave light switches that are also repeaters so connectivity shouldn’t be an issue. Since I ordered two devices, I tried the second one and that one worked perfectly so I suspect that I have some type of defective device. Back to Amazon for a replacement.

Almost a year any news yet?

I don’t think zigbee support is coming. I am going to go ahead and buy the zwave module for the lock…this will guarantee the zigbee release soon :slight_smile:

I’ve been using a Yale ZigBee YRD240 with no issues for months. In fact I have written a DTH with lock codes to work with lock managers. See below:

Thanks…just in time! I was about to start looking on Amazon.