New App: Vacation Light Director

This is a great App to assist in home security! I was wondering if it would be possible to add an option to turn lights (On) at a Dimmer percentage other than 100%?

1 Like

Greetings all,

Having some trouble with setting up VLD. Looking to use one instance in the morning and one in the evening. I can’t seem to get it to run. Ever. Here is a log of my most recent test.

8fda7e2a-fe3a-4300-99d6-11de808bb3e7 12:21:00 PM: debug mode OK. Running again
8fda7e2a-fe3a-4300-99d6-11de808bb3e7 12:21:00 PM: trace modeOk = true
8fda7e2a-fe3a-4300-99d6-11de808bb3e7 12:21:00 PM: trace timeOk = false
8fda7e2a-fe3a-4300-99d6-11de808bb3e7 12:21:00 PM: trace timeWindowStop = Sat Oct 21 19:44:00 UTC 2017
8fda7e2a-fe3a-4300-99d6-11de808bb3e7 12:21:00 PM: trace timeWindowStart = Sat Oct 21 17:20:00 UTC 2017
8fda7e2a-fe3a-4300-99d6-11de808bb3e7 12:21:00 PM: trace daysOk = true
8fda7e2a-fe3a-4300-99d6-11de808bb3e7 12:21:00 PM: trace modeOk = true
8fda7e2a-fe3a-4300-99d6-11de808bb3e7 12:18:34 PM: debug Installed with settings: [startTimeType:time, falseAlarmThreshold:1, people:[A, S], switches:[Kitchen Light, Dining Room Light], endTimeType:time, ending:2017-10-21T14:44:00.000-0400, starting:2017-10-21T12:20:00.000-0400, frequency_minutes:2, newMode:[Away], days:[Monday, Tuesday, Wednesday, Thursday, Friday, Saturday, Sunday], number_of_active_lights:1]

It seems like timeOk = false is the problem, but I don’t see why. Log time is 12:21, which is the turn on time for the app… 12:21 + 5 hours to UTC = 1721. Can anyone see what I’m missing?

Thanks for the help.


Are you using the one from the marketplace or the one that’s self install? I was never able to get the marketplace one to work solidly but the self install one has been fine.

@farlicimo, Thanks! I’m using the one from Automation>SmartApps>Add a SmartApp>Lights & Switches>Vacation Lighting Director, on the android app. I’m not familiar with the self install process yet, but will take a look.

Check this out. I only skimmed it but looks like it covers the process pretty well.


@farlicimo thanks for the guide and the redirect to custom code. I’ve got it working.

The most recent version (published September 2016) works great. It doesn’t let you offset from sunset or sunrise which is a feature I like. So I tried the second most recent version and couldn’t make it work. I went back to the most recent version and it continues to work great after two “production” runs.

Here’s the cliff notes of what I did to set it up for any interested nubes like me - insert standard guide written by a nube disclaimer here - your mileage may vary…

To use custom code from the wonderful folks who publish their work free on Github:

  1. Get a free Github account.
  2. Link your git hub account on the IDE My Smart Apps page with the button on the top right - follow sites directions to fork the Smartthings Repository on Github.
  3. Do an update from repository with the button on the My Smart Apps page.
  4. Use the New Smart App button on the My Smart Apps page to create the smart app. You can use the “from templates function” to access many templates (from Github?). I couldn’t load the template for VLD so I searched within the Github site to find the code and then copied and pasted the it directly using the “From Code” creation option. I’m sure there is a better way, since this probably breaks the updates, but it worked.
  5. Publish it with the button on the My Smart Apps page. My only publish option was “for me” which put it on my phone’s SmartThings app under the Add A Smart App > My Apps option at the very bottom of the list. Ready to configure and run.

Thanks again to all for the great app and the help getting up and running.

Glad it worked. I think I’m running version .2 and have the offset option. It’s a separate line from where you choose the time. I don’t use the offset though.

Would you please add the ability to turn on to a light level? Looking to use this all night and thought it would save some energy to lower brightness.

1 Like

Has this stopped working for anyone else? Been working well for months and seems to have just stopped. Went to see if I needed to update code and link to GIT appears to be broken?

EDIT: Is there a way to trace what the code is doing when it tries to execute ala webCore? I think I have it configured right but maybe I am doing something wrong and can see where it says X=Y is false and alert me to where I have run afoul. I did just replace a bunch of bulbs which this uses so maybe it has something to do with that?

It has been working for me. Github is there fine.

You might want to re-configure the settings, and “done” your way out. If you removed devices (in addition to adding devices), and did not clear the settings of VLD before you did, you might have to remove and re-install. Removing devices without cleaning up apps using the devices can cause problems in ST apps.

1 Like

Pretty sure I removed first, but it was a lot of juggling apps since I was replacing some items so I could have missed. You are suggesting I remove the app entirely and re-install right? I’ll give that a try. What link are you using for Git? I am using the one at the top and getting a 404 not found.

EDIT: Removed my link because it was just a replica of the bad one at the top and noticed people trying to use it.

That could well be broken. I did an update on VLD.

Thanks, that link worked. Will give it a try.

Uninstalled everything and reinstalled and working like a charm now. Thanks.

Are you asking how to install the app or how to configure?

Yes, that’s how I have found it to behave. People have found that the Marketplace version has issues. If it works for you great, but it seems most end up installing from the custom code in this thread.

Hello world

What I found. . .and seen others note. . .is that when it doesn’t work it generally just does nothing. Not some sort of weird half working behaviour, but just doesn’t do anything. To install you basically follow the same method you did you install webCore. The code link is at the top of this thread. Allen wrote up the steps he followed in response to a post I linked about creating custom code. Either one should be useful.

Today I noticed that this is turning off lights outside the time I have set and none of the other things are being met. not sure why.

Just copied the github source code to my graph.api apps, seemed the easiest way to do it to see if it works – so…

How can I see if it’s working? Any easy way to test? Set away and see what happens?