New App: Vacation Light Director

Eric, is there a way you can have a modified smart app name for your version. I think some folks are having a bit of confusion on whether they are using Tim’s or your version.
In addition i would love to try your smartapp but not have to remove Tim’s from my setup.
For example, I use Tim’s delay when I am “away” and it seems to work fine. Where it fails is when I go on vacation and a few days pass, then the app stops working (have we ever identified why this happens?) So I would love to use his App in “away” mode and yours in “vacation” mode. So I would like to have different identifiable instances of VLD in my system. Can this currently be done with your version?

Thanks in advance!!

Has this started working for you again? :slight_smile:

Hi, I have started using this app couple of weeks ago.
It works well however it puts an entry in the activity log every minute, on each of the devices it controls.
Is there a way to minimize the log to show only the real on/off?

So that’s what was doing that!! I was away for 2 weeks and noticed every minute all these new meaningless entries and wondered what I had done!!

WOW what a cluster … installed the ST smartapp it didn’t work. i removed and install the 2.4 version on GitHub. After correcting a few commas in the code I was able to publish and authorize. I tried to start the app on phone and get “You are not authorized to perform the required operation”. But that’s not all - I am unable to delete from IDE - “This SmartApp can’t be deleted at this time because it is installed by one or more users”. AND there more - now I have 19 count em instances of Vacation Lighting Director on the phone SmartThing SmartApps.

HELP!

not sure what the 2.4 version you are referring to is. Sounds like an old version of tslagle’s ?

I suggest you consider this one:

On a couple occasions i have checked in on my house to find all simulated lights in off state. Is anybody else seeing this happen? I am running Eric’s version with settings configured to maintain 2 active lights.

I have not seen this. ST platform had some issues last week, so it is possible the platform issues stopped things.

If you have IDE logs, post them as a private message.

I have setup my vacation light director to turn on and off lights when away till 11PM. But I see that all lights are turned off by 10PM. I am in the UK. Is this a bug?

If you are using the version I posted, please check your timezone information (location) are set correctly in SmartThings mobile app.

If you still have the issue send me some IDE logs via a private message.

I have checked my location information and seems accurate as below. I am in the UK.

Below are the logs. I just scheduled it to run from 2:30PM till 3:35 PM. It started at 2:30PM as expected, but stopped at 2:35PM instead of 3:35PM.

03a9333c-8754-4c99-ac1c-5843d5e9a4ab 14:36:07: trace All OFF
03a9333c-8754-4c99-ac1c-5843d5e9a4ab 14:36:06: debug wrong time - Stopping Vacation Lights
03a9333c-8754-4c99-ac1c-5843d5e9a4ab 14:32:01: trace turned on Landing 1
03a9333c-8754-4c99-ac1c-5843d5e9a4ab 14:32:01: trace turned on Dining Room
03a9333c-8754-4c99-ac1c-5843d5e9a4ab 14:32:00: trace inactive switches: 4 numlight: 2
03a9333c-8754-4c99-ac1c-5843d5e9a4ab 14:32:00: debug Running

hmm does your area have daylight savings time?

Did you recently switch, or are you soon to switch?

I wonder if ST has incorrect data for this…

You may want to check with ST support.

I’ll look at the code, but I don’t think I have control over this.

Our DST switched recently about a month ago.

Daylight saving time 2017 in United Kingdom began at 01:00 on
Sunday, 26 March
and ends at 02:00 on
Sunday, 29 October

I will raise with ST Support.

I looked at the code and it seems correct. Please ensure you are running the latest code, I cleaned up a couple of things, but did not find a smoking gun.

If you continue to have problems we can turn on more debug statements

Thanks for the update. I have raised a ticket with samsung and also updated to the latest code. Will check if this resolved the issue.

Thanks for providing this app which works nicely. I’m having a problem with the 3 lights I have it controlling turning on after my hub loses then regains the internet connection. Both times it’s happened in the morning when Vacation Director isn’t active and I have confirmed that all 3 were off the night before at the appropriate time based on the app settings.

Has anyone else seen this? Is there some routine I need to run when the hub regains the connection?

I have not see this behavior (from vacation light director).

This could be the lights themselves (i.e. not vacation light director)

They are all Cree Connected bulbs. Maybe I’ll add a light controlled by a GE Smart Switch to see if it turns on too,

thx

Another thing to keep in mind is if vacation light director is running/operating, and you come home, it does not turn off the lights that are on (under the theory you don’t want to walk in the house and have the lights go off).

If it is running, and its end time/mode happens, it will turn off the lights it has on.

I don’t see a simple way to turn this on or off. Let’s say we have it on using two presence sensors, but we have family staying with us for a few days. They do not have presence sensors and the two of us that do leave. I wouldn’t want lights randomly turning on and off on them. Is there an easy way to turn on/off the automation?

Also…If I install Eric’s version from IDE and it gets updated, how would l know to update mine, and would I just have to copy and paste the new code over?

Also, reading the comments above, when you add a Smart App, it says you have to hit publish after you copy and paste the code. Is that the same for device handlers? I have installed two device handlers, but I only hit save and not publish. Am I supposed to hit publish on device handlers too?

My device handlers appear to work just fine showing “unpublished”. Should I go in and publish them to me?