New App: Control lighting in great detail with button devices (Aeon Minimote, Enerwave ZWN-SC7)

If anyone is interested I have updated this app to support a “toggle” function. Just FYI.

Eric, you, sir, are amazing! This app was exactly what I was looking for to control my Hue lights. Thank you!

1 Like

Glad you like it. :slightly_smiling:

This question is hopefully very basic, but almost slightly embarrassing, but here I go.

I installed this smart app because I’m pretty sure it’s exactly what I’m looking for. Got the smartapp installed without issue but when I got to set it up from mobile, it gets to the section (which is first setup screen) It says to select a button, push that, and there is no button to choose.

I looked closer at screen shots and noticed the Aeon Labs Minimote, so I went to device handlers and installed the Minimote. I’ve published both “for me” and still no choice for button.

What am I missing?

Well, I’m an idiot and believe i’ve discovered the minimote must be a physical device. I had never heard of it, so that’s where my confusion came from. I’m looking for something to just control many lights “on / off / dimmer” for several lights (zigbee in this case) but really does something like this exist?

you want a virtual switch/dimmer to do that

So, I’m a little confused. This app is for physical devices with buttons to control the lighting. Are you thinking about using the SmartThings App to easily activate different lights? One workaround might be to create a device in the IDE and assign it the handler in this thread:

You should be able to set my SmartApp up using the newly created device as the Button Device, and then press the buttons from the device in the SmartThings app to activate the scenes. Just a theory, but it should work.


@erocm1231 Thanks for the useful app! I have been using this for a couple months now without any problems with a v1 Hue bridge. There has never been a difference (for me) in the warm white and soft white colors, but it’s been close to the expected color.

Within the last two weeks, these colors have changed to a light green. Have you noticed any change on your end? Being more of a hardware guy and not a programmer, I looked at the code and could not see what to tweak. Not sure what “hueColor = 23” was referencing.

Any ideas?

I have noticed this too. Thanks for reporting this as it gives me a good idea of where to troubleshoot. I’ll take a look to see what is going on.

1 Like

Alright, it seems that SmartThings must have done something to the Hue Device Handler. I think I have it fixed. The updated code is in the github.

1 Like

OK, thanks! I’ll give it a try in the next day or two and report back. I almost scared to change anything with all the other crap happening in the system :worried: I don’t think your handler is affected though.

OK, I had a couple cocktails and decided to give it a try, it works :grin: back to the origional colors, I will do some more testing with the whites.

I understand the need for some to check state for on, but not sure that I like it. I have one Minimote for Hue scenes and button 4 hold is to turn all off. I used to be able to switch between colors, now it goes dark in between scenes. Just a thought…

Yeah, I have been thinking about that as well. The problem is that it works well in some situations and doesn’t in others. For my Philips Hue stuff I just disable toggle on all the “scenes”. So I have button 1 set them to some colors, button 2 some other colors, etc. I then have button 4 (held) turn all the lights off (like you do). Did you use the toggle the way it was set up before? The way it used to be setup was you had to press the same button twice in a row and it didn’t do any checking the state of the lights before toggling. The problem with this was that if the lights were on (because some other automation turned them on), and you hit the button expecting to turn them off, they wouldn’t do anything until you pressed the button again.

Turning off the toggle should work for me too. I forgot it was there, thanks again for the support!

I have a little visual issue running on IOS…and I cannot get the app to show up under Smartapps section of the IOS app…I can see it when I go into smartapps for the bulb that I am controlling…and in the IDE, under location/installed smartapps, it lists the name I gave (Button Colors) but with (dev) after it. Any ideas?

The visual issue is with the number of buttons…the numbers are blank…so I just counted down to 7…but the “7” does not show up on the main page…still shows blank (yet everything works, except it showing up in my Smartapps list in the app). Any ideas?



The number of button display problem is only on my iPad - my Android device it works fine…so I’m sure it is an IOS issue, not the smartapp…

I was able to get the “Button Colors” app to show up in my smartapps list and get the "dev " to go away, by unchecking the “Enable Local Child App Discovery” box in the smartapp in the IDE…although when I just went back in to grab a screenshot, it was checked again…

Anyway - Thank you @erocm1231 for this app - it is working great for me.


Thanks for bringing the iOS quirks to my attention. I really need to get an iOS device for testing, but Apple=$$$. :wink:

This is exactly what I needed in order to get more granular control over my Aeon minimote!

But, I must be missing something. I set the remote to control, chose a light (tried LIFX and my Cree bulbs) and once I go to “Next Page” to configure the options, all that I see is the option to turn the light on or off. Should configuration options like level, color, etc. be on that page also? Or am I missing something? Maybe just an issue on Windows (mobile).

Strange, looks to be a Windows App thing. This is how it should perform:

Yep, feared that it may be specific to the Windows platform. I may be getting a cheap Android tablet for certain other small configuration naggles.