New app and multiple locations... is it possible?

@BlueJacket, just to confirm my setup - I have 2 locations on my system (Home and Home2) and one Hub=Home Hub. I use Home as my live location for both Classic and New (the New App doesnt actually see Home2). All of my devices are configured as Location=Home and Hub=Home Hub. All SmartApps are in both locations. All still working OK. Hope this helps.

@Brad_ST
Ticket#sconnect19032100862

Received email today that the incident was resolved. Called support, support do not have a way to move devices between locations.

Sorry to hear about that experience!

The frontline support is not able to resolve the issue directly but should be able to escalate to someone who can. If this wasn’t offered, please email support@smartthings.com and let them know your devices on the wrong location.

Big problems here. Have emailed support and it has been weeks with no resolution.
New app shows no locations, no hubs, no devices.
Old app shows 2 locations, one of which is correct. The other has an old robot vaccum i used a few years ago.

In the IDE, I have 2 locations, both of which are default and cannot be deleted. Under the accounts dropdown in the IDE, I have 2 duplicate accounts, instead of just one.

What is going on here?

You may be able to set one location as the default and then remove the bad location…

Go to #2 in the first post of this thread.

1 Like

No dice. All locations are read-only default.

Did you use an incognito/private tab when logging into IDE?

Nope, but just tried. Both locations still set as default and can’t be changed.

@Brad_ST I’m having this issue as well - ticket 879737. Can you have a look? I have a location named “Delete Me” which in the app still lists the hub and one switch, and another location named “Home 1” that has all my other devices. Obviously I’d like the hub and one device pushed to “Home 1” and “Delete Me” deleted. I posted here following the specific directions at the end of this post:

Do you see the Delete Me location in the app? Are you able to delete it there?

1 Like

@Brad_ST woah I didn’t even know you could delete locations in the app. It worked, but now my hub (which was one of 2 devices on that other location) is now showing offline in the app. However it seems to be functioning normally otherwise. Is there anything I should be concerned about with respect to that?

Thank you for the help :slight_smile:

Nevermind, rebooting the hub seems to have fixed that. I’m good now. Thanks!

1 Like

Need Help ASAP, after the migration all my devices are mixed up between my two locations. I currently have 2 hubs, one at my personal residence and one at our church. After the migration many of my home devices are showing at the church. Many are my leak detectors and even my alarm (siren). With this being the case it seems as none of my Automations/Scenes or routines are working correctly. Im afraid I may have a leak or a door entry while Im not home and either not get notified or my automations wont shut the water valve off to my house. How do I fix this @Brad_ST

1 Like

Hi @Brad_ST

Similar problem here. I have had two locations for a while but it never bothered me. Now with the new app this has come back to kick me in the butt so I am trying to rebuild.

At the moment I have two locations:

Location 1, which is my default lcoation with all my devices in it that (for some reason) has no hub associated with it in the IDE

Location 2 “home”, which has my hub associated with it, is NOT the default location, and which I cannot delete manually because I get an error message.

Could you have a look? I havent been able to control most of my devices for a month now and it is supremely frustrating.

Thanks!

Hi Nick - Can you check if things look correct now?

Hi Brad,

thanks for getting back. Yes, something did change: My original location is gone now and only the “new” “home” location remains.

However it seems all the devices that were associated with the original location are also missing now.

From our side there was only 1 device associated with the original location, a mobile presence device. The devices aren’t visible under the Home location in the app or IDE?

Thats odd,

I dont have the foto I took a few days anymore, but I would say around 65% of my devices were linked to the now deleted location, while the remaining 35% were linked to “home”, the one that remains now.

The 65% also disappeared from the IDE now, where they were visible before…

That is very odd. What kind of devices are missing? Are you able to add them to back?

Now that I had a closer look it seems that exclusively my devices connected via my Hue Hub are missing…let me see if I can bring the Hub back…

Edit: Ok, this worked. Thanks @Brad_ST , after having gone 6 weeks without any support I had almost given up. Ill try to get my routines and light recipes, etc. sorted out tomorrow but with this solved I am positive it will be relatively straightforward from here.

1 Like