NEW: Aeon Home Energy Monitor v2 Device

yeah… I am on ios V2.0.8 thanks for the link! love being in the beta program!

1 Like

Hi @damohabir,

Yep, kinda figured that when I saw what you posted above and noticed the lines were left justified vs centered.

The Min value should always show up, even after a reset because technically the first value read would be Min, and Max for that matter. I honestly have no idea why this is happening to you.

Ok, I just pressed “Reset Energy” and now everything is displaying correctly. I could have sworn I did that before and it did not have an effect. But for now,all is good.

1 Like

I appreciated the GroveStreams recommendation. I finally got my Aeon HEM v1 connected up and immediately set out to send the data to GroveStreams. I spent several hours tweaking my dashboards to get them just how I wanted them and was loving the data I got.

I was wondering in the back of my head how much of the 5 MB/month I was using of my free account at the default polling rate but didn’t dig too far into the interface to find it. Well, I woke up this morning to a message on my dashboard that I had gone over the data limits and no more API calls would be accepted. I found my usage numbers and realized that I had sent about 15MB in about 16 hours! Needless to say, without some major increase in the reporting intervals, there’s no way to use GroveStreams in the free or $5/month tiers.

I’m looking at Splunk on my own server (500MB/day for free) or maybe Initial State’s first paid tier (with unlimited data and streams but limited support) now.

Can you share how much data you send to GroveStreams and how you tweaked your reporting to fit in their fairly low limits? I enjoyed the interface and the QuickStart that you posted was very easy to get up and running but I feel that the other options out there will let me work with the data that I’m able to collect.


EDIT - I just realized that you developed the Device Handler I’m using as well. Great work all around and really appreciated!

I am having trouble with my Aeon Labs Home Energy Monitor. I can’t get your app to work. It installs fine, but I get no results on the screen. See my screen shots below. Any help would be appreciated.

I figured it out - it was only working on battery and so it wouldn’t report anything. Now, I plugged it into an outlet and it is working fine, but I only get the first two rows to show anything. The other rows aren’t showing results. Any thoughts?

I’ve switched to the Google Sheets Logger written by @Charles_Schwer and it looks pretty good so far:

I have one sheet for Temperature, one sheet for Power.

I’m having my HEMv2 installed today, so I’ll let you know how it looks once I’ve got some data from that.

Yup, it looks pretty good.

So going back to my Jan 6th post if you go here

I have finally got ST to ship data off to Splunk. Just follow the directions in the post and you should be good to go.

I haven’t implemented the LAN side of things yet plan to work on that soon. I want to set it up so you can select LAN/Cloud and have it construct it that way in case someone is using the Splunk Cloud stuff. Let me know if you have any questions.

How do I add the Zoom to the top left corner of the graph so it will show (5’, 1hr, 1day, 5day etc)

Here are the steps:

  1. Ensure you have everything logging to your FullData sheet according to instructions from @Charles_Schwer
  2. Add a Sheet and call it something logical (like “Doors”)
  3. On the new sheet, click Insert then Chart
  4. Under Chart Editor | Chart type, scroll down to “Other” and select “Timeline”
  5. Select a set of ranges for the data, such as “FullData!A:A, FullData!K:K, FullData!F:F, FullData!B:B, FullData!P:P”
  6. Select “Use column A as labels”
  7. Click the Insert button
  8. Stretch your graph out and play around with how it looks

For reference, it should look a little like this:


Anyone know whether this meter can differentiate between import and export? (Most can’t).

Don’t know whether it’s the same elsewhere, but here in the UK many of us have microgeneration (PV panels - yes, we have sunshine sometimes, wind turbines, etc.) and any excess is exported to the grid via the normal connection. Our meters are designed so that they don’t run backwards!

Trouble is, most simple ‘whole house’ meters can’t differentiate between, say, 4kw import from the grid, or 4kw export.

The difference is important!


I don’t believe that this meter will.

My thoughts on why not:

Even if it can, it for sure doesn’t store import/export KwH in seperated sets… likely you’re not selling your power back to the grid at the same rates the power company charges you, so it wouldn’t be possible to calculate the difference given the unit only has one KwH store variable (import)

Since it might be possible to show a negative Kw usage, someone might be able to cook up a tool to do the KwH -/+ calculation on the hub or a computer, though this would be inaccurate as far as the hub missing packets or due to rounding errors. They only KwH value you can only go by is the HEM’s KwH variable that’s calculated on the HEM itself.

I’m willing to bet as solar gets more popular, we’ll see new generations of HEM monitors that have two data stores for KwH import/export. Hopefully we see that soon!

Thanks Erik.

I wasn’t actually thinking about cost. For me it’s all about device switching. I have a number of low priority electrical appliances that I only want to switch on when I’m exporting sufficient power to run them for free.

But your point will be important for some people.


1 Like

Does this work for anyone?

Trying to C&P the groovy code in a new “smart app from code” and getting this error:

No signature of method: script14580825953031798550368.metadata() is applicable for argument types: (script14580825953031798550368$_run_closure1) values: [script14580825953031798550368$_run_closure1@4c61a647] Possible solutions: getMetadata(), getState(), setState(java.lang.Object), metaClass(groovy.lang.Closure)

It’s a device-type not smart-app. The forum search has many examples of this error.

A tad confusing but thanks for the clarification.

Search currently isn’t working for me, so forgive if this has been asked before.

I have installed both versions of the device type, but setting the device to use either one results in the ST app giving me the “unexpected error” when trying to open the list of devices. But data does show up in the IDE log for both.

If I set the meter to use the stock device, the app works perfectly. Has anyone seen this issue? I tried clearing app cache on my phone to see if that fixed it…

Please provide more specifics. Which Device handler and which ST App are you referring to? How are you installing them? How are you “setting the meter to use…” the stock device, and which app then “works perfectly”?

Here is a little more info.

I received my Energy monitor today (the cheap one). After adding it to smartthings, I added both of the custom device types from this thread, not knowing which I would need/want.

If I pull up the smartthings app (not a smartapp) and look at the stock Aeon device it was working normally but with the very limited information of the stock device type.

I then changed the device type in IDE to the one labeled V2, but described as for the V1 devices [everything commented out]. Once this device type is set, if I open the ST app again, and try to view my things… i get the red banner of “unexpected error has occured.” This repeats when I try to open the specific device as well. I tried closing ST, and also tried clearing app cache in android. Neither fixed the error message. But in the IDE I was able to see the event history and reporting of the V2 custom device.

I repeated all of the above for the V2+ device type thinking maybe it was correct for my energy monitor. This had the exact same results: unexpected error in the app, but IDE shows all the data correctly.

I then changed the device type back to the stock Aeon energy monitor, and opened the app again. this time there was no errors, and the device showed up correctly.

By any chance are you using an Android device? If so, you can try removing/commenting out all the color commands…historically, Android hasn’t supported the advanced color features that are offered on iOS devices.

If that’s not it, I can’t really help, as I don’t have an HEMv1 to work/test with…

1 Like