Netgear Arlo mode management (AutoArlo)

I will get really specific as soon as I get a chance to go through steps again, I wish I could just write some code but with this there’s a little more to it. Definitely a special Thanks to JoeBee for starting this and what he did to get this started, certainly anything I am able to add to it wouldn’t be possible without him starting everything. Hopefully I can get enough off from base station and camera that he can eventually write it into his code and all it takes is a flip of a switch in an app and ST has full control.

Can anyone help a newbie.

When I try to create the device handler from code (copied from the link) I get the following error:

Java.lang.NullPointerException: Cannot get property ‘locationDTO’ on null object

Do I need to change anything in the code to match my system?

Also when you eventually get to creating a new device, what is the Device Id you use as this is mandatory?

Thank You

AutoArlo is a SmartApp, not a device handler.

Ha ha ha, I told you I was a Newbie :smiley:

Thanks for responding very quickly, I just haven’t got used to the terminology yet.

Very Embarrassing.

Thanks

No worries, we all start somewhere! Let us know how it goes.

That worked great thanks.

To get it to turn back to the disarmed would you have to have another smartapp (different name) that invoked the mode0 and was fired by the smartthings being set to Home.

Also I would like to switch it to schedule but this doesn’t seem to be identified like the mode0 and mode1, how would you do that?

And lastly, is there any way to view the video live feeds for the Arlo camera’s as devices in Smartthings.

Thanks

@Ian_Hirst
Not sure about your last two questions but the answer to the first is yes!
AFAIK the only way to view arlo output within Smartthings is to abandon the arlo hub and link to a Samsung NVR like @Crussell above.

Has anyone got a mix of Arlo wire-free and Q cams and got this working?
I’ve got it working for the hub but not the Qs.
Any assistance much appreciated!
Cheers,
Matt

I believe I did as was required but when I change modes in SmartThings to test my mode in Arlo does not change. Does it matter if I specify ‘Mode1’ or ‘mode1’? Any help?

Thanks

Never mind, ‘Mode1’ or ‘mode1’ does matter. I had ‘Mode1’ which obviously was incorrect. I changed to ‘mode1’, tested and all works as expected. Thank you for the smartapp.

1 Like

Hi Folks - I am clearly doing something wrong. Can someone please post step by step directions?

Has anyone had any luck doing something similar with the Arlo Q?

Did you ever have any luck getting this to work with the Arlo Q?

I’m pretty sure it can be done, using either autoarlo or arlotron, and substituting arlo device IDs straight in. It’s a horrible workaround, and not sure it’ll work but will try tomorrow. My coding skills are too limited to do it properly!
Was hoping IFTTT support might have arrived by now (seeing as it was due “in April”) but have given up!

Ok, no. I failed. My groovy skills are way too limited for this!
Maybe @JoeBee or @platron might be able to help?
My plan was to add a section to the smartapp inputs that allow you to input the device IDs of your various Qcams/Hubs, eg

section("Hub/Q device IDs:") {
      input(name: "devID1", type: "text", title: "ID1") 
      input(name: "devID2", type: "text", title: "ID2") 
      input(name: "devID3", type: "text", title: "ID3") 
    }

and then use those inputs to run multiple instances of the mode change. But I’m not that good, I don’t know how to get the inputs from above into the section below, and run it for each ID. The AutoArlo code grabs a single device ID, which is fine for the regular wireless cams, all running off a hub, but with Qcams you have one for each.

Boolean setArloBaseStationMode(String strModeId) {
    def mapBaseStationDevice = getArloBaseStationDevice()
    try {
        httpPostJson(
            [
                uri:     "https://arlo.netgear.com",
                path:    "/hmsweb/users/devices/notify/${mapBaseStationDevice.deviceId}",
                headers: [
                    xcloudId: mapBaseStationDevice.xCloudId
                ] + getArloRequestHeaders(),
                body: [
                    action:     "set",
                    from:       "SmartThings",
                    properties: [
                        active: strModeId
                    ],
                    active:          strModeId,
                    publishResponse: false,
                    resource:        "modes",
                    responseUrl:     "",
                    to:              mapBaseStationDevice.deviceId,
                    transId:         ""
                ]
            ]

If anyone with a brain can assist that’d be awesome!
Matt

Hello Everyone,

Before I ask my question, I will mentioned that I a newb here. So I have the Smart App published and when I attempt to configure it on my phone by providing [creds, change mode to “mode1”, and set the trigger Mode to be “Away”] leaving “Assign a name” and “Set for specific mode(s)” empty. Things do not seem to work.

I triggered “Away” and nothing happened on the Arlo side. In fact, when I try and review my SmartApp settings again, I get an empty form again instead of what I had provided before. Is this by design?

Thanks in advance!

Have you tried assigning a name? Just a first thought!

Just found Arlo channel on IFTTT, so excited to setup some new recipes for my Arlos

Aaaand relax. About time!

1 Like

Works GREAT!
Thank you!