Netatmo for UK users (Temp workaround)

Currently, UK users (and I guess Europe) connect to European servers rather than the US ones, and apps like the Netatmo (Connect) seems to be broken at the moment. In the meantime, here’s a temporary workaround for the impatient!

WARNING: You have to be comfortable with logging into the SmartThings IDE, setting up a new Netatmo DEV app, creating/modifying smartapps and possibly device types.

I would also suggest reading @JDRoberts awesome guide beforehand if you haven’t messed with the IDE yet:

Right, let’s get on with sorting out netatmo in ST:

  1. Go to this link and login to start creating a Netatmo DEV app:

  2. In the “Create an application” page, just fill in what you like for the app name and description e.g. smartthings connect, agree to the terms of use and hit the create button.

  3. In your newly created app, note down the clientID and secret, we’ll need it later in smart things

  4. Now log into the SmartThings IDE:


  5. Click into “My SmartApps” and then click “New SmartApp”

  6. Click “From Template”, then select “Netatmo (Connect)” from the left hand column and then click “create”

  7. This should create the smartapp and you will see the code once it refreshes the page.

  8. Click on the “App Settings” button and click “settings” on the next page.

  9. Enter the ClientID and Secret that you obtained previously when you created your Netatmo DEV app, and then click “update”

  10. Next, click the “Code” button to load the app’s code.

  11. Find the following line (near the top)

    private getServerUrl() { “” }

… and change it to:

private getServerUrl() { "https://graph‐eu01‐" }

12.Click the “Save” button and then Publish ‐> For Me button to finish.

13.On your mobile, navigate to the martketplace ‐> my apps, and you can now install the “netatmo connect” smart app

14.Now you should be able to use the app as intended to install your netatmo weather station devices into ST

NOTE: if it appears to be successful but no devices appear in “things” then that usually means the netatmo device types are missing in your mobile app. The default Netatmo “device types” should be published…

However, another UK user and myself noticed we couldn’t get them to appear until we added our own “netatmo” device types:

  1. Go back in to the online ST IDE and in the “My Device Types” section, click on the “New Device Type”

  2. Click the “From Template” tab, and then locate and click on “Netatmo Basestation” from the left column

  3. This will populate the right window with the netatmo basestation device type, and then you click create

  4. Click on “Save” and then “publish” —> “For Me”

  5. Repeat the above steps to create device types for the additional module and then again for any other netatmo devices you own.

Now, try the netatmo connect smart app from your mobile again, and it should now have added your netatmo devices to your “things”.


Here you go @Matt_Brain!


That’s awesome - thank you, i’m going to have a go at this later in the week - i’m just waist deep in central heating mods which has prevented me from progressing this any further…

I’ll let you know how i get on,


Many thanks for this.

However I have a small problem, I now have 3 Netatmo connect smart apps, and nothing happens when I press them. None of my Netatmo devices are listed.

Is there anyway of removing all 3 Netatmo connect smart apps? There is only one listed within IDE.

Yeah, would’ve been a good idea if I also mentioned to uninstall any instances of the app on your mobile first! Click into each instance of the netatmo app, and there should be a big red “Uninstall” button to do that… then try again.

Sadly no, nothing happens when I click in them, went back to my apps and tried there, now I’ve got 4 Netatmo connect instances. :smile:

I too get the Netatmo (Connect) app listed in myApps but when I click on it I just get the spinning clock tickmarks for a second or so and then nothing - screen stays as it was. Have double checked all setup, tried adding Netatmo devices and have rebooted SmartThing hub to no avail.

BTW I did have to just logon to the IDE via the US site - redirected to the EU one as your link didn’t load.

( https://graph‐eu01‐ )

Update: Just tried enabling oAuth in App > Settings > OAuth - all seems to work now

I have tried the same, when I then click on the Connect to netatmo (Tap to enter credentials) it looks like it is trying to load a webpage but nothing happens…

Edit: Should remember to check my work - cut and paste of URL was messed up - fixed and all working - thanks to @MA10 and @xAPPO

Interesting, the EU URL that I posted above works for me and it’s the first time I’ve seen the one you mentioned in your post… looks like there are different EU servers?! Thanks for the info!

@xAPPO, is that link correct as it doesn’t load in a browser for me?

I’m using the URL above which is working fine (when i copied and paste it into the IDE for some reason the ‘-’ were converted to ‘?’)

1 Like

Sorry - perhaps a bit unclear - that was your actual link that you have posted in the first post even though it displays differently that’s where it directs to … below is the EU one.


Ah, I see now… that’s really weird! I tried manually creating a link using the post editor and it’s as you say, the actual url becomes garbled?!

You dancer!

Thanks for that, it’s perfect.

Bit of a pain to setup, Had I read all the comments I could of easily avoided them! - Thanks

Hey guys wonder if you can help, when i click on Netatmo Connect on Smartapps templates is doesn’t update the code at the top of the screen, all the other apps seem to work, just the Netatmo one seems to be broken

I’m having exactly the same problem, the same thing also happens when trying to select any of the Netatmo device type templates.

Has anyone managed to get this working recently?

lots of these templates dont work in the IDE at the moment - but you can pick them up in the smartthings github page

My station stopped working about 4 days ago, no updates being sent to ST. Still works in via the Netatmo page.

I find this happens occasionally too…I just reopen the Netatmo (Connect) smartapp and click through to Done, and it seem to refresh itself ok after that