Nest Thermostat

I have not had an issue to clear the auth data on some time basis. In short I’m not aware of why you need to do this.

Can you be more clear on why you have to reset the auth data?

Earlier in threads you see this was a workaround other created to unwedge things, but I have not ever had to do it…

I actually have the Nest and I love it. It works really well for my home

So, I certainly do have to unwedge things every couple of days as the Nest stops responding. The workaround is in place, and I can unwedge by updating. Incidentally I’m pretty sure I’m using the code from your repo @desertblade!

Not sure why my Nest needs a re-login every couple of days (maybe its something to do with me having a UK hub/UK Nest?), but at the end of the day it does. Really just wanted some feedback on whether what I was planning would work or if it was plain dim for any good reason.

About to go away for a week or so but when I get back I may try the @E_Sch version and if that works then great and if I still get auth issues on a regular basis I’ll try the update I’ve suggested.

Failing that, I’m currently using a Domoticz server to run some lightwaverf switches and that has a Nest integration that works just fine without dropping out. Already integrated (one way) with Smarththings controlling Domoticz devices, so I may make a device handler using the Domoticz API as an intermediary for the Nest.

You may want to check if nest has a different server for the UK than USA.

Hello Community Members,

I am trying to solve a problem with my Nest Gen 3 Thermostat which is connected to my SmartThings Hub v2. I sent this question to ST Support, but they directed me to the community, since Nest isn’t an officially supported device. I still find this odd, since everyone else in the world is part of the Nest partner program but ST.

I am sorry if this has been covered, and I have overlooked the answer. I tried searching for this in the search bar, but nothing came up, and I don’t have the time to search through the multiple threads to find an answer.

My question is regarding Nest gen3 Thermostats, and mode/routines changes based on presence.

I have properly set up my upstairs and downstairs Nests with ST, so I have full control and the ST app updates stats appropriately. I just updated the code with the latest community code, from Github. I have also set up the Smart apps “Good Bye” and "I’m back”.

This is where the problem is. ST doesn’t change presence of my Nest devices (Home/Away), but only the Temp settings, when we leave the house. I verify this by looking at the Nest presence, in the Nest App.

I read through some of the last couple of posted pages, and this seems a common problem. I don’t experience any of the problems with the latest app crashing, as some other have said. I don’t care for the Nest to set presence, since I only use their Thermostat, but rather I am concentrating on ST to change the presence of the Nest to away, when we leave. Can you again offer any suggestions that could help me with my Nest presence problem?

Also, since I am having ST now control the temps and presence, how does this affect the Nest Schedule or the Auto Economy Leaf Function? Which device takes precedence?

Thank you for your help!!!

Are you using the Nest Manager app and devices that @tonesto7 and @desertblade have done a great job of creating and giving to the community?

I use Routines set on a timed schedule. I don’t use presence to change the routines statuses. For the last few days my “I’m Back” Routine has not set the temp to the correct setting. That’s a ST issue. Hopefully the ST update will correct these issues.

I am using @Dionoga code, but I guess I didn’t read back far enough to realize that the others are better.
I use schedules for my standard ST routines (Good Morning and Good Night), which then set my ST modes (Home or Night). I use presence for ST modes (Home, Away), which then sets the ST routines (Good Bye and I’m Back). These also set the Alarm and the temps on the Nest.

Maybe I configured this all wrong, but it is doing exactly what I want, except for when I forget when the Night mode is set on schedule, I am open the back door to take out the trash. The whole household is ever so happy hearing the darn Aeotech Z-wave Alarm go off.

My reasoning to set the Nest to Away, is to try to leverage the inherent energy saving features/ Algorithms of the Nest. I don’t want to strip down all their feature set, otherwise I could have saved a ton of money and purchased a standard Zwave Thermostat.

I will check into the other codes, but if anyone could offer any configuration changes based on my description, it would be appreciated!

I use Routines based on time schedules and they set the Nest to home/away as appropriate. Good Morning and Good Night are both home but have different temperature settings. Goodbye is away mode with its temperature setting. It pushes an alert to my phone if there’s any motion also. I’M Back is home mode with another temperature setting. When my schedule changes, I make adjustments to the routines as needed. Works for me as long as ST is playing nice.

Are you using a Smart App to have your Routine set the Nest to home/away?

When you schedule changes, do you make manual changes to your routines? I am trying to automate this, so I don’t have to go into the routine to make any changes, because our mid-day schedule changes very often, thus whey I use presence to make the change overall.

My only challenge is getting the next to change into its Home or Away mode, when my routine changes. Shouldn’t be any different regardless if I use a schedule to do this or presence.

Thank you for your help and responses.

I have the Nest Manager, but in the Routines’ settings I select the temp settings and home/away modes. I work rotating shift work so my schedule changes a lot. For now, I’m manually going in to the routines’ settings and adjusting as needed. Only takes me a couple of minutes and I check to make sure all the settings (lights; temps; home/away mode; motion) are how I want them for the upcoming time frame.

Wow… what rock have I been hiding under. I just loaded Nest Manager, and this is AWESOME. Thank you so much @tonesto7 for your hard work on these apps and device handlers!!! Thank you @desertblade and @E_sch for your contributions.

The instructions were easy to follow and much more simple than the basic Nest App I was using. This now integrates like a Native work with Nest app. Wow… :slight_smile: :smile:

Although I use my STv2 hub a ton, and automate most things, I am foreign to groovey, and how to alter the code.

For people like myself, I followed your instructions step by step, but noticed two points were left out, or I didn’t see them.

The first was to go into the SmartApps, in My SmartApps IDE link and hit App Settings. From there I went to OAuth, and enabled it. I belive this is discussed in the Nest Manager topic, but if you don’t scroll down, you would never know beyond your Smartthings App informing you of this problem.

The other thing that is not mentioned, or I didn’t see it, is that you need to add your Device Managers first. This is obvious since you need something for the app to work with, but I was being dense and literally reading step by step, and forgot this step.

Since these two corrections, Nest Manager and Automations are a god sent. Thank you… Thank you… Thank you! This now doesn’t make me second guess my purchase of Nest Thermostats v3.

Now, I can’t wait for the Rachio integration that @tonesto7 is working on.

5 Likes

Hi, i am very new to the idea of using code but have added 2 smart apps previously using these forums to SMARTTHINGS by using the Graph.api pages. I have followed the up to date instructions for nest manager having just purchased NEST but the app doesn’t show still on my phone? I have done the oauth bit too.

Many Thanks

Things to check:
Make sure the App and Device handlers are published in the IDE
You will need to add the smartApp from marketplace (under My Apps) in order for oit to show up in the App.

Once you add it from marketPlace it should show up under Automations->SmartApps

Hey Dianoga, thanks for the custom smart app. I just loaded it up and turning off my ecobee works perfectly. My only issue is it doesn’t turn back on after the sensors are closed. Do I need to setup something else for my ecobee to resume it’s schedule?

Thanks!

Anyone with this setup can confirm if this still works? I’ve heard Nest disabled a lot of their APIs that were needed for any kind of integration.
Thanks!

It still works for existing users that already had integrations in place. But new integrations are no longer possible to set up. Also, users need to remain on their nest account and not migrate to a google account at this point.

1 Like

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.