Nest Protect Device Type

@beckwith LOL very good… it’s so true!

Hello,

I am about to buy 2 nest protects, but i cannot make clear if you recieve messages from ST when smoke alarm goes off? And did anyone managed to make smartthings do anything when the alarm goes off? Like opening doors or something.

@crasy88 With this code no and I haven’t checked anything else. I’ll look around but I highly doubt it!

Web/http Devicetypes don’t have the ability to auto poll/refresh themselves, you need something like pollster to refresh your nest protect so you can get alarms. I have pollster updating get mine every minute. yes there is some delay, but it works. :wink:
https://github.com/statusbits/smartthings/tree/master/Pollster

1 Like

Just wanted to confirm, my NPs went off the other day and ST did not update the device states and the according modes. My wife was pretty upset. I’ll try to look closer at the NP code to see if there isn’t a cleaner solution than pollster

Now that Nest includes Dropcam (and soon Revolv, right?), I’m a little wary of using this code since it forces you to store your Nest account password in clear text, visible in the ST graph/IDE and in code as well.

Is there a version of this device type or another one that uses OAuth to connect with Nest instead of storing credentials in the dash?

@jaypeecee - (excuse the off topic for a moment) Wasn’t it confirmed that Google wanted only the developers and Revolv is in fact dead? It seems likely the Nest brand will release something for HA, but I believe it will be independent of any old Revolv hardware.

1 Like

Nest protect v2 pre orders now! Glad I held off

Did you work out why protect didn’t update device statuses?

does this work with mulple nest protects? i’m guessing so?

I have multiple Protects defined, but until we can find a way to get the status, not much use. Im sure it must be possible - there is some code on the Vera app store that might help. I have them defined through there as well, and they report ok.

@Andy_Godber are you using pollster to get updates from the nest protect? With out it your nest protect can’t update smart things. If you are using pollster there is an open smartthings issue with schedules dieing until this issue is fixed it will not be reliable. You can resurrect your schedules by opening up pollster and taping done and it will happily poll and update till it dies again.

Yes, using Pollster.
I think if you read the previous messages, the ST code for NP never worked?

IDK why its not working for you or anyone else, but i have been using this [devicetype][1] with pollster (polling every minuet) and it does work for me and i have gotten notifications from smartthings. I know that devicetype works. Right now due the the scheduling issues pollster won’t be reliable until smartthings fixes the scheduling issues so currently notifications should be wonkey.


[1]: https://github.com/NickHBailey/SmartThings-NestProtect

1 Like

Please can you show me a screenshot of one of your NP’s from the Developers Dashboard (graph.api.smartthings.com) / My Devices ?

For me, they never show anything in Data or Current States.

Also, perhaps a screenshot of the activity log for a NP, when you pass smoke under it to activate it?

Thx

No, as neither will help you get it working. If you would like for me to double check your settings, I’d be more than happy. You can PM me or post it here.

thank you ! what are the scheduling issues smartthings is having? are they close to fixing it? wonder how long it lasts before it “dies”.

I have four nest protects coming so i’m quite excited to get it going. really appreciate everyones replies.

Here is the thread for scheduler death, time between deaths seams to vary greatly.

1 Like

Any update on the scheduler deaths and reliability of Nest Protect code?

I have never been able to get any of the Nest Protect device types working in my SmartThing with my three Nest Protect units.

When I add them, I am able to see the data via the IDE.
When I attempt to go into my connected devices in my ST App on my Android Device, I get an Unknown Error.
If I remove the Nest Protect devices from the IDE, my ST App starts working again.

Support sent me here to resolve.

Note: I have tried four distinct Device Types. All have the same issue.