Nest device type with a bunch of new features

Sounds great. Thanks again for your help.

@cdallum, I’ve done some testing with setting the setpoints using only the auto method… Essentially, the results are the same as you are already seeing.

When I set both heat and cool setpoints via hello home at the same time. They set correctly in off mode and persist when changed to cool and auto modes. The problem is when you switch to heat mode, it still uses the cool setpoint. I’m not sure if it’s going to be possible to do what you want natively in the device type. You’ll probably have to push the intelligence into a smartapp so it sets the intended setpoint when changing the mode.

From what I can tell a potential workaround would be to have the SmartApp temporarily change the thermostat mode to auto, change the heating and cooling setpoints, then change the thermostat mode to the desired state (e.g. heat or cool).

That’s a bummer if the device type cannot handle this situation natively. I’ll revert to the previous version for now and keep my fingers crossed. Thanks for the feedback!

How does the Humidity setpoint work? This is a new feature for me since migrating to V2 Hub and having to reinstall all of my smart apps.

How can I remove the presence sensing from this device type? I don’t want this to show up as a presence sensor.

Am I able to turn the fan on with this device type? I installed it and it appears not. I want to have the fan turn on when remote sensors have > than 1 degree temp difference with the thermostat.

I’m not sure I understand the question. It works like any other setpoint. Do you have a humidifier attached to your Nest? If you don’t, than it does nothing for you.

It is completely harmless if you don’t want to use it, don’t, but if you must, remove or comment out line 81.

	capability "Presence Sensor"

This device type does allow you to turn the fan on without heat or cooling. It’s the button immediately above the heating setpoint. You’ll obviously need your own SmartApp to actually control that functionality of course though.

1 Like

That’s an easy one… Just remove the line near the top of the Device Type code that says something like

 Capability "Presence"

Save, Publish, and refresh the App on your phone by killing it and restarting it.

I did the same to my Nest Thermostats after the APPv2 was released.

1 Like

Thanks. I was confused by that button because it goes from circulate->fan auto->fan on when you press it, so I wasn’t sure if I was controlling the fan or the fan mode.If I hit the fan button in the Nest app it just asks me how long I want it to run for and doesn’t change the mode. That is the functionality I am looking for.

That sort of functionality has to be done in a SmartApp. A device type is really just meant to interact with a device, not intelligently control it.

That’s not to say you couldn’t add another state and hardcode 15min or something…

Thanks! That took care of the issue.

Forgive my ignorance; I’m new to the community but pretty tech savvy. I’m having trouble with step 5 as there is no ‘edit’ button next to preferences for that device, just edit next to delete and it brings me to the same choices I had when configuring the device. I can’t find where to put the SN in…

Sorry and thanks

Thanks for this device type! My nest is finally up and running with SmartThings. I’m using @imbrianj’s “change nest mode” custom app to set away and home modes on the nest and it works perfectly. However, I’d like to trigger a temperature setpoint at night when I put smartthings into night mode. The hello home action/routine has an option to set the temperature on my thermostat as part of the routine, but it never works. I can change the temperature on the device manually within smartthings, but it never works when part of a routine. Any help?

I’m having the exact same problem Robert is seeing, are we doing something wrong?

On your device, under the type drop-down, make sure you select “Nest” at the very bottom of the list and not “Nest Thermostat” higher up on the list. Then you can put in your preferences.

Nevermind, figured out my mistake!

The instructions are vague in two areas:

  1. You have to copy/paste the code from GitHub into your ST code page for the devicetype.

  2. The Edit -> Preferences referred to are also in the app on your phone/device. Took me a while to figure this out.

Note: I had to close the app on my phone and reopen it after entering my Nest account details. App works great!

THANKS OP!!!

Hope this helps.

This might be of interest. It applies to using any custom device type:

So, is anyone else using a alternate sensor for their temp reading instead of the thermostat itself?

I recently tried this and realized the heating and cooling set temperatures do not change when I change to different motes. I’m using “Keep Me Cozy II” I removed the alternate temperature option from the preferences and it start changing like it should again.

1 Like

I’m still having this issue with keep me cozy II. Anyone else?

1 Like