Nest device type with a bunch of new features

So for the people that are adding the Nest device type and are not finding where the preferences are… I figured out the problem for me. When you go to add the “My Device” most likely you are doing like I was doing and choosing “Nest Thermostat” … make sense right??? nope wrong, scroll all the way to the bottom and find the one you actually created in “My Device Types” and everything will work just fine. On that note make sure you give ur device type a unique name so you know for a fact you have the correct device type.

I finally figured out last night what my issue was: I had entered the letters from my Nest’s serial number in lower-case but the check seems to be case-sensitive. As soon as I had updated my letters to upper-case, everything worked :confounded:

Daniel, I have the same issue. Nest works fine when controlling it directly but when I want it to update the temps during mode changes I get the following error.

0364139d-50c9-486e-87d3-b72409143b1f 7:43:35 PM: error
java.lang.NumberFormatException @ line 440

Any luck in figuring out ?

Does anyone else get crashes when viewing the activity log for this device type? I literally can not even look at the log without it crashing. I’m using the Android app.

I’ve had the same issue for a couple of weeks. I can manually change the Nest temperature set points via the ST tile. However, the temperature settings don’t change on the Nest when a Hello, Home phrase executes. I’ve opened a ticket with ST support. They’ve been able to confirm my issue but don’t have an update on the cause and/or resolution.


hey just want to say thanks. I’ve been using this for my nest for about 5+ months. About a month ago the temperature sliders from my app stopped working (my nest wouldn’t update temps) and I haven’t installed smartthings app on my new phone until now to troubleshoot, but now everything seems fine again. also I just noticed that I could get rid of the awful sliders in exchange for buttons! awesome. thanks

How do you switch from sliders to buttons?

It can be found in the groovy code, see below. Add “//” to comment a line and remove the “//” uncomment a line.

	// Slider or Buttons...
	// To expose buttons, comment out the first detials line below and uncomment the second details line below.
	// To expose sliders, uncomment the first details line below and comment out the second details line below.  

	details(["temperature", "thermostatOperatingState", "humidity", "thermostatMode", "thermostatFanMode", "presence", "heatingSetpoint", "heatSliderControl", "coolingSetpoint", "coolSliderControl", "temperatureUnit", "refresh"])
	// details(["temperature", "thermostatOperatingState", "humidity", "thermostatMode", "thermostatFanMode", "presence", "heatingSetpointDown", "heatingSetpoint", "heatingSetpointUp", "coolingSetpointDown", "coolingSetpoint", "coolingSetpointUp", "temperatureUnit", "refresh"])

Got it! Thanks!!! So much better!!!

@cdallum, @theredmoose, @dseveso, @notoriousbdg (Sorry if I missed anyone)

I have a fix for the issue with Hello Home actions not working. I’ve submitted a Pull Request to @notoriousbdg to include it into his code and additionally, added Humidity Setpoint control for those inclined. The pull request is located here:

For those less familiar with git, you can pull the fork directly off of my repo here:

If you’re wondering, the fix for Hello Home support is changing the ‘–’ to 0 as Hello Home doesn’t know what to do with a string when it tries to set the temperature setpoints. Downside to this is that you’ll see a 0 in place of the more pleasing ‘–’ in the tiles when that setpoint isn’t being utilized, but it doesn’t bother me at all.


@bmmiller, awesome job! I merged the pull request The addition of humidity control is really nice feature.

@notoriousbdg No problem. I actually have a separate Smart App that sets the humidity setpoint off of outside air temperature every 15 minutes. Works quite nicely. Feel free obviously to change the color from green to whatever. Blue for water probably makes the most sense, but seemed too close to cooling.

This is awesome! Thanks for the fix. :joy:

Thanks for the device type; much appreciated. I have not been able to find this so far but is there any method for setting Home and Away presence in the nest based on Smartthings modes?

I use

As an additional enhancement request, do you know if it would be possible to get the Nest device type to accept temperature setpoint changes while in off mode? I’d like to use the new Thermostat Mode Director SmartApp. However, when this app puts the Nest thermostat into off mode, my Hello Home Phrase Director app tries to unsuccessfully change the temperature setpoints if I leave or arrive.

A common example is during the summer the outside temperature is often cool enough to turn off the A/C during the night and early morning. If I leave for work before the temperature is high enough to turn the A/C on, my cooling setpoint will remain at 74, rather than being changed to 80 when the ST hub is set to away. Later the outside temperature will get high enough to turn the A/C on, but the cooling setpoint is at its last value, which was 74 (while I was still at home), rather than 80 (which should’ve been set when my ST hub went to away mode). Thoughts?

There’s a note in the thread for the Thermostat Mode Director about the Nest device type and changing setpoints while in off mode.

1 Like

@cdallum, I just checked in a fix that seems to work for me. Can you try the latest version?

1 Like

I’ve installed your latest Nest device type. I’ll let you know how it works.

Thanks for the extremely quick response! :grinning:

As an update, the temperature setpoint changed while my Nest was in off mode. However, the heating setpoint was incorrectly set to the cooling setpoint value. Here’s a quick synopsis of what occurred overnight:

  • At 9:24 PM my Nest was changed to off mode because the outside temperature was within the neutral range.
  • At 10:30 PM my ST status changed to Home - Night. Heating should’ve been set to 66 and cooling to 73.
  • At 5:45 AM my Nest changed to heat mode because the outside temperature fell below the neutral range. The heating setpoint was incorrectly set at 73, rather than 66. Since the interior temperature was 71, the furnace turned on for a few moments until I set the thermostat to off mode manually.

I’m pretty sure I know what the problem is. The code performs a different API call when in heat and cool modes than auto mode. Essentially heat and cool setpoints are the same thing unless the Nest is in auto mode. The code currently sends the heat / cool setpoint commands (not auto) when in off mode. I can try to make it send them as though it’s in auto mode. I’m not really sure how that will affect it yet. I’ll see what I can do.