Nest device type with a bunch of new features

I can get everything to work perfectly except “present”. It doesn’t seem to be linked to my phone as presence sensors at all. I never saw a way to link them and they haven’t done it automatically. I thought at a minimum when my hub goes into “Away” (triggered by a Goodbye action of all presence sensors leaving) that this would go into away and trigger my Nest into Away as well. But nope. Hub is Away and this is still showing “present”. Help please (and I am a noob).

Hi, so, I followed all of the instructions at https://github.com/notoriousbdg/device-type.nest but all I get in the smartthings app where an icon should be is Unknown and a big question mark. In preferences, it only allows me to input a name, nothing else like SN… I’m new to this, so perhaps there’s something basic I’m missing that isn’t stated in the instructions? Thanks

I would also like my Nest to go into away when my presence sensors leave. Any ideas?

Hi, I have the same problem. I followed all the instructions but when I step number 5 (edit, preferences to enter the Serial Number and etc) I cant do anything beyond entering a name.
I have also tried to delete all and create a new device type from “code” ,then copied and pasted the latest version (Jan 2015), but the ST site could not create the new device type due to compilation errors. I am not a programmer, sorry because probably I am doing something wrong…any help or ideas?
Many thanks!

UPDATE: Sorry, I found the error, was a missing “}” at the end of the code!, so just creating the new device type from the latest code worked fine. Many thanks!

Did you get this resolved?

It sounds like all of the device type code wasn’t copied over properly.

I’ve been trying to set up my nest to smartthings for 3 days. On the step you copy and paste the code, I keep received the following error when I save. Can anyone help me out with this?

org.codehaus.groovy.control.MultipleCompilationErrorsException: startup failed:
script1429214551532314747256.groovy: 98: expecting ‘}’, found ‘,’ @ line 98, column 33.
94 attribute “temperatureUnit”, “string”

Thanks in the advance for the help!

I have the same issue My nest goes into away mode but I have to use the nest app to put it back to home.

Ive been using this for a while now, works fine:

OK, I admit to being new to SmartThings and COMPLETELY clueless. I don’t understand at all how to take this post and turn it into a working Nest. Are there step by step instructions for dummies?

I really don’t even know where to start. I follow the instructions I can find and get a Nest tile, but no way to add the S/N or do anything. At not point am I asked to copy code.

Again, clueless. Help appreciated it.

Thanks

Tom

I had used these steps from the earlier device code from another post created by Dianoga a while ago , I hope this still works
You can use the other code fragment from this post as well instead of what I mentioned.

Log into ide.smartthings.com with your mobile app credentials
Click My Device Types
Click New SmartDevice
Enter “Nest” as the name
Check the capabilities boxes for Polling, Relative Humidity Measurement, and Thermostat
For custom attributes add "presence"
For custom commands add “away” “present” and "setPresence"
Click Create
Remove all the default code in the text editor box
Copy/paste the code from https://gist.github.com/Dianoga/605591839 into the text editor box
Click Save
Click Publish > For Me
Click My Devices
Click New Device
Name: Your Choice, Device Network Id: Your Choice, Type: Nest Thermostat (should be the last option), Location: Choose the correct location, Hub/Group: Leave blank
Click Create
Scroll down and click the (edit) next to Preferences
Enter your Nest username, password, and serial number
Click Save

Awesome! Worked perfectly.

I’m not sure I’m blind or what but for the life of me I can’t figure out where I am supposed to do this step…

“Update device preferences”

Do I do this from the app or from the dev panel?

When I access the app I locate the new device but there are no preference options for the device I don’t get a gear to change anything with the device. And when I look in the dev panel from the web I can’t locate preferences for the new device I created in “My Devices”.

Help?

Follow the yellow circle

Is there a reason why I would not see preferences from that same screen?

I see current status, which of course isn’t populated with data yet since I haven’t connected my device… And I see events, but there is no preferences shown… :frowning:

The only thing i can think of would be you didn’t copy all the code from github. Copy everything paste it into your devicetype, then Click Save
Click Publish > For Me. Use the link below.
https://raw.githubusercontent.com/smartthings-users/device-type.nest/master/nest.devicetype.groovy

That would be it. This is the first device I was adding this way and I didn’t realize that after I added the device type that I needed to copy and paste the code (the instructions didn’t mention that) but that makes completely sense I was wondering why there was code if I was just setting the parameters in the + new device section.

Seems to be working.

Thanks!

Hi,

First of all, I love the Nest integration and SmartThings itself, of course :smile:

I had the Nest device type and my Nest thermostat installed, configured and working perfectly in SmartThings - until my husband decided to delete all the configuration :frowning: Now I added the device type back in, published it, configured the device with the correct device type, but it doesn’t work. When I make changes to the device type, e.g. switching between sliders and buttons, I immediately see the change in the app. When executing a Hello, Home action or pressing one of the buttons I get the correct log on the Activity tab but these commands never reach the thermostat. Any hints for me, please?

Thanks, I appreciate it!

Nora

I’m having a similar issue. My thermostat can be controlled form the device icon / properties, but actions (phrases) don’t work.
I just created a new mode that only sets the temperature and I get the following error:

1d63feab-7858-4c42-971e-35486b9b3617 ‎1‎:‎23‎:‎04‎ ‎AM: error java.lang.NumberFormatException @ line 440
1d63feab-7858-4c42-971e-35486b9b3617 ‎1‎:‎23‎:‎04‎ ‎AM: trace settings: [thermostats:[Nest], heatingSetpoint:70, coolingSetpoint:71]
1d63feab-7858-4c42-971e-35486b9b3617 ‎1‎:‎23‎:‎04‎ ‎AM: debug HH execute(), newMode: null

I’m using dianoga7’s device type. Removed the device type and re-created it, no change. That error seems to occur before the device, since I don’t get any log from it when changing the mode.
This was working before but I couldn’t tell when broke… summer is just starting in TX :smile:

Me personally i do all my temp changes in the Nest app with the assumption that i’m home 24x7x365 and i have the away temps set as well so it doesn’t get to crazy hot or cold (I live in TX too). The Nest app is much nicer for all that. Then i use a couple smartapps to make it “smarter”.
I use ThermostatAutoAway.groovy to set the nest away based on presence and ThermostatAutoHome.groovy to set it home. (https://github.com/sidjohn1/smartthings) This allows the temp to drift when no one is home.
Due to the unpredictably of TX weather i add in tslagle13’s Thermostat Mode Director to switch between heat and cool for the 4 months of the year we call “not summer” :slight_smile: .

(https://github.com/tslagle13/SmartThings/blob/master/Director-Series-Apps/Thermostat-Mode-Director/Thermostat%20Mode%20Director.groovy)

1 Like