Need HVAC Pro feedback on Trane TZEMT thermostats

I have a Trane TZEMT500… thermostat on my HVAC system at home and have been controlling it via Smartthings. We travel for work and have not been home many days since the install. We’re finding some odd behavior with the thermostat.

I’m working with Smartthings support to see if they feel the issue is related to their code. If not, I’ll move on with Trane or RCS (the maker of the tstat).

Odd item 1: A few times an hour, Smartthings reports the temperature at the tstat in triple digits. Like 105, 107 etc. It’s a false reading and I’ve never seen the tsat display a triple digit number.

Odd item 2: The tstat does not seem to be getting the Cooling Setpoint command from Smartthings. I can watch the screen on the tstat when I fire a Smartthings Hello Home action that includes tstat setpoints. I see the Heating Setpoint command come into the tstat display. I never see the Cooling Setpoint come in and it never really gets set.

The manual for the TZEMT 500 states that the “Schedule Mode” Button is used to select one of 3 operating Modes: Hold, Run and Energy Saving.

In Run mode, the manual states this: Run the system schedule (or Z-Wave controlled schedule).

As I have my thermostat connected to Smartthings, I can see the thermostat and I can control it for a while. The issue is that the thermostat seems to lose it’s mind, relative to the setpoints I sent it via home automation.

Tonight, I learned that the installer enabled “Schedules” and in the schedule, there are some default setpoints by day with changes day and night.

My question to those in the know on the TZEMT series tstats:
As I want to completely control the schedule via Zwave via Home Automation, do I need to delete the daily schedules that are already in the thermostat and if so, how do I delete them (I see no function for deleting them). Bottom line, I need the default in Run mode to accept zwave control and disregard any local schedule. The manual is not clear if the local schedule is disregarded of the thermostat is connected to a Zwave hub.

Thanks for any feedback.



I’d emailed RCS and received a reply back from Bruce there. He confirmed that when the TZEMT500 thermostat is included on a Zwave controller, all built-in schedules are disregarded. Additionally, there is no way to delete the built-in schedules and when connected via Zwave, no need to.

The learning here is that it’s unlikely the the TZEMT500 thermostat, when connected to the ST hub, was sending heating and cooling settings to itself at the same time I had ST doing the same.

Bottom line is, the inability for my ST setup to control the Cooling Setpoint of the TZEMT500 thermostat is likely not a limitation or error in the TZEMT500. I’ll continue to work with ST to potentially resolve that part of my issues.



Tried something today and did a lot of testing. While Bruce at RCS told me that built-in schedules are disregarded if a Zwave controller is attached to the stat, he also told me if I wanted, I could go into Installer Mode on the stat and disable Schedules. I did this.

I also removed the stat from ST, then readded. I resetup control of the stat within ST (Hello Home Actions) and performed a series of settings tests (sending the Hello Home Action “Good Morning”).

The Hello Home Actions allow the sending of either or both, Heating and Cooling setpoints - and only one time.

LEARNING:Through my testing, I have concluded that when sent as a pair, the stat only responds to the Heating setpoint. The only way I could get the stat to respond to a Cooling setpoint change is to send a blank Heating setpoint and the new Cooling setpoint.

This workaround will not work in the longterm but at least I’m gaining knowledge of where the trouble may lie. It still could be the way the data is sent by ST to the stat. Or, it could be the stat itself, not responding properly. Smartthings is having their developers look into this.

It would be nice to hear from others using ST and the TZEMT400 or TZEMT500 stat as to whether they’re experiencing the same issue or not.


I have a TZEMT400 and I only get the heating setpoint too. This is frustrating.


ST has engaged me on this - so they do know of this issue. They think it may be a timing issue. The Heating and Cooling setpoints sent too close to each other. It takes up to a minute for my tstat to show the setpoint being changed. My hope is that once they implement thermostats in a comfort dashboard module, that this issue will be resolved.

Perhaps @urman or @Ben may have an update.

I have the same thermostat and have been dealing with the same issue. I did create my own custom Keep Me Cozy App and reversed the commands so now it sends the cooling setpoint before the heating one. Now on my thermostat only the cooling setpoint will set. I think this further shows that there needs to be a pause in sending the commands. I’m only a novice in coding and I’m not sure how to do that. Hopefully someone can show me how.

I have the same issue as above and changing the smart app does not help as both set points appear to be sent at the same time so adding a delay does nothing. Currently this is the only real issue I have faced since switching to SmartThings from a Vera Lite but it is the most troublesome one.

You are setting the temp from the app and only heating setpoint works?


In my case, using Hello Home to adjust heating and cooling set points, the app asks for Heating, then Cooling set points. When the app fires, it sends the heating, then cooling set points, one after the other and quickly. The TZEMT series thermostat needs up to a minute to respond to the commands. As such, that delay needs to be either built into the app as an auto-delay or even better, added as a user-defined variable.

As such, I CANNOT use ST to control my thermostat automatically. This is an area of disappointment and I look forward to the day I can re-add my thermostat to my smart home :slight_smile:

Is there a fix for the tstat reading triple digits on the STs app? i randomly get a reading in the 140s.

@jbeletti @urman any luck with this? I was going to install tonight, but good thing I did a search first. Not useful if you can’t set the cooling temp reliably.

No joy on this end. I removed it from ST.

Looks like we fixed this but the fix isn’t live yet. Stay tuned and thanks everyone.

1 Like

Awesome can’t wait for the fix to be released.


The fix for the Trane issue is live. Contact us at If you need any assistance.


Thanks for the fix. The Tstat is working correctly now and is reporting the correct temps. However, the ST hub is constantly polling the Tstat for the humidity. Is this a normal thing?

It should report back the humidity each time it changes. That screenshot makes sense as each event is a different humidity value.

Thank you. Working great!

New guy here…they are installing two new Trane units with thermostats as I write…sent an email to tech support but not sure the best method (post or direct contact) Any hints or special instructions to installers? Any hints or special instructions for after they leave?

Having the same issues
Tried to move from Vera Lite to ST but the thermostat is not working

  • jumping temperatures as described before
  • when changing the temp settings from F to C the lowest possible temp is 32C (~90F)

Few of you seem to have it solved - any help is appreciated