Need help with Vision in wall 2 relay switch

Two parts to this one. If it matters, i have 1st version ST hub.

I recently purchased a Vision in wall 2 relay switch to run my light/fan combo in my bedroom. Wired it in last weekend, both switches operate and i can hear the switch pinging inside when i toggle the switches. red light flashing in it. Problem is that it isn’t visible when i try to add a thing (tried both the 4 button push and 4 switch toggles multiple times to make sure it’s in inclusion mode and even tried a factory reset). I have been trouble shooting with Vision and so far, i verified that distance isn’t an issue (moved a z-wave wall plug within a few feet of that switch that already is in my system and it works fine so distance shouldn’t be an issue). Next tried to purposefully exclude the device in ST and still nothing. Then, they had me add a device handler and then try to add and still no change. So, i thought i’d ask the community for advice.

I am a novice smart home person, i have a bunch of bulbs and a alexa dot’s running and have built a garage door opener, i even have another one of these same switches in my living room running my fan and got that one working fine(it’s been a year or better since i did this though).

The second part of this is Vision’s troubleshooting team is telling me to use a device handler. WHen i installed the first one, i dont think i used a device handler. in my hub the downstairs one shows a basic switch that when i operate, only toggles switch one on and off. What i remember doing last time is making a virtual switch, but i don’t remember how i did that, but what i do know is that virtual switch doesn’t operate correctly any more (it will turn on the fan/light, but won’t update status and won’t turn the switches off),

So, if anyone has any advice on getting the upstairs switch visible, i’d be appreciative. Second, can someone help me understand the difference between making a virtual switch, or using a device handler and what a smartapp does (they recommended using one of those as well on this device). Finally, if the device handler route is better, how do i convert the one that works to use it?

THanks and if i was not clear here, let me know and i’ll try to articulate better!

Thanks in advance!

1 Like

The following will explain the basic concepts of smart apps and device type handlers. There’s always a device type handler, but the system will assign one at the time of pairing if it can. It just might be a simple generic one and not give you all the advanced features of a device.

In this particular case, the advanced features include using the second switch.

I’m not sure what the current status is on this particular model, so hopefully someone who knows more will respond. :sunglasses:

Talk to the folks in the following thread after you read the FAQ, they may be able to help

Did you ever get this to work? I just bought two of them recently two and can only get relay 1/2 working not the other

  1. Do a General Device Exclusion first from Smartthings app on phone
  2. Login your ST IDE and create a new device handler using this DaSmartThings/vision-dual-relay.groovy at master · Nomad-Tech/DaSmartThings · GitHub
  3. In your ST IDE create a new app using this SmartThingsPublic/virtual-device-sync.groovy at master · erocm123/SmartThingsPublic · GitHub so you have independent control for the 2 relays
  4. Add a thing now (pair your relay to hub) from your phone app
  5. On the phone go to Automation select and setup the app you created

Yes, the smart apps from this thread worked?

I was researching for a customer of ours. Thought I would throw our post in here to help.
We have had St users in the past say they need a handler to work correctly with Vision’s dual relay (VL7432)
Here is a post on how to get it working.](

I hope that helps.

1 Like

Anyone know the status of pairing one of these in 2019 to SmartThings v2 Hub?
I accidentally removed my hub / home and have since tried excluding / including again but they don’t seem to work anymore correctly… the relay will toggle once but then won’t respond after that.