Need help with TCP lights

Everything I find online is from 2014. I can add my TCP lights to my phone and they work, and then they get lost. I get an error message over and over again saying:

TCP Lighting is having communication errors. Error code = 400. check that TCP Gateway is online.

Which it is online and I can reconnect it from anywhere and the message goes away and then it has issues again.

Please help.

I noticed the same thing for at least the last week. Might even have been longer,since I moved all TCP lights and hub next door to the daughter’s a while ago. I was trying to turn on her cellar lights and discovered they wouldn’t work. I would up installing the native TCP app on my phone. When I looked at the ST notifications I had that same error going back as far as I felt like scrolling. I tried relogging into TCP through ST and resyncing her TCP hub but neither helped.

Somebody broke the C2C on one side or the other.

I get the same error. Reauthorizing through TCP connect app fixes it for a few days.