Need help to pair Ring Contact Sensor to SmartThings hub

@Daniel2_Kusterer If some developer doesn’t come out with fully loaded driver I’ll publish my adopted stock driver.
I think that if you are using stock DTH tor your sensors, that they will be moved automatically t9 stock edge driver.
With SmartThings moving devices from DTahbto edge drivers you don’t have to remove and add devices. If you want to do it ahead you’ll need to remove and sensors again. Some users might have a lot automations that might loose if don’t do driver swap correctly. I did mine using one virtual contact sensor in place of all automations.

1 Like

In the Moment I use the Standard Z-Wave device handler .

Thank you for your help

Try this link

1 Like

The Sensor ist working with you driver. Thank you so much.

My Smartthings website no longer has a tab for “My Devices” how do I change the device type for the Ring Z-Wave S2 sensor?

Saw your Youtube video on the subject.

Thanks, I have all my doors switched and they all work.

I started with my one spare sensor and am adding an edge sensor, changing the name of the old one to (name)x and then swapping it out in each automation with new (name) sensor, unpairing and resetting the old one, then moving to the next sensor and doing it all again until I am thru. I got all the doors and the fridge done in about an hour. Still have to do the windows tomorrow night

Hi David! Welcome to the community! Sorry for my late reply. It appears that you have found an answer to your question. If not, I would recommend that you to check out the following community thread: Edge Driver needed for the Ring Alarm Contact Sensor Using the 'Z-Wave Plus Door/Window Sensor' DTH

Funny that two David K’s enter this discussion at the same time. I was following this discussion the entire time, and got mine switched over the last several days. The other DavidK is new. Milan’s driver works great. But I did have a few sensors that took mulltiple tries to get them to exclude and then repair properly. One I almost gave up on, as it kept pairing as a stock DHT Zwave sensor, then on about the 5 or 6th try it worked. I now only have two devices still on DHT’s a Zen51 relay for my hardwire smoke detectors and a Hue Outlet.