Need help connecting to hub

Hello,

I’m developing a device based on the NXP JN168 Zigbee module and having problems connecting to the ST hub. I’ve got a v1 hub, using both the Atmel RZUSB stick and TI USB dongle as a sniffer. On the sniffers, I can see the hub sending out some data about every 4 seconds, nothing connected as far as I can tell.

Powering up my Zigbee endpoint device, it sends out a beacon request, and the hub responds with a beacon which has the “Association Permit” field set to false. From what I’ve read, this means that the hub isn’t allowing nodes to join. The hub never shows any activity such as joining attempt, or even acknowledgement that my endpoint device tried to join. The ZED constantly sends a beacon request, and the hub responds each time with a beacon. But no join happens. The hub’s log shows nothing except for the “hub events” sending a ping, with value ping. Don’t know what that’s all about since I’ve never seen that in any Zigbee documentation.

I tried to set up a device handler, based on some code that I saw elsewhere for the NXP module, but that didn’t do anything.

Is there something that needs to be done to enable the hub to allow ZED nodes to join? There isn’t any clear documentation in the smartthings site about how to set-up the hub and network to allow devices to join. I know there’s a general underlying assumption that you just power up devices and they connect automatically, but this doesn’t appear to be happening. Any help would be greatly appreciated.

1 Like

I have very little experience in this regard, but, I try to be helpful since I am doing some similar work with some success.

  1. Are you using a ZigBee HA based profile?
  2. What is the ZigBee HA descriptor you are sending in the join request?
  3. Does #2 show up in the Hub event log?

Hi Terry,

I’m using the ZigBee Home Automation profile
There is no descriptor being sent, since the hub is not allowing joins, so the ZED device is constantly sending a beacon request (join request), but the hub acts as if it didn’t hear it. So the ZED doesn’t even send out anything beyond the beacon request. Here’s a screenshot of the sniffer output:

The blue and gray lines are from the hub. The red lines are from my ZED device.

As I stated in the original post, nothing is showing up in the hub event log. Check out the image:

What happens if you go into “Add Device Mode” (using the SmartThings mobile App, + Add New Device option)?

That will force the hub to listen for … well, descriptors over Z-Wave and ZigBee. If they are seen and not matched to a known device type signature, they should show up in the Hub Event Log.

You need to make sure the ZigBee network is set to promiscuous join mode. Devices are not allowed to add themselves to the network. You can do this by following @tgauchat instructions.

2 Likes

Thanks guys,

That did the trick. The actual steps were slightly different, but it worked. I was able to see activity on the hub and do some things because I had a device handler and some functions setup already. The device never joined the network though. I don’t know if it’s because I have to bind the server first, this is using the occupancy sensor profile. I wish this procedure was a little clearer in the documentation though.