My SmartThings for Advanced Users (SmartThings Advanced Web App)

I have several z-wave lock edge drivers installed, including the ST one. Thanks for the tip about looking for the fingerprint, although I would think it would just work because it’s a common z-wave lock (but who knows if it was dropped). Maybe it’s because I never actually deleted the Rboy lock app. Anyway, I’ll keep trying because it hasn’t converted yet by itself, even to just the Thing driver.

PS. I tried to look at the API+ link in your post and it says it’s private or doesn’t exist. My locks are Kwikset 910s. Shouldn’t they work? However, my ST drivers are from the beta channel of ST. Does that matter? I have the Rboy beta driver installed and one would think that would include the 910 lock. I have a bunch of other devices that have never converted either (like some ZigBee bulbs and Inovelli multi switches). I keep waiting…

I wonder what the SoftLimit means versus an OK limit. My V2 is OK, and my V3 is Softlimit.

I have a Contact sensor _TZ3000_6jeesvrt TS0203 using a Zigbee Contact MC Driver and a second one running on a DTH. I cannot change the DTH device over to Edge using this method. So for now the answer is no you can’t

2 Likes

To use the API Browser+ you need to create a Personal Access Token at
SmartThings. Add a little smartness to your things.

Devices with the same name can still have different fingerprints. This is why you need to check that your exact fingerprint is included.

The only real difference between the ST beta and ST regular drivers is that some devices might be available in the beta that are not yet available in the regular channel drivers yet needing to be tested.

1 Like

Here’s the thread. The topic title is a clickable link to the full thread.

as far as I can tell, Softlimit means you get the warning in the mobile app that the memory is getting full, but it still lets you add the device. My ST Station is ok and V3 says Softlimit.

My tests with remaining DTH devices would indicate you cannot. The UI displays an error prompting you to make sure the fingerprint matches, even when I’m sure they do.

Edit: @Jeff_Gallagher already said as much, I missed it.

4 Likes

Stock driver only has a 910/1, 910/2, 910/3 with these fingerprints:

Don’t see any other 910 locks in the driver from philh30 either.

Can you check in the API Browser+ or the new Advanced Web App for the fingerprint for your lock?

2 Likes

Has anyone tested if more than 20 rooms can be added?

nice that you can add/edit/remove Modes

Yes, it works.

1 Like

I have a personal access token. I wasn’t asked to enter it anywhere. I use it mostly to log into T Austin’s browser (which might be to what you’re referencing).

I’ll try to check, but based on other posts I don’t think I can go from DTH to Edge this way. I wasn’t able to in the past convert directly, so I was surprised to see the option.

Ok, I have access to that. It just didn’t work from the link in the post

1 Like

Seeing the same thing with mine. Does anyone know why?

I am not sure I can offer a ‘why’ as such, but there is nothing new or unusual about it. It is simply that most native tools are Location centred so it is easy not to be aware of the devices that aren’t in Locations.

The ‘mobile as a thing’ device represents your mobile or tablet as a device in itself. It appears to be a ‘User Device’, whatever that means specifically, in the API parlance and sits outside of any Locations. It is the parent device of the mobile presence devices which are created in each Location where presence sensing has been enabled.

Does it have any function apart from being glue in the architecture? No idea.

Except that not every device that is enabled for location tracking has both a “mobile as a thing” device and a “SmartThings-smartthings-Mobile_Presence” device.

You can see all the mobile presence devices in all the Locations that you are a member of. However you can only see the ‘mobile as a thing’ devices that you own. Sorry, I forgot to mention that.

I am used to seeing them listed like this but three of those are placeholders …

1 Like

Got it, thanks!

Excellent point. Very disappointing that we are now just 8 days away from losing access to the old portal and Samsung has still not supplied the ability to run VITAL utilities in the new Web App. Nor are these utilities listed in the latest version of my iOS ST app. Feels like they are abandoning these tools. That will end my 8yr relationship with Smartthings if they do.

2 Likes

Is it possible to run a Z-Wave repair from this tool?