My Scenes have all gone missing [January 2021]

Yea, I am with @ebug, I can recreated 2 of them and already have. Thank You for the Support @vlad :slight_smile:

1 Like

Hi vlad, I am still missing most of my scenes. I can’t figure out how to DM you but would like to discuss mine with you as it may be a unique case.

Just chiming in to say I’m having this issue too. I’m missing at least one scene, which happens to be the one I use most. I have it set up to fire with a smart button, and that still works. But I can’t see the scene in the ST app.

I’m having the same issue. I will send you a DM. Thanks.

All my scenes and automations disappeared today.

As am I as of today, will send a DM shortly. FWIW, it seems to have deleted the scenes I had tagged as “favorites”, but I am not entirely sure that was all that it deleted. It did leave many intact. Hope there’s a recovery possible.

Yes same here all automation and scenes are missing but they are still working!
How do I get them back?

I also am having this issue. Scenes gone but still working on schedule. I do not have a hub.

I should also note that scenes are still visible (and work) in the iOS widget but not in the actual app

1 Like

Just adding on here, all of my automations that included “Sunset” or “Sunrise” have gone missing & they’re not working. Every night i run around the house to turn all the exterior lights on…wonder if this is Smarthings way of trying to make me get more steps!

Wrote to support and got their usual “Uninstall + reinstall” which doesn’t help.

1 Like

smartthings replied that this is a known issue and they’re trying to resolve it.

I’m having the same issue. Any word on a fix?

Any more word on this?

My wife updated her iOS app and the scenes and automations are all missing. We’ve tried logging her out and back in, with no change.

I have yet to update but won’t do so until this gets resolved.

Thanks.

I seem to be having a similar problem. 2 days ago my outdoor lights failed to turn on. I thought that it might have been a network issue here. It happened again on the following night so I thought that I should have a look. The scenes that turn on my outdoor lighting were missing on my GS20+ phone. So I logged into my Smartthings account online to see if I could fix it there. When I tried to load my scenes I got the following error: An error occurred fetching scenes for this location. I believe that all the missing scenes used the Sunset parameter to turn the lights on. I turned the lights on manually and noticed that the lights turned off automatically at the scheduled time. The “off” does not use Sunset/Sunrise - it is set to 10:30PM. Also, the night before all this started my GS20+ updated itself.

Same issue on iOS here. Scenes are empty in my app and gives an error via the web IDE.

Any update on a fix? This is silly. Alexa knows about my “disappeared” scenes and can execute them, but ST iOS app does not. I’m expecting the fix will be to delete the missing scenes from Alexa too and force recreation of this stuff that has worked for 3+years until recently.

I closed my app and started it again, and now I see my scenes. Yay.

1 Like

No joy here. Logged out, closed and still missing. Glad to hear they have made some progress so perhaps there’s still hope.

Same on my side, all scenes and automations gone, but still running.
Strange is my wife (member of house) still has all working and you can edit the automations without issues.

I think things happened more or less at the same time I started using Smartthings on Android Auto and hidden some devices. Can it be related?

Its all related to the app update that enabled those features. That version (February update) of the app updates all of your scenes and automations to be saved in an underlying format called RulesAPI - avoiding the technical description. Lets just say you want this, its the path forward to potential local execution.

Buuuuuut.

In doing so the app (both Android and iOS) have bugs dealing with displaying or editing scenes and automations based on RulesAPI… So it enabled and migrated them, and then depending on which version and platform of your client, it may work fine, may not display or may not allow you to edit.

OK, so I would like to just recreate the scenes that ST’s buggy update lost, however that begs the question of how do I “delete” the scenes that are hidden from the app but do work/exist for Alexa?

(Otherwise I anticipate problems with duplicate names and would rather NOT change the names for those scenes that the wife’s been “trained” on :grin:)

Anyone know how to reset/delete that stale hidden state?