My First Automation -- Didn't work as planned

Many community members always start first with the official SmartLighting feature, whether they are using the classic app, the new V3 app, or both.

The reason is that these are the primary automations which are loaded into the firmware of your hub and therefore can run locally on the hub rather than having to go out to the cloud. That’s a good thing both because it reduces latency and improves reliability. :sunglasses:

A smartlighting automation will only run locally if the devices in it are also eligible to run locally, and if it doesn’t include anything which doesn’t run locally, like GeoPresence or location.modes.

Also it has some really nice extra features like the mirror option and power allowance.

It’s up to you whether you choose to use it or not, but it’s popular for a reason. :sunglasses:

5 Likes

To Reset Geofence: SmartThings New app:
1. From the App Dashboard, tap the three dots in the top right
2. Tap Edit
3. Tap Geolocation
4. Tap the map (if needed, long press to place the pin in a new spot on the map, or tap and hold the pin to drag it)
5. Pinch and zoom to change the size of the geofence surrounding your home
6. Tap Save when you’re done

  • Reset Geofence: Classic app*
    In the SmartThings Classic app, tap the menu (Android) / More (iOS)
    1. Tap the gear icon beside the Location
    *2. Tap the map (if needed, long press to place the pin in a new spot on the map, or tap and hold the pin to drag it) *
    *3. Tap and drag the dot to change the size of the geofence surrounding your home *
    4. Tap Save when you’re done

These were the instructions sent to me by Support. Neither set of instructions make sense to me because I followed the steps and didn’t see what was supposed to be there. For the NEW APP, if I tap the three dots and then tap Edit, geolocation isn’t an option.

For the CLASSIC APP, I don’t get a map shown when I tap the gear icon.

For the new app:

It doesn’t really look like it, but that is two separate menu options: “edit“ and “manage location.“ You want the second one.

The next screen will show you your address. Tap on it, and then the screen will open where you can change the pin for the Geo location.

@Brad_ST

Ah, okay. I was just blindly following the instructions. I guess I shouldn’t have tapped EDIT as instructed. Now I see how to get where I’m trying to go. I actually already tried moving my geolocation to California and then back East again and it didn’t help to change the incorrect sunrise & sunset times. I’d like to finally get this figured out, but over the weekend I took your advice and started using the Smart Lighting App instead of using my original automation. So far, the Smart Light App has been working perfectly.

1 Like

Glad to hear the Smart Lighting app is working well. I did receive additional clarity that I want to share as it may explain the original issue. While Smart Lighting automations will reschedule the time for sunrise/sunset events every time that they run, custom automations in the new app only reschedule sunrise/sunset when the trigger time is greater than 5 minutes offset from the time of sunrise/sunset.

For most users, sunrise/sunset shift by about 1 minute per day. As such, it can take several days before the offset is greater than 5 minutes which will result in the automation updating the time it is scheduled to execute.

The table below is an example of what a user may experience. With a shift of approximately a minute per day and sunset initially scheduled for 8:00 PM, the automation might execute at 8:00 PM for seven days before rescheduling for 8:06 PM.

Day Sunset Time Time of Automation Offset
1 20:00 20:00 0
2 20:01 20:00 -1
3 20:01 20:00 -1
4 20:02 20:00 -2
5 20:03 20:00 -3
6 20:04 20:00 -4
7 20:05 20:00 -5
8 20:06 20:06 0
9 20:06 20:06 0
10 20:07 20:06 -1
4 Likes

Brad, thanks for the explanation. I think I noticed the sunset time not changing about five days after I created my automation. If I had waited a few days more, I guess the sunset time would have updated.

2 Likes

I’ll bite. Do you happen to know why this is? Does it reduce the hit from shedloads of automations rescheduling or something?

Just checking in to say that everything has been working perfectly since I switched over to using the Smart Lighting App. I even had an internet outage the other day and my interior and exterior lights still came on as scheduled. That’s something that wasn’t possible with my old Wink hub.

1 Like

Update on my automations---- I’ve now had two failures of my smart lighting automation for my landscape lights. All other automations have been working flawlessly. But I have no idea why my landscape lights failed to turn on twice over the last two weeks. Anyone else having issues with smart lighting failing to execute?

I think I may have figured it out. My landscape lights failed to turn n again tonight. Looking at the app, the switch for the landscape lights showed as offline. Manually trying to turn them on didn’t work either, which makes sense if the switch is offline. I think this switch, which is located outside, must be on the edge of my range. If that’s the case, does it seem like a good idea to buy arrange extender to increase reliability? Something like this for $30 on Amazon?

No. :wink:

You may very well benefit from adding an additional Z wave device to strengthen the mesh, but as I have been saying for years (in many places in this forum) there’s no justification for the single purpose extenders now except to make more money for the companies. You just don’t need them.

At this point, pretty much every Z wave plus device operates at maximum transmission power, so you can use any mains powered device and it will act as a repeater which is just as good as the single purpose device that you linked to. And you’ll get a lot more value out of it and probably pay less as well. This can be a light switch, a relay, a plug-in pocket socket, even a plug-in motion sensor.

The single purpose range extenders were needed back in the third generation of Zwave when some devices were only operating at about half power. But we’re talking 2014 or so.

Since then, the fourth generation of Z wave classic or Z wave plus (the fifth generation), you just don’t need them. And you especially don’t need to pay more for one, which is the part that makes me crazy. :rage:

The following device is just as good a repeater as the one that you linked to, and also has two independently controllable smart sockets.

Just sayin’… :sunglasses:

1 Like