My Ecobee Init (Service Manager) for easier installation

Hi @rda2w,

I made some minor changes today (v3.4.2) at my beta branch, and it now works as expected on my end.

Regarding your specific issue with the hex name, it looks like you’re having specific connectivity issue… Do you have good wi-fi connectivity at home?

On my side, I’ve noticed the following facts:

(1) Cloud Connectivity between ST and ecobee is an issue.

This morning from 9h30 to 10h40 (EST) the ST connection was lost with ecobee.

Then, at around 10h40 (EST) the connection was re-established and MyEcobee device was able to recover and it proceeded then normally after.

(2) The stock ST device is even more vulnerable to cloud connectivity issue.

I was running the ST stock device in parallel to see if it is also affected by the ST-ecobee connectivity issue. And, I can confirm that it is also greatly affected.

However, contrary to My Ecobee device, the ST stock ecobee device is now stuck since 10h30 (EST) and does not respond at all. I cannot increase/decrease the setpoints or even refresh it.

The device is now longer responsive and I will have to kill it.

(3) It seems that having ecobee3’s remote sensors generates more exceptions

I’ve noticed that most of the ecobee3 users who expose their remote sensors to ST have more issues than other ecobee users.

The more ecobee3’s remote sensors, the more exceptions they get.


  • If you have many ecobee thermostats or many ecobee3 remote sensors, create many instances of MyEcobeeInit and ecobee3RemoteSensorsInit and split your devices between them.

You can assign a new name to the smartapp at the last page.

  • If ST support says that you should switch from my custom Ecobee device to the ST stock device, this is clearly wrong as the ST stock device is not able to recover from any ST-ecobee connectivity lost.

P.S. I’ve updated the known issues section of the ST community wiki with my recommendations


Thanks for your work @yvesracine, I just got a new ecobee3 and installed using your apps, but am experiencing the connection issues. To move to the new beta code, do we need to uninstall the existing thermostat and sensors, replace the code, and reinstall, or can we just copy the new updated code into IDE?

@becma27, the beta code has been promoted to the main branch since yesterday.

If you’ve implemented/updated the code since December 1st (that was some ecobee API changes that day), then you just need to copy and paste the new code (at the main branch) and save&publish.

However, the new code will not correct all the ST-ecobee connection issues; it just basically implement some throttling to avoid connection issues as much as possible.


@rda2w, in your case, I would uninstall and re-install everything from scratch.

Don’t set up your ecobee3’s remote sensors first (do not install ecobee3RemoteSensorInit), just the thermostat and see how it goes.

After a while (a day or 2), if the thermostat is stable, then install ecobee3RemoteSensorInit, but just for 2 remote sensors.

Let me know how it goes.

Hi. I have been watching this thread as am having the same issues. Did not have any remote sensors exposed. Just the thermostat and two change mode smart apps. One away and one home. Uninstalled all the apps. Updated everything yesterday on IDE. Reinstalled thermostat only and only works for a couple hours at best before it fails. To bad if ST or Ecobee broke it as it had been rock solid and was a great integration with the change mode.
Thanx, Abe

@Abe, I think that the connection issues are maybe dependent on the US region where you live, as mine has been OK since December 1st (the day ecobee made some changes to its APIs and created a mess with the token renewal logic).

I live on the East Coast (Canada).

This could be related to the way ST manages its connection pools…

I’ve tried to implement some throttling to avoid connection issues as much as possible, but my code does not correct the root cause of the issue which is the cloud connection between ST and ecobee.


EDIT: some people contact me after a while to say that everything is back to normal after uninstalling and re-installing the smartapps and the device itself. Go figure.

Hi. Thanx for the update. I to live in Canada (Saskatchewan) but will try a complete new install from scratch and see how it goes.
Thanx, Abe

Will do, thanks. Like Abe mentioned, after loading the apps last night I was getting about 2 hours of good data before having to re-login. I’m going to be on travel this week but will take a look each evening to see how it’s doing.

Hopefully ST will fix its cloud-to-cloud connection issues soon. As Tim Slagle said it in an earlier post about this topic:

Continuing the discussion from Initial Setup for Ecobee3, Smart-SI, EMS, Smart-02 thermostats - My custom Ecobee Device:


@rda2w, @Abe,@becma27,@allen00se, @bgoddard79,@Jim_Salyer

Somebody forwarded me an email he got from ST support about our ST-ecobee connection issues:

While it may not be out for a few weeks it does look like we have some Ecobee integration improvements slated for later this month. That should hopefully get this Token issue cleaned up. There isn’t a good solution for the short term, but lets see how the platform update later this month helps.


SmartThings Support

No luck overnight. I removed everything and only installed MyecobeeInit and it ran ok for 2 hours and has repeated the token and server error messages since then.

Hi, sorry to hear that, where do you live? I’m trying to figure out if some US regions are more affected than others…

I know that somebody from Texas had this issue as well…


I’m in Syracuse NY. I’m going to run the stock ST code today to see if I have any connectivity drops. It’s been going 5 hours so far and still responds to a refresh.

@rda2w, I’ve been running the ST stock device at my home since December 1st, just to see how it reacts to connectivity issues.

Be aware that. even if it looks like the stock ST device is running (and does not throw exceptions), if you try to increase/decrease the setpoints or resume Program, you’ll find out that it is not responsive to any commands and does not do anything at the physical thermostat…So, it’s also affected but nothing happens in the logs.

EDIT: That’s what I’ve observed on my end anyway.


Hi @rda2w,

Till ST makes some changes to their cloud backend (Devconn) as promised, I will ask you to test a new version in my beta branch (if you’re interested):

  • So far, my code has been proactive in dealing with exceptions, but as ST cloud now seems to throw exceptions for HTTP requests coming from some users (but, not all of them as I and others don’t experience any exceptions since my last change on December 1st), I’m wondering if I’ve done some over-engineering on this issue.

  • I created a new version of MyEcobeeDevice, myEcobeeInit and ecobee3RemoteSensorInit in my beta branch that deals differently with exceptions using a handleExceptionFlag. The flag is set to false by default, and in that case, the code in my smartapps will not handle the exceptions pro-actively and just try to proceed normally despite exceptions.

  • Please give a try and let me know.

As I don’t experience any exceptions myself, it’s kind of difficult for me to find a workaround.

P.S. You just need to copy and paste the code,save &publish for the smartapps and MyEcobeeDevice.


Hi @yvesracine. I’ve loaded the code from the beta branch and enabled 2 of the 4 remote sensors. I left the flag in the false position and left the default intervals. I’ll let you know how it goes.

Overnight the results are similar to the past. After 2hr 10min the login credentials seem to have been lost and it didn’t receive any data after that. MyecobeeInit says “you are connected” but has thermostat name replaced with “11f5337d-2f13-497d-bf05-62923e1e2cde.ecobee3.316511652709”. That string also appears in github under My Devices-My ecobee-Device Network Id 11f5337d-2f13-497d-bf05-62923e1e2cde.ecobee3.316511652709.

Just for information, I ran the stock ST code yesterday for about 18 hours and it did have issues but a little different. The login credentials remained intact but it stopped updating the temperature after several hours. I was still able to change the set point with the up and down arrows and refresh still updated the setpoint after I changed it with the ecobee app. The ecobee connect app still said “you are connected” and had the correct thermostat name.

@Abe,@becma27,@allen00se, @bgoddard79,@Jim_Salyer

According to some feedback from several users, my code is now working with the
workaround that I implemented about the connection issues.

My Ecobee Device, MyEcobeeInit, Ecobee3RemoteSensorInit need to be resync first at the main branch (just save & publish the code in the IDE).


P.S. My code now ignores some exceptions that are thrown by the ST cloud backend (i.e. ) for some users.

Please support the developer :grinning:

Hi @ben, @slagle,

Could you please close this thread as I’ve published some detailed configuration steps (and troubleshooting section) at the ST community wiki:

Also, please note of the following new thread: