SmartThings Community

My Apps not appearing on Mobile


(Jason) #1

Can any provide advice of why My Apps are not syncing into my mobile app. I installed core and had to uninstall many times before it synced over. Now installing a new smartapp that wont appear in My Apps on mobile. Installed on my buddies phone with no issues. I have logged out and back in multiple times also ensured to publish for me after installation. Any ideas why I cant get it to sync over to the Marketplace > My Apps?

Thanks


#2

Which OS? There have been some reports of it taking 15 or 20 minutes to show up on Android.


(Jason) #3

I am using the iOS app and been a few hours. Approximately 5 hours did it about 1pm


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #4

Installed SmartApps appear under “Automations” Page in the SmartThings mobile App.

“My Apps” in the Marketplace is only for Apps developed and “published for me” in the IDE … and they will only appear if published on the right shard of the SmartThings Cloud.


Smart Dehumidifier Control
(Jason) #5

They are not installed yet , but they were published for me in the IDE. I logged into the developer site and its not sync’d. I did install the same why for my buddy and showed up in his Marketplace > My Apps. Am I going to the wrong place to publish them? Is there a different site I logged into my account.


(Jason) #6

What do you mean by this. I went to developer site logged into my account and published for me in the IDE. Not syncing over to my Marketplace > My Apps.

Thanks for your help.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #7

Yah… This may not be the problem, but it is a common mistake.

SmartThings has 3 (or more?) “shards” (partitions) in their Cloud, and you need to publish to the correct one that your Account’s Location lives on. To do this, you need to login to the correct shard, paste, and “publish for me”.

Reference:


(Jason) #8

@tgauchat this worked perfectly and the site for some reason directs me to the wrong website. With these urls and this info I was able to get it published.

Thanks again!


(MacTechGenius) #9

Some of my smart apps don’t load…when I click on it. It just spins!! Strange!! Any idea??


(Stephen Mohring) #10

Newbie here,Thanks so much for this!!! it led me to here
Update:
The URL: https://account.smartthings.com2.0k should take you to your correct Shard automatically as of July 2017.

and magic presto… plus no idea why, i stayed logged in, all my device handlers and apps disappeared, I re-added the repositories, re-updated from Repo… and boom - the apps show up on my mobile.

yay and whew. but why this odd system with what looks/feels like multiple accounts under one account name?


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #11

A user (single Account) can actually have multiple Hubs (“Locations”) and they can live on different Shards. If you navigate via the My Locations list, you will always arrive at the correct Shard.

It could be made invisible to the user, but other side-effects might result.

The “average customer” is not supposed to ever use the IDE website. Never. It was never intended to be a Customer (non-Developer) portal.


(Stephen Mohring) #12

Thanks!
I figured I was a bit out of my depth as a hobbyist in the programming
world. I appreciate the clarification (and verification).