Multipurpose sensor falsely activates (both contact and three.axis) / false positives

Hey there fellow automotrons! – Have a weird issue in the last week, that Ive only been able to find one other obscure reference to. The sensor triggers when it clearly should not.

Originally I had the sensor set up as a contact open/close for a garage door. It worked flawlessly for a year. Then last week it would alert open/close with no disconnect. Im using a nickel size neodymium magnet, less than a half inch apart. I thought maybe the distance was too far but bringing it closer same result.

Could it be heat related? Thats the only variable that seems outside my control that could have changed?

I then converted it to garage mode, and created a piston based on the z-axis changing tracking current state with a virtual contact sensor (attached). Things were good for a few days, but then it triggered. When it triggers, it goes to about -942 on the Z-axis, which is odd because all my tests, that was a significant angle, which the door wouldnt sway to with wind/shake.

I havent used the full garage mode as the open/close test as it unfortunately needs to be vertical/horizontal to record, and I want a bit quicker feedback on it opening – but maybe that is where I will need to go to, as then its a very large tolerance.

Anyway, have others experienced these false positives? Ideas? thinking about swapping the sensor out and see if this one has just end-of-life’d (which sucks as it is just at about a year old).

When’s the last time you change the battery? It could be temperature related, but the battery is the first thing I‘d try. :sunglasses:

Thanks for the quick eyes!!! … Battery swap was the first thing I tried, it was at 80% when I swapped it, but you never know. No luck there.

1 Like

Is this the smartthings multi sensor or a different brand? And how hot does it get in the garage?

Getting false open/close readings is pretty unusual for a sensor that previously worked in the same location. So it usually means a Device failure of some kind. Fluctuating battery is most common, but overheating can be an issue as well. Or it could just be the device going bad all together, but again, that would be fairly unusual after just a year.

Thanks again !!! … Its the Samsung Brand, latest version (I think, its the the square rounded corner with contact, temperature, and ‘activity’). It gets into the 90s this week, which is the same as it was last summer though, thats why Im wondering if its just good old device failure.

1 Like

Its overkill, but, maybe I will set up two and have them both need to hit the tilt tolerance. False positives suck.

1 Like

Final note, also powered off the Samsung Hub for 20 minutes and let the devices resync to the mesh. So far, working better. Will keep it with the dual sensors for fault tolerance.

1 Like

@IceBear, I don’t think it’s just you… mine are doing it also. Had to turn off my Alexa announcements because they were driving me bonkers.

This is just a snippet… and all of my ST multi-purpose sensors are affected. One of them is only a few weeks old and on an interior door (no temp fluctuations.)

1 Like

There was a thread from 2017 (?) that there was a bad update that caused this. It had a lot of chatter. Not much recently – so I thought it was me. Are your contact triggers or other activating? Since you mentioned Alexa, Im thinking the contact is false triggering?

Man – so frustrating, feel bad for people that are using this for a security solution.

1 Like

Yeah, it’s never been a good security system because you could neither defer nor deny platform updates. So things can change at any time without notice. Sometimes that’s good, but sometimes that’s a glitch, and sometimes it just means that your system is unexpectedly unavailable. :disappointed_relieved:

In the US, it’s not UL listed as a security system, and never has been, with the exception of the ADT/smartthings which is now in “end of life“ status. (ADT bought a different company to be its do it yourself security offering.)

The interior sensor triggers the light on/off just fine and I never see the light come on unexpectedly (it’s on a louvered door in my family room, so I’d notice.) When comparing actions in the IDE, it does not appear that the “acceleration is active” activity is triggering the light. But, I’m using open/close as the trigger rather than acceleration.

The only thing the exterior door sensors do is trigger announcements. I am getting the announcements, just not always timely. Like, I’ll get 10 come in all at once a few hours later. Or, sometimes they are timely, but they repeat themselves. I don’t think the 10 announcements all at once problem is related (more likely stems from new ST skill in Alexa). The repeat messages… ??? Alexa activity doesn’t show when announcements were made, so I can’t go back in history to compare the timing. But, if they are working like the interior one, then I guess I don’t have a reason to suspect false positives as the root of my problem, since those are triggered by open/close also.

FWIW, my big garage door shows “acceleration active” activity several times a day, every day, and that door has never been opened since I put the sensor on it.

I thought I had a bad multipurpose sensor because it was always triggering acceleration on/off so I replaced it with a spare. Then I noticed that the device page for the newly added multipurpose sensor (exact same model) was different since it included Axis in the device page. All of my other same model multipurpose sensors didn’t show this Axis in their device page. So, I readded the bad multipurpose sensor and it too now has the Axis listed on the device page, and now it seems to work fine so it appears that it wasn’t bad.

So, to avoid this happening to my remaining in use multipurpose sensors, I navigated to the IDE devices page and changed every multipurpose sensor to ‘SmartSense Multi’, and then back to ‘SmartSense Multi Sensor’. Now all of them show the Axis in their device page. I hope by doing this that I’ve avoided this acceleration thing happening to them in the future.

1 Like

Thanks for this, I will try later – by device page, you mean in one of the apps (classic or new)? … and by IDE page, the smartthings graph web page?

This is good intel - thank you

@perduewv – Ive noticed that acceleration triggers a lot, and I think it is meant to - such that it does track the movement of the device. The trick is figuring out how to monitor/alert so that wind/rattle on something like the garage door does not trigger it.

Ive been having good luck so far with the dual sensor combo on the door – but then again, watching the log, Ive only have one of the sensors drop below my threshold (-950 Z) which is still odd since that angle during tests seemed to be far greater than any ambient movement of the garage would be

The device page in the new SmartThings Connect app.

Sorry about just referring to it as IDE, but most posters here simply refer to it that way, SmartThings Groovy IDE

That particular link will only work for some people. :disappointed_relieved:

Different accounts are on different “shards” of the smartthings cloud. Instead, use the universal sign-on URL, it will work for everyone, as it will automatically direct people to the correct shard for their account:

The URL: should take you to your correct Shard automatically

FAQ: How to find out what "shard" (cloud slice IDE URL) your Account / Location is on?

1 Like

I learned that my WebCore was out of date (missing some new modules, but running current release). Ive since updated, Im am not sure if this could of also been an issue. I havent had a false positive since I added the redundant sensors.

1 Like