Multi Purpose Sensor - Use as a Garage Door Tilt Sensor

OK, thanks anyway. My guess is that they’ll have me spending more money before it’s over, but I saw that coming with the required updates. Take care!

In the IDE, my device type shows it is using the ‘SmartSense Multi Sensor’ device handler so you may be using the other ‘SmartSense Multi’ device handler instead. If so, then try changing the device handler from ‘SmartSense Multi’ to ‘SmartSense Multi Sensor’ and then you should see the ‘Use on garage door’ option like I do and hopefully it works for you.

I tried this and the garage door setting appeared, however, the device no longer properly communicates any activity with the hub. Looked promising at first!

Well, taking your idea a bit further, I set it as a garage door multi and it works just fine! Thanks for the help!

SmartSense Garage Door Multi fixed my issue with using the MultiSensor on a garage door as a tilt sensor. SmartSense Multi and SmartSense Multi Sensor didn’t work for my garage door sensor. Thanks!

How did you find the “SmartSense Garage Door Multi”? I did the same as you and connected the MultiPurpose Sensor via the ‘SmartSense Multi’ where I only see the Temperature Offset under settings.

  1. At web address: graph.api.SmartThings.com/device/list I clicked on my Garage Overhead Door device.
  2. At the bottom of the web page displayed: click Edit
  3. Click on the pull down menu in the ‘Type’ box (5th box down)
  4. Choose: “SmartSense Garage Door Multi” from the list of choices.
  5. Click Update at the bottom of the Edit Device page.
1 Like

People following your instructions should go to account.smartthings.com so that they are directed to the correct instance of graph (aka shard).

Once logged in, click on “My Devices” at the top to get to /device/list.

1 Like

Hello Everyone,
I used to use the smartthings multi-sense for my garage door for many years. Now it suddenly doesn’t show if my garage door is closed. all the sensors work, I can see the numbers change with tilt and temp and vibration, just doesn’t know that door is closed when horiozontal. I found this thread but the new IDE is totally different. Of course now I don’t have access to classic app and not sure where to find the “use on garage door”.

Any help on how to check this setting on the new IDE or the new smart things app would be appreciated.

Thanks,

can you identify which version you have for the sensor?

Below is a list of known devices which will be affected by the migration away from Groovy DTHs to Lua Edge drivers**.** Some devices may lose partial functionality or full functionality within the SmartThings app. These devices may continue to work outside of the SmartThings app.

SmartThings
SmartSense Multi Model STSS-MULT-001
Sensor will continue to function but will no longer work as a “Garage sensor” using a specialized DTH.

Hi,
The model I see in the IDE for this sensor is:

PGC313

So, what is the next step for me?

Thanks,

I can’t find any info on PGC313 old smart things multisensor in the article. It seems to work and I can see all x y z values change but smart things always shows it open. Smart things shows contact sensor open.

Anyone has the same problem?

Could this be a different device handler or driver that I need? I guess it needs to be told that this is a garage tilt sensor and not contact sensor.

Thx

Try selecting the 3 dots on the garage door tile in the SmartThings, select Setting and there should be a setting ‘Use on garage door’

All I see there is temperature offset :frowning:

Until about a week ago, have been using an original SmartThings SmartSense Multi STSS-MULT-001 as a tilt sensor on my garage door. My automation to lock doors just stopped one day. The sensor itself acted very strangely so I pulled the batteries and brought it back to life.

It works now including the 3-axis sensor but it does not work as a tilt sensor so that software setting has been deactivated. The Settings selection only shows the temp offset. Only the magnet will make it show closed.

Is there a way to turn this back on?

Or is there a different sensor I can purchase that will act as a tilt sensor?

Thanks

edge driver for 1st generation smartthings multipurpose sensor with preference for use in garage doors

It seems that no one decides to try to save these smartthings devices from the garbage to use them as tilt detectors.

I have no device to test and I can only see, with a new multipurpose sensor samjin, that there is no fatal error that stops the driver from working.

I have added the fingerprints, the profile with the garage door usage preference and I have adapted the “smartsense-multi” subdriver from the stock driver to my driver.

I have created a TEST version

─────────────────────────────────────────────────── 
 Name         Zigbee Contact Mc-TEST
 Version      2023-08-14T16:11:35.91346802
───────────────────────────────────────────────────
- id: Smartsense/multi/1
    deviceLabel: Multipurpose Sensor
    manufacturer: SmartThings
    model: PGC313
    deviceProfileName: smartsense-multi
  - id: Smartsense/multi/2
    deviceLabel: Multipurpose Sensor
    manufacturer: SmartThings
    model: PGC313EU
    deviceProfileName: smartsense-multi

I think it should be enough to install the driver in the hub and make a driver change in the app.
I didn’t need to clear the app cache for the profile to appear with the garage door preference.

Try it and if it doesn’t work and someone sends me the error log, I’ll try to fix it.

I hope it works well!

UPDATE:
Something went wrong in publish TEST version to the channel and I saw now that it was not posted to the channel.
I just published it, but Zigbee contact Mc is the same as TEST version now, although it seems that nobody cared about the publication or not

4 Likes

Hi,

I would like to test this. New IDE is all different so am not sure how to get this to work now. From what I understand I need to add a channel, and then select a driver that supports garage door tilt from that channel for my multisensor. I don’t know how to test your code but if u send me some instructions on how to install I would be happy to try.

I added the “Mariano Shared Beta Driver” channel and installed driver “Zigbee Contact Mc” but when I go to the multisensor in the smart things app and select to change driver it says "no results found. i tried to change driver from IDE under the device setting to the Mc driver but I got “Error changing device driver to “Zigbee Contact Mc”. Ensure that the driver you are trying to change to has a valid fingerprint match with this device.” My device setting says I have model “PGC313”.

Am I missing a step? Or there another way to do this to get my garage tilt sensor to work again for my garage?

Thanks :pray:

Use API Broswer+ to locate the manufacturing code for that device. Give that code to the developer and ask that it ba added to their Edge driver. Once the developer adds the fingerprint and pushes out the update, you will be able to switch the driver. Unless the device is not supported and the developer would let you know.

Always best to post in the developer’s thread.

Tagging @Mariano_Colmenarejo

Don’t call it new IDE :slight_smile:

Thank you so much. WOW! API Browser is really nice… it simply says:

image

Pretty generic I was expecting some kind of a code :slight_smile:

LOL :slight_smile: what is the correct right name for the “new IDE” ? :slight_smile:

I worked with @Mariano_Colmenarejo and he fixed the Zigbee Contact Mc driver to add the garage setting and it works like a charm.

Thank you @Mariano_Colmenarejo so much for your good work and efforts.

Thank you…

2 Likes