MQTT Bridge events not toggling devices


#1

Hi,

My first post… please excuse any noobs mistakes. Wasn’t sure if I should post here or in the HA forum.

I have the MQTT bridge up and working fine, sending message back and forth between HA and my ST Hub. Only issue is that events sent from HA are not being recognized. I have two lamps attached to switches, one Lutron Caseta and the other a HomeSeer WS100+ switch. Here is my HA config for the lights:

light:

  • platform: mqtt
    name: "Office Light"
    state_topic: "smartthings/Office Light/switch"
    command_topic: "smartthings/Office Light/switch"
    payload_on: “on"
    payload_off: “off"
    optimistic: false
    retain: true
  • platform: mqtt
    name: "Standing Lamp"
    state_topic: "smartthings/Standing Lamp/switch"
    command_topic: "smartthings/Standing Lamp/switch"
    payload_on: “on"
    payload_off: “off"
    optimistic: false
    retain: true

On the ST log side I see the event coming in as:

a2f05ea3-7695-462d-a4c6-e093170e0247 12:02:38 PM: debug Received device event from bridge: [name:Standing Lamp, value:“on", type:switch]
d8fe8b77-b0e0-452c-aac8-c419b7e6fc46 12:02:38 PM: debug Parsing ‘index:07, mac:E4CE8F66E0BE, headers:UE9TVCAvIEhUVFAvMS4xDQpob3N0OiAxMC4wLjAuMTA4OjM5NTAwDQphY2NlcHQ6IGFwcGxpY2F0aW9uL2pzb24NCmNvbnRlbnQtdHlwZTogYXBwbGljYXRpb24vanNvbg0KY29udGVudC1sZW5ndGg6IDU4DQpDb25uZWN0aW9uOiBjbG9zZQ==, body:eyJuYW1lIjoiU3RhbmRpbmcgTGFtcCIsInR5cGUiOiJzd2l0Y2giLCJ2YWx1ZSI6IuKAnG9uXCIifQ==’

Added some additional logging in the SmartApp which returns:

device=Standing Lamp property=switch value=“on"

If I trigger from the smarthings app I see on the HA side:

2017-06-26 12:04:50 DEBUG (MainThread) [homeassistant.components.mqtt] Received message on smartthings/Standing Lamp/switch: off

But the state never changes. Maybe a light is not a switch in the parlance of Smarthings and HA. I feel that I am so close to having this working yet am missing some key understanding


(Andy) #2
light:
  - platform: mqtt

Try listing them in the configuration.yaml as a "switch: instead of a “light:”.

switch:
 - platform: mqtt

See if it works under those settings.