Motion Sensor Losing Connection and Firmware Will Not Update

Hi all,

I have a Smartthings Motion Sensor STS-IRM-250 that keeps losing it’s connection. It is closer to the hub than most other things on the network but it just keeps going dead. Steps I have taken are:

  • Moved it closer to the hub, about 15 feet away
  • Replaced the battery
  • Removed and readded it several times
  • TRIED to update the firmware several times (currently it is 0x00000019, newest is 0x0000001B)

For the firmware, I have OTA enabled for all devices on Zigbee and I have hit the ‘Check Now’ button several times. When you List Events, I am seeing ‘Motion Sensor firmware update started’ but nothing is happening.

Is there some kind of trick to it that I am not reading or doing? I have read you need to remove power after sending the command so it can reinitialize? Any help is appreciated!

The device worked flawlessly for nearly a year and then all the sudden started having connection issues. Thanks in advance!

I have the same problem with the new Smartthings motion sensors. I have two, one has updated sucessfully the other will not despite trying to force it. It now appears to drop out on a regular basis while the updated one does not, any ideas?