Monoprice Zwave + Door Window Sensor


(Jeffrey Bittel) #1

Just received this yesterday. I had no problem with ST finding it and including it as one of my Things. It appears to be working under Recently it will show open/closed whenever I move the magnet off. But what I can’t do is get it seen as a sensor under automation. I would like to have it send me a text message when activated. I’m probably missing a simple step but I cant figure it out.


(Tony Fleisher) #2

Please provide detail on what you are referring to as “under automation”. In the smartthings world this could mean many things.


(Jeffrey Bittel) #3

Tony, what I’m trying to do is place this in a mailbox outside. When the mailman comes I would like to receive a text message that he arrived. Eventually, I will add a ST doorbell that will also chime when the mail is delivered.

My thought was under automation I could build a new routine and then under “Something Opens” add this sensor. When I try this the Monoprice Door Sensor is not shown as a sensor option.

Hope this helps clarify? Maybe I’m going down a completely wrong path? Should an App be associated with this sensor? If so can you recommend one?


(Jason) #4

Are you referring to Monoprice #24259? What do you have the device type set to in the IDE? I have mine set to Z-Wave Plus Door/Window Sensor and it works just fine. Are you trying to create a new Routine that does something when it opens, or are you using SmartLighting to do your ‘automation’?


(Jeffrey Bittel) #5

Dreamwalker. Yes, that is the model type.


(Jason) #6

What device handler are you using?


(Jeffrey Bittel) #7

None. Probably my BIG problem. What do you suggest?


(Jason) #8

Go into the IDE and see what it is. If it isn’t “Z-Wave Plus Door/Window Sensor” I would change it to that.


(Jeffrey Bittel) #9

OK, extremely ignorant question, but how do I do that? I do not see that on the phone app.


(Jason) #10

Ahh, now I get it. I’m must sound like a fool that just assumed you knew what I was talking about. lol Sorry. SmartThings has a sort of ‘behind the scenes’ interface for developers. You can login and change things. Go here and sign in: https://account.smartthings.com/login

Once you’re in the IDE you can look to see what the device type is for your devices. You can then change them as well. At the top of the page is ‘My Devices’ find the Monoprice sensor and in the ‘Type’ column it will tell you what kind of device it is set to. If you click the device’s name you can then edit the device. In the ‘Type’ drop-down you can choose “Z-Wave Plus Door/Window Sensor”

It’s much easier to do this all on a computer.


(Jeffrey Bittel) #11

Bingo that was the problem. Thanks for the good help!


(www.rboyapps.com - Make your home your butler!) #12

If you have access to RBoy Apps you can use the handler we’ve developed for it here:

The 24259 an excellent mailbox sensor with an easy mount/removal and tamper switch with a very handy external contact terminal built into it for using it with pre-wired boxes/doors. The handy feature is that it runs with 2 AAA batteries as you’ve probably seen.

The tamper switch part if very cool because in a mailbox it’s pretty exposed and if someone’s trying to make off with it, you can get an instant alert that’s someone’s removed it.


(Jeffrey Bittel) #13

OK, so for about an hour I had this device working perfectly. I had to remove another device and I think I made a mistake somewhere in the process and this device disappeared from my “Things” list. I’m sure I was the culprit, just not sure what I did.

However, now I can’t get it to pair with the hub again. Any ideas what I should look for first?


(www.rboyapps.com - Make your home your butler!) #14

2 options:

  1. Exclude the device
  2. Reset the device (which will also automatically exclude itself)

Instructions:
EXCLUSION INSTRUCTIONS: If you deleted the device without excluding it won’t pair up again until you exclude it.

  • Set the hub into exclude mode (log into the IDE -> My Hub -> View Utilities -> Z-Wave Exclude.
  • Bring device within 5 ft of hub
  • Put hub into exclusion mode
  • The light should be solid red, if not then press the button for 5 seconds and release it, now it should be solid red
  • Press the button for 1 second and leave it
  • When the exclusion is successful the light start flashing

FACTORY RESET:

  • 24259 : Press and hold the Z-button for 20 seconds, the lights will flashing after about 5 seconds, keep holding it until the lights stop flashing

Now pair it again


(Jason) #15

You’ll want to exclude the sensor, then you can add it again.


(Jeffrey Bittel) #16

Thanks! Great help. BTW I do have your subscription and enjoy your work.