Monoprice Z-wave plus switch drops off network

Has anyone experienced the monoprice z-wave plus on/off switch dropping off the network? I’ve had it drop off twice now, both times about 2 days after I set it up. Last time I couldn’t get it to reconnect and had to re-add it as a whole new device. At this point kind of useless.

So I found today that I could sometimes control the outlet via the app, but the tile in the app didn’t correctly show the state of the device. So I could turn on and off but the app always shows off and registers no events in the history. Does this sound like a handler problem?

Maybe try a Z-Wave repair in the app. Could be a range issue and needs to mesh with a closer neighbor.

I have a couple of ge outdoor plugs doing the same thing, wrong state on the app but can be controlled.

Good suggestion, and tried it, but no luck. I have 2 hard wired z-wave switches in the same room and they have been doing fine. Sadly, even after my 3rd reset, its already acted up again. Still can control but no status update. Sadly, likely going to have to stop using it. I am using it to enable my kids to turn on a space heater and this will turn it off after 15 as a safety measure. Since the status doesn’t update the routine to turn off doesn’t fire.

So it’s started acting even more odd. Status in the app device list is correct, status in the device detail page within the app is incorrect. No events recorded in log. Unplugged and re-plugged and now all works fine. Think I am going to start looking for a new outlet as I don’t feel comfortable using this as a safety device with it being so flaky.

So I had Monoprice RMA the unit and got a new one. Stopped reporting status after 1 day. Can still control it but not reporting any activity. Looks like I am going to have to just scrap using it. Can’t tell if its the device or the hub.

In case anyone else comes here looking for answers, a possible fix. I posted a question on the monoprice site and got this answer from Frankpjr. I gave the stock z-wave device a try along with an unplug/replug, and its been 4 days and its still working. Fingers crossed.

“I have 3 of these and I also have had trouble with them every once in awhile. I tried in IDE to change from generic z wave to Plain Z wave device with some success. I have 1 that has been rock solid working for 8 months that just last week decided it no longer would find it. The other 2 seem to work fine as far as auto trigger controlled but every once in awhile I have to unplug it for a few seconds then reconnect it and all is fine for months. I wish I could tell you more but all I can say is they have been working well enough now that I wonder if it is because of more devices making stronger mesh network where when I had only the 3 it was constantly dropping them”

I have two Monoprice 11995 plugins and 1 GE zwave plugin and I have the exact problem as farlicimo with my monoprice zwave plugin model 11995 (different problem with the GE plugin). I tried to resolve the problem by unplugging the plugin from the outlet/AC power then plug it back in. That fixed the issue for about 2 hours and the problem came back after 2 hours (I have tried this two times and the problem came back both times).

Then I read this post, and thanks to paulmike3. This is how I resolved the issues for all three plugins.

  1. Unplug the plugin from the outlet for 10 secs and plug it back in.
  2. Wait 20 secs after you plug it back, open your smartthings app and go to Zwave Utilities and hit the repair zwave network button. The controller will repair and fix the problem. Do this one zwave item at a time.
  3. You maybe able to repair all your zwave products all at once. But I haven’t tried that. I repaired one at a time and it worked for me. So the Zwave plugins have been working (both monoprice and GE) for 4 hours now and this method seemed to work.
  4. Now the status of the plug is correct and recent activities are being shown. On and off also works like a charm.
  5. Will report back after a week and update my post. (if I remember)

Will be interested to hear how it works. Once I switched handlers it has been far more stable, but still seems to inexplicably stop updating status (but still responds) after a few weeks then eventually falls off and stops responding. It seems to me the problem occurs when there are prolonged stretches of non use. For normal usage I would probably just live with it, but I am using on a space heater to make sure gets turned off so reliability is key. I’m on the hunt for a better outlet that can handle the load.

Just to round this out, I kept having problems. Got frustrated enough that I just swapped out for a GE Z-wave switch and been rock solid for weeks.

I have two of these devices. Neither have worked with any sort of reliability. They’re garbage.