Monoprice HKZW-DWS01 Contact Sensor Keeps Going Offline

Another week and offline again… Does any one have a solution for these Monoprice Wave Plus contact sensors (Model HKZW-DWS01) that continue to go offline…

Are they really offline or are they just marked offline? Easy to check. Just open the door or window and see if they respond.

If they respond they are really on line and changing the wake up intervale might help.

If they don’t respond they are truely off line and you may need more repeaters.

These all worked for the last few years before moving to Edge drivers and the 2 that it keeps occurring to are within 10 feet from the hub. I have tried setting the timeout to 30 and unable to get the parameter to update. After using the config driver and the “Send” action when I use the “Get” action it shows 0.

If the wake up interval is still coming back as 0 then the device is never doing its wakeup checkin and will show offline once its inactive for a period of a few hours (exact duration is unknown, but likely 6-12 hours).

When using the Config Mc tool to set the new wake up interval, you’ll need to wake up the device in order to get it to read the new setting. From the manual for this device:
image

A default wake up interval of 0 sucks, and the stock drivers don’t override this value or allow you to change it so it makes sense that these will keep showing “offline” within ST.

If you’d like we can add support for the device on the Zwave Sensor CS driver. The wakeup interval is adjustable within the driver and will have a sensable default applied. What is your device fingerprint (viewable on the Advanced Web App under ‘manufacturer code’). Is it 0208-0200-0008 or 0208-0201-0008?

1 Like

Thank you, below is the information.

Manufacturer code:
0208-0201-0008
Model:
0201-0008

They also dont report battery status properly. I can put new batteries in and they show 15%.

1 Like

@csstup can you confirm if this has been updated in the driver?

Not yet. It will be a few weeks.

3 Likes

I thought my battery had finally died after 4+ years, turns out it was probably still going strong, just the EDGE driver and now ST reporting it offline. It does report once the contact status changes. The battery last reported around 30%. What a shame. It was probably fine.

@csstup - Sorry to bother, but has this been added yet? I have the same device and experiencing the same issue. Thanks for your support!

Having the same issue. Respectfully requesting if an updated Edge drive is available?

I’m having the same problem with this sensor. It keeps going offline until I open and close the door to wake it up again. I was about to throw the sensor away as defective but decided to check online first. Is there any development going on to add a driver for this sensor?

@csstup can you confirm if this has been updated in the driver there are a few of us that are having the issue?

Short of a driver solution, is there any way to change the wake up interval by sending commands to this device in SmartThings? Please share a detailed procedure if you have one.

Right now I am using Z-Wave Masquerade (contact sensor mode) from the philh30 channel. This driver seems to be the only one that properly shows this device as only a contact sensor. All the other drivers try to show too many unsupported sensor readings and keep giving error messages about not updating all its settings.

I’ve been struggling with this for quite some time. I hopped into my.smartthings.com and took a look at available drivers on my HKZW-DWS01, it shows the Z-Wave sensor CS is available. I don’t remember that being the case prior. I’ve changed mine over to it and will report back if it stays online.

Added untested support for the HKZW-DWS01 to the “Zwave Sensor CS” driver. Its not yet mentioned on the supported list as I don’t have one to test with and will need someone here to let me know if it works or not. Its been released on the production channel, if you already have the Zwave Sensor CS driver installed, it will update within the next 12 hours.

3 Likes

Thanks so much for looking into this again and adding support!

I had given up and decommissioned my Monoprice contact sensor to replace it with an Ecolink sensor instead. I still have my original Monoprice sensor which I pulled out again to test this out.

I was pleased to see that the driver now automatically recognizes the sensor as a Monoprice sensor when adding it to SmartThings and it gives it the correct icon and animation as well! The settings now include: low battery level, wake-up interval, and battery update interval. The open/close indications are working correctly. I will monitor the sensor over the next few days to see whether the disconnected sensor issue comes back.

One enhancement would be to add in the tamper indication which is supported by this sensor as well.

3 Likes

@csstup After the driver update, the status is updating properly but it is still going offline with the wake up set to every hour.

Suggestions:

  • If you didn’t re-include the device with the new driver, try that. Just switching to the new driver wouldn’t trigger the logic to set the wake up time.
  • If you did a clean include but it went to another driver first, same issue. It should find Zwave Sensor CS as its primary driver so it can set the wake up time during configuration.

With the default wake up time of 0 seconds (never), the device never wakes up to check in, and won’t reset its wake up period either (which normally would take place during a wake up).

If you did a fresh include and it found this driver first and it still doesn’t work, then sorry - to debug it I’d need a device here to test with.

I have reincluded the device and this driver was added by default but device still goes offline with the wake-up set to 1 hour intervals.