Monoprice 10761 Multizone Audio and iTach IP2SL

Yes, seems like it! I haven’t tried doing any “automating” with webcore yet, but in terms of control via SmartThings, it’s alive!

My first attempt (so be gentle) at writing a device handler so I swung for the fences. :smiley:

Probably was a cleaner way to write it all but it works for me and my use case. I use the ios “Monoprice Whole Home Audio” app when I’m home since it’s full featured, but for remote or Webcore control, I rely on this handler.

I do have to fix the volume/bass/treble control for levels under 10, it sends the command as 5 instead of 05.

To label your zones, just replace the ZONE1NAME with your own and replace the SOURCE1NAME, SOURCE2NAME, etc with your source labels. I don’t think I can use a variable for this.

Set your IP and Port of the iTach under settings

This is awesome! Thanks poelock. I may switch to iTach if my Pi becomes unreliable

This is great… I will test it out tonight when I am home. I’ve been wanting to update my DHT and yours definitely has a lot of great things! +1 for Webcore integration

@poelock I tried setting this up tonight, but couldn’t get it to work.
I copied your DHT, added a device with that type, added the IP:PORT in the settings, but couldn’t get any of the items to work. I even put debug statements in your code to see what was calling and I can see it being executed, but none of the commands were working. I don’t see anything in the hub console. No errors are thrown or any other info statements.
Can you point me into the right direction?
I also used an android app (similar to your IOS one) and that one works.

@oyzerskiy - What do you have for the Device Network Id. I can’t recall if i hard set mine or if it pulled in from the handler but I pretty sure the Device Netword ID needs to be the IP:Port in hex of the IP2SL. ie. mine is set to C0A80028:1387.

Unfortunately, my IP2SL seems to have died or is being a bit finicky lately…I can’t even connect with the app. Also helpful to have Serial-TCP free from Comm-Front running on a PC to monitor the IP2SL and the commands it’s receiving

I dont think you can use the physicalgraph.device.Protocol.LAN protocol. From what I remember reading, there’s a bug in the Smartthings hub where it strips some of the things needed. (see this TCP Commands not transmitting with HubAction?)
You may have to rewrite it to something like this…
new physicalgraph.device.HubAction(“body”: “$theCom\r\n”, “headers”: [ HOST: HostAddress(), “Content-Type”: “text/plain; charset=utf-8”])

Well it was working without issue for me the other day. WebCore turned on zone, selected a source and then played “welcome to the jungle” as I pulled in the driveway. :slight_smile:
It wouldnt accept any responses from the iTach to have proper status updates. But since I was using the “Home Audio” app locally, I didn’t need the current status to be valid in SmartThings anyways. Just wanted to send commands to it.
Unfortunately my IP2SL no longer is accepting commands from anything for some odd reason.

Has anyone had luck with this using either the IP2SL or the Flex lately?

I’m wanting to switch over to the globalcache hardware away from running the pi and redloro’s implementation.

I’ve gotten the android app working fine, so I know the Flex is working. However, I’m not able to get this to work at all.

I’m not exactly sure what the previous post about “new physicalgraph.device.HubAction(“body”: “$theCom\r\n”, “headers”: [ HOST: HostAddress(), “Content-Type”: “text/plain; charset=utf-8”])” means; so any help would be much appreciated!

I use the Flex daily. you said you have the android app running and it’s working (which app are you using?).

@oyzerskiy, after a while, I was able to get your device handler working, so it’s definitely connected right / working from SmartThings. However, I’ve still not been able to get @poelock 's working at all. Same IP settings of course, and just zero response/control.

As far as the separate app goes, I’m using this: https://play.google.com/store/apps/details?id=com.monoprice.audiocontrol&hl=en_US

Any chance on getting Redloro’s integration to work properly in the new app?

Just hoping I can get any traction on this. Would really to get this to work properly in the new app

Thanks

Yeah I wish there was some traction on this as well… I am still able to use some of the code as I am using WebCore on the back end to do some of the tasks. The device inside the new app is completely useless as they took away a lot of the functionality.

I’ve emailed Rboy twice with no response. My suggestion would be to have everyone interested to email him about recoding this integration.

I’m really interested in this as well, as I will be purchasing either the Monoprice 10761 or HTD MCA-66. This will probably sway my decision.

Rboy probably has endless emails going to his box at the moment because of this transition to the new Smartthings App… Speaking of which I need to email him. :joy:

If you’re looking at the 10761, check out this upgraded version. A bit pricier though.

Has anyone been able to use the Monoprice amp with the iTach within SmartThings? I also have the Home Audio app, works great, would just like to automate.

Take a look at this thread…

I have a few integrations:

  1. I can use a standalone app (similar to the itunes one) but it’s for android (https://play.google.com/store/apps/details?id=com.monoprice.audiocontrol)
  2. I have also set up a Device Handler (along with a dummy device) that allows me to control all the options via Webcore. The device inside of smartthings is useless this way. IT doesn’t show any useful options and I didn’t want to spend the time trying to fix it. Since I am using WebCore, it allows me accomplish all the items I want. I have certain Zones automatically turn on/off at specific time of days for example.
    If I need to manually turn on a zone, I can either go to the standalone app and turn it on (#1 above) or I’ve even created Virtual Devices (Smartthings) and add them to ActionTiles and can turn them on/off that way if needed as well (uses webcore on the backend). You can turn volume up/down, etc as well if you want to customize further.