Modified Oso PlantLink Sensor DTH

plantlink
dth_sensors

(Tony - SmartThings Unpublished Contributor ) #1

Modified DTH for OsoTech Plantlink Sensors

This is a SmartThings DTH for Oso Plantlink soil moisture sensors. It is based on the Plantlink 2015 OsoTech DTH.

I added Capability “battery” and Capability “water”, so that I could better monitor the devices using SmartTiles and CoRE.*

The “battery” attribute just mirrors the existing linkBatteryLevel attribute.

The “water” attribute is based on the existing plantStatus attribute. According to SmartThings’ capability reference (http://docs.smartthings.com/en/latest/capabilities-reference.html#water-sensor), “water” sensors can only be “dry” or “wet”, so the “water” attribute will:

  • read “dry” if plantStatus is “dry”, “needs water”, or “too dry” and water sensor capabilities, or
  • read “wet” if plantStatus is “good”, “too wet”, or “watered”

The device looks substantially the same. It keeps “plantStatus” as the main attribute, and adds the “water” attribute on the bottom left. It looks like:

*SmartThings really needs a “soilMoisture” capability…


(Megan) #2

I am going to try and play with this, this week. I like my plantlinks, and wish I could order more.


#3

Just tried install this device handler, and I got this error:

Org.springframework.dao.DuplicateKeyException: a different object with the same identifier value was already associated with the session: [physicalgraph.device.CapabilityDeviceType#physicalgraph.device.CapabilityDeviceType : (unsaved)]; nested exception is org.hibernate.NonUniqueObjectException: a different object with the same identifier value was already associated with the session: [physicalgraph.device.CapabilityDeviceType#physicalgraph.device.CapabilityDeviceType : (unsaved)]

Any idea what to do?


(Tony - SmartThings Unpublished Contributor ) #4

Did you already have the devices linked to your ST account? If so, you first need to delete them and the service manager, then reinstall.


#5

it was setup on my ST earlier, but I did delete smartapp and device, and tried install the device handler in ST afterwards, but still got the error.


(Tony - SmartThings Unpublished Contributor ) #6

And you made sure to publish the new device type?


(Jarrett Campbell) #7

I’m getting the same error upon installing the DTH. I’ve never owned a PlantLink and have nothing installed that should conflict (mine is on the way from an Ebay vendor and was trying to prep for it).

@Fredrik, @infofiend – did you guys ever resolve this?