SmartThings Community

[MODIFIED] Netatmo Weather Station

weather
smartapp_weather
dth_sensors
dth_weather
netatmo

(Nathan Block) #309

What “Orth settings” are you referring to? I triple checked the client id and secret and went through all 6 different IDE sites again, but it’s still not working.

Are there supposed to be any devices listed on the dev.netatmo.com page in the app? There’s a list of “Scope available” and it lists “read station”, “read thermostat”, etc, but I don’t see anywhere that it actually shows my devices.


(Nathan Block) #310

Figured it out. For some reason it didn’t show the list of devices when I first logged in. I went ahead and saved the settings without any device selected. Then went back into the app and both my devices are showing up now.

Thanks for the help!


(Mike) #311

Hello, I have Created the app in Netatmo Connect, added the SmartApp for the Base Station, added and published the Device handlers for the Base, and Outdoor Modules.
I go back to the IOS app and it says Netatmo is now connected to SmartThings.
When I select Next to proceed, I modify my preferences, then select Devices. the Netatmo Base shows up. However all the readings are from the Outside module. I see nothing for the actual inside module. Any idea what is wrong?
thanks


(Mike) #312

I see the outside module but not the indoor base station screen on my phone.

Here are the log messages, looks like a groovy.net address problem. Not sure where to look for that.
Thanks if anyone can point me in the right direction.

34bcba82-48d6-4b4a-9962-c6c63a59eaf1 12:31:42 PM: debug Error: groovyx.net.http.HttpResponseException:
34bcba82-48d6-4b4a-9962-c6c63a59eaf1 12:31:42 PM: debug Delete: []
34bcba82-48d6-4b4a-9962-c6c63a59eaf1 12:31:42 PM: debug In refreshToken
34bcba82-48d6-4b4a-9962-c6c63a59eaf1 12:31:42 PM: debug Refreshing station data
34bcba82-48d6-4b4a-9962-c6c63a59eaf1 12:31:42 PM: debug getChildDevices(false), children=0
34bcba82-48d6-4b4a-9962-c6c63a59eaf1 12:31:41 PM: debug apiGet: Call failed groovyx.net.http.HttpResponseException: Forbidden
34bcba82-48d6-4b4a-9962-c6c63a59eaf1 12:31:40 PM: debug In refreshToken


(Mike) #313

After publishing the device handler for the Basestation, I do not see it in the list of devices, anywhere, on my iPhone, or in the simulator. I do see the outside module in both, but I have published them several times, and done everything I can to get it to work. Any help would be appreciated.
Thanks


#314

Make sure OAuth is enabled. Double check your client ID and secret are correct, make sure there is no space before or after. Try different server urls.


(Mike) #315

Thank you for replying.
OAuth is enabled and true for the Smartthings app. That works. But the device showing up in the device list is only the Outdoor module even though I have the Base DH installed. So the SmartApp is connected. It looks like it is not seeing the DH for the base. I did try the URLs - https://graph.api.smartthings.com/ and https://graph-na04-useast2.api.smartthings.com/
My smartthings side goes to na04.


(Realy Living Dream) #316

Sorry @cscheiene, but I Fubared something and can’t figure out what.

I installed the new Netatmo security ST app from CopyCat. ( Out of laziness? ) I used my same Netatmo Client ID and secret I already had for your app. Since both were going to ST, I honestly didn’t think it would be an issue. Everything went fine setting it up ( once ST fixed the IDE GitHub issue anyways). Then I noticed that all my NWS stopped updating in ST last update looked to be the exact time I used my same Client ID and secret.
So I went into Dev.Net and created a new app and got new Client ID and secret, entered them into ST and renewed 0Auth. When I logged into Netatmo from ST app, I got the " you can’t currently add this" under devices. So after scanning through this thread I completely removed all of my Netatmo weather devices and the DH, smartapp. Did a completely fresh install with my original Client ID and secret, new 0Auth. Same result. Removed everything in IDE again and reinstalled with new Client ID and secret. Devices are still unavailable to select.

I’m at a loss at to WTF I did to break this. Especially since I have totally deleted everything and done fresh installs, yet it seems like nothing has changed. Any idea on what I did, how to fix it would be appreciated


#317

Strange, I would not think that should be a problem.

I have updated with some additional error handling borrowed from Netatmo Security app.
@RLDreams and @mstahlman please try again and PM me the logs from when you try to install, it might contain some sensitive information


#318

I’m stuck.
Android phone just hangs after tapping “Next” on the screen that says “Netatmo is now connected to SmartThings”.

Below is the error fron the ST log.
4:45:23 PM: error java.lang.NullPointerException: Cannot get property ‘data’ on null object @line 403 (doCall)

Any help is appreciated,


#319

I have reverted some changes, please update and try again


(Scott Scoob Maloney) #320

Just installed today everything went smooth, all sensors reporting, Thanks!


#321

I now have “Netatmo (Connect) Modified” in the SmartApps.
Now what.
When I click on it my only options are “Remove” and “Next” (which brings me in a circle.

I does not show up in “Things” What did I miss?

Thanks for all your help.


#322

Did you follow the installation instructions in the first post?


#323

Yes. I don’t know why it didn’t work but I removed the SmartApp from the phone and re-installed and now it works fine. ???
Thanks for all your hard work and help. You are a real credit to the ST community.


#324

I have followed the steps in the OP twice through perfectly. I am having an issue like one of the posters above where I can’t add any devices. It says “You can’t currently add this.” Any suggestions?

Thanks


#325

Hi cscheiene
Thanks for the good work an detailed instructions !
I was able to integrate netatmo weather station and it’s showing perfectly right in smartthings

I was wondering if there is any smartapp that I can use to trigger certain actions on smartthings if sound levels reach a minimum threshold ? I’m not being able to find one

Appreciate any hint

Fab


(Orange Scuba) #326

You might want to check out WebCoRE smartapp. If your not familiar with it then there is a bit of a learning curve. I use it for CO2 level alerts.


#327

You can also use the built in Smart Home Monitor for this. Create a custom rule, there you can select the sound sensor from the Netatmo module.


#328

Just press save, and then go back via automations (not marketplace) and try again once the smartapp is created. You can have livelog open and see if there is any messages there