SmartThings Community

[MODIFIED] Netatmo Weather Station

weather
smartapp_weather
dth_sensors
dth_weather
netatmo

(Joel W) #267

My outdoor module is less than 10 foot, but the rain or wind will be about 30 foot, line of site.


(Laurentiu S Pintilie) #268

Hello! I’ve tried to instal smartapp, all goes ok after credentials, until I try to edit devices: they are unavailable on the first attempt; only after I save app prefferences, but then when trying to save I get the error: Error saving page! regardless of the device I choose: both indoor or outdoor units.


#269

Can you see in the livelog when you do this?

Make sure you have set the location of your hub in the Smartthings app


(Laurentiu S Pintilie) #270

It was location of the hub, solved, thanks!


#271

Thanks for this device handler and app, working great.
Cheers


(Chris Irwin) #272

Thanks fir all your hard work on this. After several false starts I managed to get the Smartapp to run and have installed the device handlers too. the Smartapps yes them but they do not appear as Things to be added, so I cannot view the values at all. Do you have any idea why they do not appear when the Smartapp recognises them and lest me select both the base station and outdoor module? Earlier comments suggest that once selected in the smart app they should automatically appear in the Things list, but they do jot in my case. Neither searching for them or trying to add them manually works, so I am stuck. Any advice gratefully received.


(Joel W) #273

Did you select your Modules in the config file?


(Chris Irwin) #274

Thanks for your quick reply. Although an engineer by training I am new to this level of geeking to get stuff to work. I don’t know which config file you are referring to? If you mean the Smartapp, I have checked all the settings and there is not one for location. I also checked in the IDE but couldn’t find a file such as you refer to.


(Joel W) #275

After you installed the app and the device drivers, you created Netatmo Connect. That App is on your phone. When you open it in “Automation’s” you set up your devices in there.


(Chris Irwin) #276

Yes, I had already opened that and clicked the boxes to select the 2 devices I have, but the problem is they do not appear anywhere else in the Smartthings app so I can’t link them with a room or even view the temp and humidity parameters.


(Joel W) #277

So you don’t see them on your Things list in the App? If that is the case I have no idea!


(Chris Irwin) #278

Exactly, that’s the issue. It is baffling that they appear in the SmartApps, which implies the Device handlers are working, but they do not appear in the Things list. Thanks for your suggestions anyway. Maybe someone else will see the post and know how to fix it.


#279

In the IDE, click live log and have it open when you run through the process. Any errors in the app when you try to install it?

Make sure you have published the device handlers in the IDE

It should add the modules automatically.


(Chris Irwin) #280

I did as you suggested. I have an Evohome integration which works, so this sends data frequently. In between I saw the attached lines which look like they may be the problem but don’t mean much to me.


#281

If you click on Netatmo Connect at the top in the livelog, it will filter out only the Netatmo stuff.

Make sure you have OAuth enabled. double check your client I’d and secret are correct, make sure there are no spaces before or after the client id/secret. Try all the different server urls


(Chris Irwin) #282

Thanks, I really appreciate your help. I did previously check the Oauth as that was advice you gave to someone else on the Forum.

The logs seem to show it is communicating ok with the base station and outdoor module as values are being returned (I’m in Helsinki just now, which is probably why its showing 2 hours ahead on the timestamp). The house is in the UK though. I scrolled through the Netatmo log, but no errors showing.

Best regards Chris


#283

Can you have livelog open when you enter the Netatmo Connect app and select your modules and save.


(Chris Irwin) #284

Thanks for that tip. I found an error message which made me look again at the device handlers. I seem to have loaded a different version by a Brian Steer instead of yours. When I uninstalled those and loaded yours it worked fine,. Thank you so much. I notice that you have done some work to enable graphing using something called DBinflux. Where can I find the thread that provides instructions on how to make that work? As various people seem to keep modifying code that has been developed its quite hard to navigate the Community threads and Github to be sure to get the best version to use. Guess that is the nature of open source.
Than you again for your great work.
I’m now trying to find out how to link my Energyhive account that links to my Wattson. It seems from what I read that I could use a smartapp intended for Efergy but will ahve to hunt down how to do the mods…


#285

Have just followed the instructions for smartapp and DTH. However, when opening the ST app, nothing is showing up in Marketplace… Im also a newbie with smartthings, so I have no idea what I do wrong…


(Joel W) #286

Go to Marketplace>Smartapps>My Smartapps it should be there.