SmartThings Community

[MODIFIED] Netatmo Weather Station

weather
smartapp_weather
dth_sensors
dth_weather
netatmo

#206

Cool - OT, got family there :wink:

Just selected a random station. It appears in the smartapp, but when I choose it I still get an error.
I typed in all the informations, as well as the number of decibels before it detects the sound.

(Sorry if I’m polluting the thread with the error :smiley:)


(Nathan Parker) #207

Trying this myself. I installed the app and device handlers and logged into my Netamo account, but the app isn’t finding my two Netatmo sensors. What else do I need to do to bring them in? Thanks!


#208

Are the modules missing completly from the “Select devices” list?

Have you followed the installation process in the first post and added everything in the app settings?
Can you give me the log info from when you try to install the smartapp in the ST app?


#209

I have sent you a PM, we can take it from there :grinning:


(Nathan Parker) #210

They are missing completely from the Select Devices list. I did follow the installation process in the first post. I noticed over at Netatmo there’s a feature I may need to switch on that would allow data from Netatmo to flow into the custom app, but since it wasn’t mentioned in the install instructions, I didn’t do it yet. I’m not sure where to get the logs yet to send you, but you’re welcome to PM me if you want (or reply publicly here) and we’ll get it knocked out. Thanks!


#211

In the IDE, select live log while you open the Netatmo Connect app.

I’m not sure what feature you are talking about, but try it :grin:
Make sure your client ID and secret are correct in the app settings.

Also make sure you have given your station and all your modules a name in the Netatmo app.

Send me a screenshot of the live log, and we can see if there is any useful info there


(Nathan Parker) #212

Double checked the Netatmo feature, and it is the Scope feature. It is enabled for the station (it only needs manual enabling for a camera).

Here’s the live logs of everything and just the Netatmo app.


#213

Thank you. Looks like an authentication issue.

Looks like OAuth is enabled, can you confirm? What is the IDE address you used in the app settings?


(Nathan Parker) #214

OAuth looks enabled. I’m going to PM you a screenshot of it. The IDE address is: https://graph.api.smartthings.com.


(Jason "The Enabler" as deemed so by @Smart) #215

Do you have the camera’s working with this?


(Nathan Parker) #216

I don’t. I don’t even have the wind or rain sensors. Only outdoor and one indoor unit. Basically why I’m testing this with SmartThings is the following: I’m an IT consultant for Earth Networks. We used to own WeatherBug but we sold WeatherBug to GroundTruth (formerly xAd). We were launching a new program called WeatherBug Home where we were interfacing with SmartThings and Netatmo and other weather stuff for home automation, energy savings, etc., with weather data, and Earth Networks bought me a SmartThings hub and a bunch of sensors for my home plus the Netamo so I could track temperature across my home for them. After we sold WeatherBug, we re-branded WeatherBug Home “Connected Savings” and bought a new company Whisker Labs that also makes smart home sensors. We just spun off Whisker Labs into its own company, and Connected Savings will be a service they offer. Earth Networks will still play a major role with Whisker Labs providing weather data to them, and they’re still going to be in the same building as Earth Networks, plus much of Earth Networks top management went to work for them. I’m still consulting for the “mother ship” Earth Networks, although Whisker Labs is letting me continue to test SmartThings and Netamo for them plus any new stuff Whisker Labs develops in house.


#217

Thank you @MrRhubarb for being patient and providing me with all the information and logs so we where able to sort it out. I will do some changes so we can clearly see if someone has the same issue you had


#218

Hi, I have successfully connected my netatmo (I think…) but I can not see the weather station as a thing in my ST app. Do you have any idees?


#219

You have not installed or published the device handlers


(Jason "The Enabler" as deemed so by @Smart) #220

I’ve installed all of your code and it’s working great. It sees all of my add-on modules, base stations, wind and rain gauges.

It works great, thanks!


(Ulf Thomas) #221

Hi,

and thanks for the good work. :slight_smile:

I do have one peculiar situation: I am using webcore for my automation and it seems that main Netatmo module is only reporting integer temperature to Webcore. The temperature is showing properly in the ST client but when I assign the temperature to a value using Webcore it only shows as integer. (Even with decimal, or string as the variable type.

Any ideas on why this might be?


#222

Just did a quick test, it shows as decimal for me. Are you on the latest version of webcore and the Netatmo Connect app?


(Ulf Thomas) #223

Right you are, indeed. If I investigate the logs I can see that it does compare a decimal value.

I am trying to assign this decimal value to a variable but it only takes the integer part - any ideas why:

I do: x2 variable {CurrentTemp} = Sensor - name’s temperatur;


(Curly Tailed Buffalo) #224

I have noticed what seems to be a bug when trying to get a refreshToken.
In refreshToken()
I changed…
state.accessToken = data.access_token
to:
state.authToken = data.access_token

AND

I changed:
if ( !state.accessToken ) {
return false
}
to:
if ( !state.authToken ) {
return false
}
Before I made this change the app would throw errors whenever it tried to get a refresh token, now it works great.


(Aaron) #225

I followed all steps, can see my Netatmo devices on the ST app, but when I click “Save” on the “Choose Devices” screen I get a red “An unexpected error occurred.” Here is the debug from when I click “Save” on the app:

8786641a-6842-467a-82b0-f4811c1bc5f9 3:26:30 PM: debug lowBatteryHandler: Outdoor battery is 46%
62e28eba-0528-40ed-af01-c5067027d450 3:26:30 PM: error java.lang.NullPointerException
62e28eba-0528-40ed-af01-c5067027d450 3:26:30 PM: debug Updating Outdoor Module [time_utc:1515252238, temp_trend:up, Temperature:13.5, min_temp:10, Humidity:85, date_min_temp:1515242242, max_temp:14.5, date_max_temp:1515202007]
62e28eba-0528-40ed-af01-c5067027d450 3:26:30 PM: debug Refreshing station data
62e28eba-0528-40ed-af01-c5067027d450 3:26:30 PM: debug Polling
62e28eba-0528-40ed-af01-c5067027d450 3:26:30 PM: debug Delete: []
62e28eba-0528-40ed-af01-c5067027d450 3:26:30 PM: debug getChildDevices(false), children=2
62e28eba-0528-40ed-af01-c5067027d450 3:26:29 PM: debug Creating child
62e28eba-0528-40ed-af01-c5067027d450 3:26:29 PM: debug Creating child
62e28eba-0528-40ed-af01-c5067027d450 3:26:29 PM: debug In createChildDevice
62e28eba-0528-40ed-af01-c5067027d450 3:26:29 PM: debug Creating Base station
62e28eba-0528-40ed-af01-c5067027d450 3:26:29 PM: debug In createChildDevice
62e28eba-0528-40ed-af01-c5067027d450 3:26:29 PM: debug Creating Outdoor module
62e28eba-0528-40ed-af01-c5067027d450 3:26:28 PM: debug Initialized with settings: [windUnits:kph, time:12, devices:[02:00:00:01:36:5e, 70:ee:50:01:27:c6], pressUnits:mbar, rainUnits:mm]
62e28eba-0528-40ed-af01-c5067027d450 3:26:28 PM: debug Refreshing station data
62e28eba-0528-40ed-af01-c5067027d450 3:26:28 PM: debug Installed with settings: [windUnits:kph, time:12, devices:[02:00:00:01:36:5e, 70:ee:50:01:27:c6], pressUnits:mbar, rainUnits:mm]
88a77cb4-7a71-4ef0-876a-0d172496749c 3:26:30 PM: debug Parsing 'updated’
62dee4e2-7298-4364-a8da-9b551099bd0e 3:26:29 PM: debug Parsing ‘updated’