SmartThings Community

[MODIFIED] Netatmo Weather Station



Ok, thank you for the information


I have now had the time to test on an Samsung S8.

It turns out that if the “serverUrl” is not entered correctly or is the wrong address, you will get the webview error.
If its correct it worked just fine on the S8

Just follow the installation instructions carefully in the first post and try the different url’s in the app settings if its not working

Is Netatmo Integration ever going to be fixed?

Hi there!

I just received my Netatmo Weather Station and I’ve followed the installation notes from the top of the page, but… How do I actually add the basestation and outdoor module to my hub?

Thanks in advance :blush:

(Bobby) #189

Install the app and devices in ide (app under apps and devices under device handlers). Then go to mobile app and run the Netatmo Connect. That should discover and install your devices. More details aboit installation are in the first post of this thread…


Thanks for the quick reply! I did the exact thing. Installed the app and the handlers, but after I connect to Netatmo via the smartapp I’m not able to save when I’ve chosen my base and outdoor module. It just gives me an error message:

“Error saving page”

(Bobby) #191

Are you accessing from SmartApps tab or directly from Marketplace?

First click done in Marketplace, then go to SmartApps tab, under automations


Did that. Just took at look at the live log while trying to save. Looks like I’m getting infomation, but had an error (I’m NO expert :wink: )

(Bobby) #193

Hmmm, a variable is null. That can be a lot of things. Did you install the outdoor unit device handler too? I am throwing ideas.


I’ve installed both. Thanks for helping me out :slight_smile:

(Bobby) #195

Do you have all the preferences populated? Try going in each one and manually select your preference…


Yes. Just tried to populate all fields except the modules and then I don’t get an error, but when I choose any of the modules, it won’t save

(Bobby) #197

And you are doing this from the Automation page, not Marketplace, right? Can u post the logs of the connect app after u click save?


Yes, I’m doing it from the Automation page.


Can you just select your basestation and try again?


And try just selecting your outdoor module. I see that the pressure trend parameter from you basestation is missing in one of your screenshots. Rebooting your Netatmo station sometimes helps if it’s not providing all the parameters


Also make sure in the settings of your Netatmo app that you have given all you modules a name


Have tried only pressing save while choosing the indoor module. I also did a reboot and the trend looks like appearing in the log now:
(Saving while choosing the indoor module only)

(Saving while choosing the outdoor module only)

Both my modules have names and they are both shown in the config part of the smartapp - I just can’t save :confused:


Are you sure you have saved and published all the device handlers from me?
I see all your logs only has one child device

You can update to the latest version of the smartapp, it has some additional log info


Yes - I just removed all the handlers and the app again. Rebooted the hub and all the modules. Followed your instruction from the top of the page. I’m pretty sure I’m doing it correctly. Here’s the new log:

Could there be an issue with my location or something?
I live in Denmark, using a UK hub and my Netatmo is registered to my address in Denmark. Not sure if it’s relevant :wink:

I can see all my modules via the Netatmo app


I have the same setup as you, but in Norway :smile:

Can you do a test for me? Go to weather map in the Netatmo app. Find a random station and select it as a favorite.

Go back to the ST app and when selecting what modules to install, only select a module from the recently created favorite