Missing Driver menu from Detail View

Since 47.x, I am missing Driver menu from Detail View.
Currently, I am at 47.11

I know this device is using my driver.
I have 2 almost identical drivers… main and beta.
Sometimes I need to change from main to beta and vice-versa.
Without the Driver menu, I don’t know how to retrieve details about the driver or how to switch it.

Is there something new that I must add in the source code of the driver to make the menu visible again ?

Have you tried clearing app cache?

Yes. The only thing I didn’t try was unistalling the app.
But I cleared all data.

use the community developed tool: API Browser+ to verify the driver is being used for the device. I have seen a few others report devices switched from Edge driver to DTH. Not sure if that may be the issue.

The “Debug” capability I added showed in the screenshot is the confirmation it is using my driver.
Also, I monitored the logs from smartthings-cli and the device is communicating with the right driver.

Hi @w35l3y

Sometimes, when opening a device, the complete menu does not appear, the driver or settings are missing, but I close and open the device again and all the options appear.

It looks like something from the Android app.

also sometimes all the capabilities are left without information and hanging around as if waiting for the information and it is also necessary to close and reopen the device

I noticed that too before 47.x
Since then, I have opened/closed app, cleared all data (not only cache), turned on/off mobile, … nothing made Driver menu appear again.

I will uninstall and reinstall the app.

Hi, @w35l3y
Is this a normal device or a type “EDGE_CHILD”?
Also, are you the owner of the device? It means the Hub belongs to your account and you installed the device as well.

Could you please confirm if it is a new requirement since 47.x or any of the latest APP updates ?

Because it is the same device, same hub, same driver and same accounts associated since very beginning.
I used to test my driver with this device at least since Jun 2022 (43.x).

It is a normal zigbee device.

And yes, my hub is associated to an account and my mobile is associated to another, but it has been that way since ± Oct 2019.

Ps.: I am mentioning API version, but it might not have anything to do with the API, but the APP version. I don’t know what was the last version I was using before

I don’t have information about this. My questions were based on some reports I found about the “Driver” menu being missing.
I asked the team in one of them what is the status since you’re seeing it. Once I get their feedback, I’ll let you know. It would be useful if you could check if using the account where the Hub was claimed helps, if not, the issue could be somewhere else.

I tried. The problem is that my mobile and the hub only accept 1 samsung account. If I change the account, I probably will need to lose everything.

ok, don’t worry, let’s wait for the response from the team.

I don’t know if you saw that Todd Austin’s tool helps you to change the driver of a device, I’ve seen some people use it, not sure if it works completely correctly, but I haven’t seen complaints.
This is just in case you need to change the driver urgently.

1 Like

I remembered I have a tablet that is connected to the same account as the hub. I hardly use it, it is for my children.

And yeah… the Driver menu showed there.

Before updating app… the interesting part is that the zigbee device weren’t showing in the list of “Connected devices” on the tablet but it was showing on the mobile.

After updating app... I paired the device from the mobile and tablet. In both cases, the Driver menu only showed on the tablet using this new version

It seems before that version, Driver menu were being shown independently of the account.

So the question is: any chance to also make it visible to the device that was used to start the pairing process as it used to be?

I will try that tomorrow. Thanks!