Mira: Hubitat to SmartThings hub integration Edge driver

Mira is also my wife’s name - this is one more reason to be a fan if this app! : )


Hue Motion Sensor (Device) + Advanced Hue Bridge Intergration (Hubitat apps) → ST (temperature sensor)

temperature erroor …

I assume the 21.7 on the Hubitat side is in C? You didn’t specify.

What is your Mira Device->Settings->Default Temperature Unit set to? It should be set to whatever your default Hubitat temperature unit is set to, as HE doesn’t send units over to Mira. It defaults to F, which would mean its interpreting HE’s value of 21.7 as 21.7F, or -5.7C.

1 Like

Any help appreciated - Point me right! I tried to add the Mira-Hubitat edge driver. When my smartthings app finds the device it appears in a list that pops up after I scan nearby devices, that says “Automatially added to Home Hub” at the top of the section it and one other driver are in. In the same rectangular area that is the width of my phone, in the lower right I see the word “rename”. If I click that it allows me to rename then when I hit done, it goes back to the same screen. Other devices show under a heading that says “Available Devices” and these have the word “Add” in the lower right, instead of rename. If I click add, these get added to the no room assigned room, but the Mira-Hubitat device is never added to any room, and I never see the square icon that I can click on to open it up and click the 3 dot menu. The very first time I tried this it did work, but when I did everything, no devices were mirrored from the hubitat hub. I chose only 4 or 5 basic z-wave devices in the make API app. I then deleted the icon, went back to where you add the driver and uninstalled it. Ever since then it will re-install and be found by scan device as described above… I cannot get it back as an Icon in a room? What am I doing wrong?

When doing Scan Nearby… The Mira - Hubitat Hub device is added to the room where your Home Hub is located. ST used to add devices to the No Room Assigned room, but that changed sometime last month.

That is the only room I have (no room assigned) except for personal devices which is just a bunch of bluetooth devices paired to my phone. Everything is on the Hubitat Hub, nothing is on the smartthings hub right now. Since I absolutely hate the Hubitat dashboard, I was hoping to control the majority of my devices from the smartthings interface, but as stated I cannot get the mira icon to add

Not sure why it won’t add. No one else has reported this issue.

  • Subscribe to the channel
  • Add driver to Hub
  • Use +, Scan Nearby to pick up LAN devices, Mira included.
  • Mira - Hubitat Hub device will be added to in the same room as your ST hub is.
  • Configure the Mira - Hubitat Hub device as directed in the documentation.


Well, like I said it added the first time, but then because it never found and of the devices on my hubitat, I decided it must have installed incorrectly, so I removed it in the ST app, then uninstalled it, then reinstalled and ever since then, I cannot get it back. It only comes up as a device that will automatically get installed on my hub, never has an ADD button when I search for it and it finds it. Because of this I can never get the icon/tile whatever you call it with the 3 dot menu. Is there a way to clean everything out of the ST hub? Like just have everything removed and start fresh? Like I said I literally have no devices at all in the old IDE ST interface, but the new edge drivers I gather do not use that. Is there any place comparable to the IDE to look at for the edge drivers where I can force remove everything? The only thing I can think of is that I must have deleted it incorrectly and then the uninstall/reinstall messed up (although it said it was gone). I do remember the first time I installed it it took almost a minute, but subsequent uninstalls and reinstalls are done in like 5 seconds, literally. Any tips appreciated

I’m not sure why you’re having issues. If you delete the Mira device and go to Scan Nearby again, it will be discovered and added again, as long as the driver is installed.

You can go to the Drivers tab on your Hub’s device entry. You can manage the drivers and channels that are subscribed to your hub there.

I finally got it to show up again. Not sure why but here is what I did, Uninstalled your mira edge driver, then deleted everything else in my hub and any devices that were in rooms on my ST app, then deleted the ST app, rebooted my ST hub, then reinstalled the ST app, reinstalled the mira edge driver and then searched for nearby devices, same problem, driver was found in the initial list but no add button and it did not show up in any room… Repeated the above process, same problem. Repeated this 2 more times and on the 4th try, it worked. I have no idea why or what made it work, and I don’t really care as it appears to be working correctly now. Thanks for the help you gave and for replying earlier. Oh one more thing, the very 1st time when it initially loaded and worked before I had the issues, I did not specify the IP address of the ST hub, when configuring the mira device, didn’t think I had to do so, that was the time no devices came over from Hubitat. This time I specified that IP address and all the devices in the maker api came over

Glad you got it figured out! No idea why it was so problematic.

You don’t have to specify the IP address of the ST Hub in the Settings, as Mira will get and send the ST Hub IP address to Hubitat (you can view the value in the Maker API configuration settings.)
You’d only do this if you want to specify a DNS resolvable hostname that HE can resolve.

Could something like this be done with home assistant?

Thanks. This is a great piece of work! The only thing I hated about Hubitat was the dashboard. I don’t need custom, I needed functionality which the Smartthings app gives me (snap to grid etc.). Anyway, quick question (I really don’t know how all this works, so if this is stupid, I apologize). If I decide I need to delete some devices in the maker API, will they automatically delete themselves in the mirrored Smartthings app when I do a refresh on the Mira device page? If not, what is the proper process for deleting them? Do I delete each mirrored device in Smartthings manually, then go to Hubitat and remove them from the maker API? I would not want them being mirrored again accidently if I refreshed the Mira device page at some point, but I may well want them back at some point. I am thinking of all my Christmas devices, that are only used during the Holiday. I don’t need them in the Smartthings app at this time. Thanks. Lastly, do you have PayPal or Venmo where we can donate. I would hate to now, NOT have this Mira device should ST decide to break it! Thanks again,

Sure, it could be integrated. That’s a project for later this spring or summer.

Thats exactly why I built Mira. Much higher WAF and we already were used to the ST app.

A device (like the Mira device) in ST can’t delete other devices directly so you’d have to delete them manually (the caveat is that if you delete the Mira Hub device all of its child devices will be deleted). So you’d:

  • Go into Maker API on Hubitat and remove any devices you no longer want mirrored.
  • At this point, the device on the ST side is abandoned and will no longer get updates.
  • Remove the ST side device manually (press and hold on the tile screen and choose Delete).

Sure, if you’d like to support the project, you can Buy Me A Coffee. Thanks!

1 Like

Can this work with netatmo weather station ?

What capabilities does the driver on the HE side provide? If its temperature sensor and relative humidity sensor then Mira will reflect those just fine.

Excellent work! I do have a request to support the GoControl Garage Door Opener. It has both an “Open/Close” request (like opening a door) and a current door state (Open/Closed).

Z-Wave Garage Door Opener Remote Controller Accessory - GD00Z-4 (gocontrol.com)

After setting this up, I now see that while I can turn a hubitat device/light ON in the smartthings interface, I cannot turn it OFF in that interface. Also when it turns ON, the smartthings interface icon spins for a while but when it stops it does not show the device as being ON, it still shows it as OFF even though the light is on. Is this normal or do I need some other driver installed in hubitat or smartthings that will allow the state of a light/switch/device to sync? The only thing I installed was the edge driver in smartthings. Lastly, I am correct to assume that this mirroring only works locally, in other words even though my ST hub is connected to my cloud account, I cannot control my hubitat devices when my phone is not connected to my local network? Thanks

I’ve been noticing that SmartThings has been slow to reflect state changes for devices over the last few days.

It will show a light or switch is on when it’s actually off.

If its syncing for one change it should sync for the other.

Mira is bidirectional with HE. Any change in one should be reflected in the other using the local interface. Of course if you use the ST app, you’re using the app->cloud->ST Hub->(local) HE Hub. Any delays thru the ST cloud I can’t do anything about.

the hubs communicate locally. if you’re using the ST app, thats thru the cloud but once it reaches the ST hub it syncs with HE locally.