Migration to V2 - Hurdles and Best Practices

I don’t need a smart app. I just need the Routines to allow garage doors. It already functions correctly by allowing me to open/close and showing open/closed state based on the tilt sensor. The limitation at this point is with the Routines. Thanks again for the help with getting it paired to the new hub. I had no idea about pressing the button 5 times to exclude. Later.

I think I’m missing something even after reading the thread. In my V1 setup, my tilt sensor and garage door opener were always separate. I used one to confirm the other. Was there something better I missed? Or am I not understanding completely.

Right now I can still control my door and see it’s status. I use the MyQ @copyninja made and an Ecolink tilt.

Yes, a shortcut button that reported status and when touched would open or close the door.

1 Like

Aha, I didn’t know that existed. Darn. And I see that routines doesn’t do this either. Ok now I understand.

If you have MyQ using @copyninja’s integration you didn’t miss anything. For you it’s business as usual with v2. However for those of us who used relays, it’s a big loss. Luckily for me, I’ve had a MyQ hibernating on the ceiling wall of my garage. Just installed @copyninja’s app and I now have the garage door opening on presence again! This is a prime example of how different and so much better ST is than anything that’s available on today’s HA market. If you want something to make it work and is not officially offered, leave it to the community to find a workaround…(because ST is that flexible and the community is that smart!)

3 Likes

@tripster3 You can use this Smart Device for the GD00Z to use with standard ST routines:

1 Like

Holy cow! I just spent all day removing and adding my devices and all I got was reduced functionality.

  • No doors in Dashboard (including garage doors).
  • No Light groups in dashboard.
  • Can No longer use GE Remote 45600.

Had I known of these issues, I would have never “upgraded”. BIG OOPS!!!

5 Likes

No doors in Dashboard (including garage doors).
No Light groups in dashboard.

ST was upfront about these.

No, to my knowledge it was not “up front” information.

I would call myself a decently informed customer. If I didn’t know I was not going to be able to re-add a garage, I doubt the average customer would.

2 Likes

I didn’t know about the garage device issue, but I knew about the others. I knew it before migrating.

Have you confirmed if this is a problem in the new mobile App V2, or with Hub V2?

Keep in mind that you can (for the time being), run App V1 even with the new Hub (and vice versa).

1 Like

Yeah, I grabbed a 1.7.6 apk from the interwebs and it looks like they removed the option server side. I know I was able to do it before on that version.

Awww man, I thought I was doing something wrong. I tried resetting the remote, and re-adding it. nothing. Was there a post that says this is borked? This was the only way i could control my lights when the internet went down.

When i try and add it to the new hub, the light on the remote blinks green rapidly for a few seconds, and then acts like its pairing, the green light on the hub flashes once or twice, but the device never shows up in the “add new device” section.

My V2 Hub works fine with my GD00Z Linear Garage Door.
It’s in my dashboard and can be controlled as a door.
I have it notifying me when it is opened and closed.
I have it notifying me if left open for more than 30min.

I am using my version of the device code which I have moved to the new IDE standard github repo.

Ron, did you migrate from V1? I think the behavior for those who migrate from V1 is different than those who are starting with V2. I am coming from Vera and V2 in my first attempt with Smartthings. The dashboard, for me, is empty and there is nothing I can do to add anything to it.
For the Garage door, I would be willing to purchase the GD00Z if I knew for sure it would provide all the functionality you mentioned with a new V2 setup.

I probably only have about 30 devices, if that, mostly motion sensors and ge link bulbs with a couple of different sirens, open/close sensors, and multisensors plus one water sensor. Oh yeah, presence sensors and a phone acting as a presence sensor.

Since about 80% of my stuff is motion sensors (mostly ST) and GE Link bulbs, and I’ve already removed all my smart apps but two (two instances of the same security app), doesn’t that sound like a pretty easy migration? I know ‘easy’ is a loaded term, but shouldn’t I be able to delete and add all the ge link bulbs without getting on a ladder (many are flood lights)? Since those and most of my other things are zigbee, doesn’t that make them a little less prone to the common issues people are having?

My biggest things accomplished with v1 were 4 things:

  1. Have an alarm app run when I switched to night mode. Any motion sensor or door sensor listed in the app, if triggered, set off sirens.

  2. The same app (a seperate instance of it) also triggered in night mode. If one particular door sensor is triggered, a light comes on and the mode is switched to home (which cuts off the alarm).

  3. Various motion triggering lights inside house.

  4. Flood lights triggered at sun down and off at sunrise.

The other things were minor: one button to turn on multiple link bulbs.

Does any of this scream out as a problem?

Thanks!

I have been trying to exclude all my devices for the last few days. I finally got all but my LFM-20 excluded. I researched and it appears you need to press the button 4 times and hold on the forth time while you place it in exclude mode in the phone app. I tried for over an hour with no success. I gave up and decided to move everything else I have to v2 hub. It started out pretty good as I went around the house turning switches on as the app would pick up the new devices. It got up to four and I thought I’d save what I have and continue later on. The next step was to press Next on the top right corner and each time I did the app would tell me an unknown error occurred. So, now I’m stuck. I can’t continue. Tried for several minutes but received the same error. My only option was to go back and start over. Now my 4 devices that had previously successfully connected are no longer able to connect after starting the hub over. I was able to connect other devices and get past the point I was previously stuck at but now I have no idea how to connect those remaining 4 devices. Apparently they are in limbo… included in a none existing hub. How do I now exclude them? They were 2 wall switches one of which was a dimmer and the other two were the original smartthings multi sensors. I try to add them by turning them on/off but the app never picks them up. Still don’t know how I’ll get my garage door LFM-20 to ever work again. This process is very frustrating… then I read where I’ll be losing functionality from v1 hub. It almost appears I was purposefully screwed.

Maybe go to the IDE and look behind the scenes at what your devices look like. It’s not as scary as it sounds. You can tell what your hubs are doing: SmartThings IDE

Also, you should just be able to re-exclude and include them, that’s what I would do. Make sure only your V2 hub is powered.

Worst case scenario connect to support with URGENT in the ticket, or HOUSE DOWN. :smile:

PS: When I have gotten that unknown error, I have basically ignored it for a few minutes and been fine, or occasionally just force close the app, and restart it. It always seems to go away, sometimes it takes a few minutes for the cloud to catch up. It hasn’t happened often to me.

Hope that helps.

1 Like

I’m getting ready to move my devices to a V2 hub. I did a little searching on the question before posting but couldn’t find the answer. I believe I read this in the CNET article review of the new V2 hub that was published the other day, in the comments section - that devices can be moved to a new location?

I believe the idea is that you create a new location, move devices from the old location to the new location, re-create smartapps/schedules, etc. - Seems like this would be an easy way to migrate. Is this possible?

Well, when I initially excluded I went to the device in my app, pressed Remove and it stated I can now do whatever was necessary to exclude the device, push a button or what have you. Since it is no longer accessible as a device since it has been included in a non-visible v2 hub, I cannot select it for removal. Seems this type of thing happens often when someone buys used equipment that is still included on another host. Must be some way to exclude a device that you have physical access to.