Migration from Classic appears to have hosed the Monitor

I have the SmartThings 2nd gen hub purchased in 2017. I have a motion sensor and multipurpose sensor, plus integration with 4 Arlo Pro cameras for outside.

After migration, my new app’s SmartThing’s Security Monitor no longer arms or disarms the cameras. I can create a scene that turns them off and on, but that’s not what I want. I want JUST the following in the Security Monitor:

  1. Turn on all 4 cameras and the two sensors, and tell me if they are triggered through a push (Armed, Away).
  2. Turn on Multipurpose sensor only, and push if it’s triggered (Armed, Home)
  3. Disarm the cameras and don’t push either sensor if triggered.

I’m guessing the Arlo/SmartThings integration has gone south once again.

I can create scenes to turn the cameras off and on just fine, but since scenes can’t control the sensors, I can’t fully go that route.

I tried going back to SmartThings Classic, but all I get is a weird migration error that doesn’t tell me what’s wrong, and the SmartThings Security Monitor no longer works there either.

Fun…next steps anyone? Should I just delete everything and start over?

1 Like

@Boss281, have you found the SmartThings Home Monitor settings yet? When you open the STHM smartapp, you will see a cog at the top right corner. This is where you can control which cameras/sensors you want to be notified about. At the moment, I have 3 sections… Security, Smoke, & Leaks. Cameras and multipurpose sensors will be under Security. You can set them differently for Away and Stay modes. Disarm stops them completely.

I don’t use Arlo cameras, I use Ring and my cameras are listed.
I do use multipurpose sensors and they are all listed also.

My notifications have been working great so far. If someone enters my home when it is set to Away mode, I start getting bombarded with notifications from the multipurpose sensors, indoor camera sensors and other motion sensors I have set in the STHM settings (this is what I want to happen.) The only movement I monitor in Stay mode is the multipurpose sensors on a few of my exterior doors and my outside cameras.

1 Like

I have the smartthings Home Monitor migrated fine but it DOESN’T turn off or on the cameras, just the smartthings motion sensor and multipurpose sensor. BUT, if I create a scene to turn off the cameras, it works fine. However, scenes can’t control the two sensors.

In order to “secure” my house at night, i.e., both sensors and cameras ON, I must go to the Home Monitor and ARM the system, then use the scene to turn on the cameras.

It’s also weird that if the motion sensor is triggered, I get notification triggers for all 4 cameras. Annoying as all get out.

Definitely do not delete and start over. By default, routines and I believe SHM in the Classic app are disabled for new accounts or for those resetting . Plus the Classic app is going to be phased out in the coming months.

There are actually a few ways this can be done, these are just a couple off the top of my head:

  1. Create an Automation that runs the scene when STHM is armed. (This will be the 1 tap within the app to arm STHM.)

  2. If you are using an Asleep location made, you can…

  • Create a scene that changes the location’s mode (to Asleep) and turns your cameras off.
  • Then create an Automation that says IF location mode = Asleep (Precondition not toggled) THEN Change security mode to Armed.
  1. Create a virtual switch and use it in an automation to trigger STHM and scenes.
    This is actually what I do, because I can use it in my Alexa “Goodnight” and “Good Morning” routines. When I tell Alexa “goodnight”, the virtual switch is turned ON… STHM gets set to Armed-away and my bedtime scene runs. When I tell Alexa “good morning”, the virtual switch is turned OFF… STHM gets Disarmed and my wakeup scene runs. I can also use the virtual switch to customize motion lighting in the Smart Lighting SmartApp.

The advantage to the 2nd one is that you can tap it in the Widgets section of your phone without even opening the SmartThings app.

1 Like

Ahh, so in addition to my default Home location, create a new one just for being Asleep (or arm it anytime I want). I created two automations for turning on STHM and All Cameras, and a second one with turning the STHM and camera off. Strange, in my hands, withing the app, I can find no way to trigger either one.

But, I’ll try #2 above, since putting that on a widget would really work for me.

1 Like

So here is how I do it:

Create Good Night Scene that triggers cameras on and locks closed, etc. That scene also changes location mode to Night.

Automation that changes STHM to Armed (Stay) when location mode is Night.

Create Good Morning scene that triggers cameras off and some lamps on. That scene also changes location mode to Home.

Automation that changes STHM to Disarmed when location mode is Home.

Create Away scene that when all presence sensors (via Life360 or ST presence sensors) are away, it triggers cameras on and lights off/locks locked. That scene also changes the location mode to Away.

Automation that changes STHM to Armed (away) when location model is Away.

Create Back scene that when any presence sensors (via Life360 or ST presence sensors) are home, it triggers cameras of and lights on. That scene also changes the location mode to Away. (I split this into Back Night and Back Day so lights/brightness are time dependent).

Automation that changes STHM to Disarmed when location model is Home is already created above, so no need to duplicate.

Remember, in the new app Scenes are STATIC and Automations are DYNAMIC.

Last point, I sure wish Scenes could set STHM. That would eliminate a lot of the above work.

Edit: I never did specifically tell you how to automate your Night/Morning, but that can be done by adding a condition of your choosing (someone is home and time is 10pm, switch turns off, etc.) to the IF portion of an automation that THEN does the scene and the STHM control. Morning can be done with first inside motion and time is between 5a and 8a or something (thats how I do it).