Migrating Leviton DZS15 from Wink to Smartthings

I have a lot of Leviton DZS15; I disconnected them from WINK hub and then reset the switch itself by pressing up on it to have the switch itself pop out, pressed the bottom part back into its shell, then kept it pressed down of 15 seconds … then I tried to integrate into SmartThings … could someone please give me a step by step tutorial exactly how to get it to successfully pair with the Smarthings hub. All I get is errors.
Too many steps, too many questions … then fail. Thank you in advance!

Did the LED turn amber and then flash red? If not, it wasn’t reset and you should try the procedure again.

Are you using the Classic SmartThings app or the new one?

How far is the switch from your hub and what type of walls, appliances, etc are between the switch and the hub?

It did go amber then flash red. Yes.
I downloaded the app yesterday … Version 1.7.40-21
Distance … for this switch is about 10 feet with one layer of drywall in the way.
WHen I go to add Device, I choose Leviton, then Switch / Dimmer … then it asks

  • Leviton
  • Leviton Decora Wifi
  • Leviton Z-Wave
  • Leviton Zigbee

I am choosing Z-Wave, right?
But then it says to press for 7 seconds til it light amber. Release it then press it once so that cannot be the correct option?

After you go to Add Device, there is a Scan button at the top right.

Tap that, then put the switch into inclusion mode by holding the top paddle for seven seconds (until blinking amber)

Then tap upper paddle once. LED should flash green.

Next you should see three green blinks on the switch and the app will show it has located the switch.

For some reason the process isn’t documented in the DZS15 manual. It’s in the DZ6HD dimmer instructions in good detail.

Also, in less detail here

Not quite. On this switch there is no upper switch, only the “lower” one?
Different model?

Ok, I tried this scan … thing. It didn’t find the device but I’m not sure I’m synching my actions correctly.

Exactly WHERE / WHEN in this sequence should I hit the scan button ???

A. I press the top of the switch to have its “shell” open up from bottom.
B. I press the shell back into position and let it seat
C. I keep the switch pressed down for 10 seconds. The LED turns amber.
D. I keep it pressed and it starts flashing red.

What next?
Do I scan after C? D?
Do I release the switch?
Tried all combinations and am not getting the scan.
You’ll hear me scream with JOY when I get the first switch on the network from there!

Thanks for all your replies so far!

In @HalD sequence above he is referring to the top paddle on the switch…the “on” paddle that you would normally press to turn the light on.

It sounds to me that you excluded the switch from Wink. I would start the @HalD sequence in the post above again, step by step, using the top paddle on the switch.

In addition to the SmartThings support site listed above it might also help you to review the Leviton installation manual…It is included on Leviton’s website. Just google Leviton DZ15S. When you google it you will also find some YouTube videos on including the DZ15S to SmartThings. These might help you also.

Wrong switch Sakman!

The model is DZMX1 - 15A
the other is the (matching???) DZS15
Neither have a top switch. Both are only push on push off at the bottom.

Sorry…I dont have any experience with the DZMX1

Thanks all the same.

My advice is all based on the title of the thread and the mention in your first post. Both places you mention DZS15 as the model of your switch.

I’ve got two of those. They are Decora-type paddle switches with an upper and lower paddle. They are switches, not dimmers.

Since you don’t seem to have the switch models you named, you can ignore my posts on this thread.

Perhaps Google will locate instructions detailed enough for you to follow. Or contact Leviton support.

They are one and the same. I think one is the slave to the host in a three way circuit?
Oh wait, one is a dimmer, one is on/off.
Otherwise it is the same switch.
The DZS15 seems to be the prefix. The 15A suffix is not helping.

Neither are paddle switches.
Problem is … does one call Samsung or Leviton?

If it is a z-wave model, you need to exclude it. Go to https://support.smartthings.com and look up how to perform a general exclusion

Ok, I did all that. Got an error: No devices were deleted.
Or do I have to put the device itself into a certain mode before doing that?

The device needs to be in pairing mode while running the exclusion

One of the online manuals for the Leviton DZS15 says that factory reset does not remove the device from the “controller”. If your Wink hub is still online, that may be part of your problem.

If your Wink hub is powered off, then the switch may still remember the association. In that case, I suggest doing a factory reset again and then excluding the switch.

Put your SmartThings hub into general exclusion mode, then use the Leviton instruction sheet (link below) for Exclusion From a Z-wave Network.

Or call Leviton support.

The Leviton DZS15 is a Decora style switch. The thing you press to use the switch is called a paddle.

Yes, there’s only one paddle. It’s common to say “top paddle” and “bottom paddle” even though the more correct usage would be “top of the paddle” and “bottom of the paddle”

I called Leviton support. Got one working. Then two.
Then hit a brick wall.
Called them back … 3rd working. Then hung up and 4th fails. Of course.


Can you please advise the steps you took to get it to work?

Welcome Rohit.

All you have to do is factory reset the switch and then in Smartthings click the add device button and then scan nearby and then put the switch in pairing mode . Both factory reset and pairing mode instructions are in the link below. Start at the factory reset steps if you have not tried including it in SmartThings yet.


1 Like

As with any Z-wave device that’s been previously connected to anything, it’s a good idea to attempt a general exclusion of the device before trying to pair

1 Like