Migrating from Revolv to Hub v2


(JP) #1

Current Revolv user with integration to Hue, Sonos, Nest, and Z-Wave switches (GE/Jasco) … and yesterday received the Hub v2. First impressions with setup not as clean as Revolv, but Revolv is a dead end and looking forward to the automation capabilities with ST.

The big concern — thus far I have not been able to add ANY of my devices to the hub. I believe this may be because they are all currently attached to the Revolv hub. Unfortunately Revolv only provided a way to “hide” devices, not remove them. I’m sure this has been solved and have searched, but yet to find an answer … plus chat support has been overloaded all day. Advice and guidance appreciated!

J


(Tamara) #2

For the Z-wave devices, you can exclude them using the ST hub, even if they weren’t paired to it. Then you should be able to complete the pairing.


(JP) #3

I’ve tried that a few times with no luck yet - all still attached to Revolve. Evenue moved an Aeotec Repeater within 2 feet of the Hub v2 without luck

Thanks for the quick feedback!.


(Tamara) #4

Hmm. Are all your z-wave devices in-wall switches or is there any that can be moved near the hub to test?


#5

Do you receive confirmation in the app that the Exclusion is successful? If not, you haven’t completed the Exclusion step and need to complete this before being able to join the devices to SmartThings.


(JP) #6

No, nothing is excluding. I know that’s the step but it’s simply not excluding. Even with the hub 2 feet away.

Perhaps a related question - My Hub is not showing “offline” but the LEDs are solid blue. I’m investigating now how to open 11111, 9443, 443, and the NTP port (123) on Apple Extreme.


(JP) #7

That’s why I tried the Aeotec repeater - its a simple plug in device that I put in the same outlet as the Hub itself


(JP) #8

Thanks Tyler, I have not. but have tried three different device types.

I’m reading the following thread and seem to have similar problems to some others.

Solid blue lights, can’t remove/add devices, but shows up in
https://graph.api.smartthings.com/hub/show/c9922119-e109-4cda-86aa-4530706baa33

The following reply in the thread is my next attempt: Make sense?

Matt

3d

1 

Anyone still having trouble, I understand your frustration. Here is what I did. I’ve gotten things rebuilt to about 90% on V2. I still have a few things left to configure yet.

Unplug Your Hub and remove the batteries
Login to the IDE, remove all devices, hubs, locations, the devices you should really remove via the exclude process or you’ll have more work adding them back. (This will clear your 1 time use code)
Close your SmarThings App (you may need to force close)
Setup your router firewall rules per above (FWD Ports 37, 9443, 11111, 39500 to your ST hub)
Plug In your hub to power and ethernet (I did not put batteries back in yet)
Open SmartThings App (you may need to login)
Add a hub using your 1 time use code

If after all that you get stuck on the SmartThings app of please wait and the light on your hub is stays blue.

Login to the IDE and verify if your hub and location are listed again, if they are then close the SmartThings app and walk away for a couple hours. Leave everything else as you just did in the above steps. If they are not in the IDE repeat the above steps until they are.

Once the lights on your hub turn green you should be able to start adding your devices.

If when you removed your zwave devices from hub v1 they were not excluded you may have issues getting them added. You will need to use the general exclude option and run they process for exclude on your device. (This will vary per device)

I can’t promise this will work, or that all steps are necessary but this is what worked for me.

Good Luck!


(JP) #9

So … maybe the secret is patience. Sometime overnight … at least 10 hours since I last looked at it … the hub went from solid blue to solid green. And now I can add devices. So far so good.